GDM can't play sounds with spaces in the name

Bug #281518 reported by Antonio Salazar on 2008-10-10
2
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gdm

I'm testing Ubuntu 8.10. The package currently installed is gdm 2.20.8-0ubuntu2.

The problem lies in the /usr/lib/gdmplay script, which uses an unquoted file name.

Original source:
#!/bin/sh
/usr/bin/aplay -q -N $@ 2> /dev/null

Changed source:
#!/bin/sh
/usr/bin/aplay -q -N "$@" 2> /dev/null

I tested the change, and now it plays all sounds correctly. I hope I attached the patch correctly.

Tags: gdm Edit Tag help

Related branches

Antonio Salazar (asalazarmx) wrote :
description: updated
Sebastien Bacher (seb128) wrote :

thank you for your bug report

Changed in gdm:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdm - 2.20.8-0ubuntu6

---------------
gdm (2.20.8-0ubuntu6) jaunty; urgency=low

  * debian/control.in:
    - don't depends on xbase-clients the depends workarounded an old xorg issue
    - don't recommends ubuntu-sounds since it is installed by default on ubuntu
      use a suggests and let other distribution install it or not (lp: #260558)
    - recommends alsa-utils rather than depends on it, only gdmplay it using it
      which is not something required to use the login screen (lp: #293075)
  * debian/gdm.init:
    - use w argument to match only the "text" word (lp: #294980)
  * debian/gdmplay:
    - update to fix quoting issue, Antonio Salazar suggested the change
      (lp: #281518)
  * debian/patches/11_powermanagement.patch:
    - "Don't offer hibernate option if no swap partitions exist.
       LP: #320208", thanks to Michael Terry who worked on the change

 -- Sebastien Bacher <email address hidden> Wed, 28 Jan 2009 13:53:48 +0100

Changed in gdm:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers