Ubuntu

GDM incorrectly runs xsetroot, should keep background image (trivial fix)

Reported by Kristoffer Grönlund on 2008-10-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
Wishlist
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gdm

Getting GDM to keep the background image from the login theme is a trivial fix.

1. In the GDM package, change config/PreSession.in to not run xsetroot at all. Just remove everything related to #Set background color.
This change is already made upstream.

2. In the theme, add the attribute background="true" to the item tag that defines the background image. For example, in the default Human theme, this would mean putting this in the Human.xml file:

  <!-- background -->
  <item type="pixmap" background="true">
    <normal file="background.png"/>
    <pos y="0" x="0" width="100%" height="100%"/>
  </item>

3. Profit. Now instead of getting a plain colored background while waiting for the session to be logged in, the background image set in GDM is kept all the way until nautilus sets its background.

Kristoffer Grönlund (kegie) wrote :
Changed in gdm:
assignee: nobody → desktop-bugs
importance: Undecided → Wishlist
Sebastien Bacher (seb128) wrote :

The issue is fixed in the karmic version

Changed in gdm (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers