gdm should not recommend ubuntu-sounds

Bug #260558 reported by Andrew Hunter on 2008-08-23
4
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: gdm

With the new apt policy of installing recommends by default, ubuntu-sounds is depended upon by ubuntu-desktop.

Derivative distros don't necessarily want ubuntu-sounds installed.

Related branches

Changed in gdm:
importance: Undecided → Wishlist
Sebastien Bacher (seb128) wrote :

the recommends should probably be changed allow | sound-themes so other distribution can install their own variant

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdm - 2.20.8-0ubuntu6

---------------
gdm (2.20.8-0ubuntu6) jaunty; urgency=low

  * debian/control.in:
    - don't depends on xbase-clients the depends workarounded an old xorg issue
    - don't recommends ubuntu-sounds since it is installed by default on ubuntu
      use a suggests and let other distribution install it or not (lp: #260558)
    - recommends alsa-utils rather than depends on it, only gdmplay it using it
      which is not something required to use the login screen (lp: #293075)
  * debian/gdm.init:
    - use w argument to match only the "text" word (lp: #294980)
  * debian/gdmplay:
    - update to fix quoting issue, Antonio Salazar suggested the change
      (lp: #281518)
  * debian/patches/11_powermanagement.patch:
    - "Don't offer hibernate option if no swap partitions exist.
       LP: #320208", thanks to Michael Terry who worked on the change

 -- Sebastien Bacher <email address hidden> Wed, 28 Jan 2009 13:53:48 +0100

Changed in gdm:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers