gdm user switching issue

Bug #257774 reported by Petr Stehlik on 2008-08-13
6
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gdm

Running cleanly installed and up-to-date Ubuntu 8.04.1.

I am actually unsure what package this bug belongs to: either gdm or fast-user-switch-applet or even gnome-screensaver so please fix the right package relation.

Consider a desktop shared by several people, for example a family computer. Users 'A' and 'B' have accounts there. When switching between users the machine can freeze with login sound repeated forever.

Steps to reproduce:

1) user 'A' logs in first
2) user 'B' logs in using the fast-user-switch applet
3) user 'A' becomes active again after using the fast-user-switch-applet in the 'B' desktop and entering his/her password to unlock the 'A' session
4) then the user 'A' logs out
5) user 'B' tries to log back in (eventhough the 'B' is logged in already)

Expected is to get to the X11 screen where the last user was logged in, i.e. 'B' desktop, naturally password protected as always.

What happened? When user 'A' logs out in step 4) it should have switched to the locked screen of 'B' and so offer a dialog for entering the password thus unlocking the 'B' session. Instead, normal GDM login dialog is presented (asking for both name an password) and when user 'B' tries to log in they get to their desktop but it is sort of freezed, the login sound repeates over and over and everything is slow to death.

Thanks for looking into this.

Sebastien Bacher (seb128) wrote :

thank you for your bug report, what videocard and driver do you use?

Changed in gdm:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Petr Stehlik (pstehlik) wrote :

Sebastien, this is on onboard Geforce 6150 using proprietary nVidia driver.

BTW, a workaround for this issue is to try out Alt+Ctrl+F7/8/9/10/.. at step 5) when there is the normal login prompt on screen and user 'B' wants to get into his/her session. If the user 'B' has really been logged in already then his/her console is running somewhere at F7-Fx. What I am reporting here is that gdm (or who) does not switch to that console automatically.

IMHO it should work as follows: whenever any user logs out the gdm should try to locate any other running console. It normally works when second or subsequently logged in user logs out but it doesn't seem to work when the user-that-logged-in-_first_ logs out.

Thanks.

Sebastien Bacher (seb128) wrote :

could you try if you get the issue using the nv opensource driver?

Petr Stehlik (pstehlik) wrote :

The opensource nv driver doesn't work on the onboard graphics but I have just tried the same steps on a different computer with ATI Rage Mobility graphics and the behavior is exactly the same. Although it didn't freeze and seemed to be usable the gdm popup sound (not the login sound, that was my mistake in the original bug report) was repeated endlessly in the running session.

I also tried with three different users (A, B, C - logged in in this order) and it was quite interesting but unnecessarily complicated to explain and debug. The two users case is simple and reproducible easily:

1) log A in
2) switch to B
3) switch to A
4) log A out -> expected lock screen of user B session but got regular login prompt
5) log B in -> gdm popup sound is repeated, with some gfx drivers the desktop is unusably slow

There is also an interesting artefact when the user B logs out at last - the gdm prompt that appears is then asking for a password and it's not clear for which user it is. But I think this is just another sign of the problem in the step 5 when the login of B tries to reuse the existing session.

Thanks.

Sebastien Bacher (seb128) wrote :

what video driver do you use on this ati configuration?

Petr Stehlik (pstehlik) wrote :

I don't know what driver is used on the ATI - the xorg.conf's "Configured Video Device" section is completely empty. In the proprietary drivers there is nothing about video (just the wifi).
The Xorg.0.log contains lines 'Load driver "ati"' and 'Load driver "mach64"'. Does this information help? Or how can I find out what driver does it use?

Sebastien Bacher (seb128) wrote :

the ati driver is the opensource one, unconfirming for now, to send upstream by somebody having the issue, the issue when using the nvidia driver is likely a drive one, not sure about the ati bug

Changed in gdm:
status: Incomplete → New
Petr Stehlik (pstehlik) wrote :

Wish I had more different hardware to try this on (intel gfx anyone?) since I can't believe the repeated gdm sound is graphics driver related. But I have nvidia cards everywhere so I can't help it.

Giacomo Mirabassi (giacmir) wrote :

I have the same repeated gdm sound when switching user. I tried to stop it killing the gdm-greeter process but nothing changes. The only way I found is to logout and login again. My video card is Nvidia.

Giacomo Mirabassi (giacmir) wrote :

Today i've this bug happening again. I managed to stop the annoyng sound by first stopping /etc/init.d/alsa-utils, then killing the gdmgreeter process and finally starting alsa-utils again.

Hi, if it helps in the diagnosis of this problem, I have also experienced this problem several times on intel graphics chips (built-in graphics hardware on Dell Optiplex 745).

Sebastien Bacher (seb128) wrote :

Could you try if that's an issue with the new gdm on karmic?

Changed in gdm (Ubuntu):
status: New → Incomplete

Sebastien Bacher píše v Pá 24. 07. 2009 v 11:00 +0000:
> Could you try if that's an issue with the new gdm on karmic?

Wanted to try that but unfortunately KK Alpha 3 does boot into black
screen on my computer (nvidia 6150 onboard graphics). "Safe gfx mode"
selected on startup didn't help. I can hear the login sound but then Num
Lock stops responding so I suspect it just halts or something.

Petr

Petr Stehlik (pstehlik) wrote :

Sebastien Bacher píše v Pá 24. 07. 2009 v 11:00 +0000:
> Could you try if that's an issue with the new gdm on karmic?
>
> ** Changed in: gdm (Ubuntu)
> Status: New => Incomplete

Tested on KK Alpha4 - works wonderfully there. Please close as fixed.
Thanks!

Paul Hummer (rockstar) wrote :

Reporting user has commented that the bug is fixed.

Changed in gdm (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers