Ubuntu

[Intrepid] snd_pcsp module causing lockup when running as a VMWare guest

Reported by Brett Alton on 2008-07-09
34
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
Undecided
Unassigned
Intrepid
Undecided
Unassigned
module-init-tools (Ubuntu)
Medium
Martin Pitt
Intrepid
Medium
Martin Pitt

Bug Description

Binary package hint: gdm

In Intrepid alpha1, using a standard setup in VMware server 1.0.6 (which I will attach), Intrepid fails to login after I enter in the correct username and password. Specificially gdmgreeter, as far as I can tell, gets stuck in an endless loop.

Proof: I went to tty1, ran 'top' went back to tty7, logged in, quickly switched to tty1 where top and the whole computer froze. My host (Ubuntu 8.04) had a process (vmware-vmx) running at 50% with a dual-core processor for an infinite amount of time. At this time, Intrepid was unresponsive.

I'm attaching the VMware .vmx file while my next file will be the 'top' screenshot showing where the guest froze.

[EDIT by Chris Coulson]
For uname -a, lspci -vvnn and dmesg, please go to comments 20 and 21

https://bugs.launchpad.net/ubuntu/+source/gdm/+bug/246969/comments/20
https://bugs.launchpad.net/ubuntu/+source/gdm/+bug/246969/comments/21

Brett Alton (brett-alton) wrote :
Brett Alton (brett-alton) wrote :

My apologizes, it may not be regarding GDM but actually the kernel.

It receives this error message:

[ 2192.584659] BUG: soft lockup - CPU#0 stuck for 61s! [ksoftirqd/0:4]

I've attached a screenshot.

Tux (peter-hoogkamer) wrote :

I think I have the same problem. Vmware Workstation 5.5.0 on windows xp. Running Intrepid Alpha 1 with 2.6.26-3 kernel. Booting is ok, but when I want to login to GDM it stalls completly. I have logged my console ouput to a file via the serial port for debugging, but cannot seem to find any strange things.

Peter

Evan Dandrea (ev) wrote :

[ 385.477041] BUG: soft lockup - CPU#0 stuck for 61s! [ksoftirqd/0:4]

Experiencing the same problem here with the Hardy Alpha 2 candidate images (20080711) in VMWare.

Changed in linux:
status: New → Confirmed
Steve Langasek (vorlon) wrote :

I haven't been able to confirm whether the bug I'm seeing is exactly the same because I'm not set up to where I can switch and grab a vt under vmware to run top on, but I think it probably is the same bug: after entering username and password, the vm locks up, and stops responding to network traffic.

Kjell Braden (afflux) wrote :

I think I've the same issue on the desktop live sessions as well as the installed system from alternate images. I can't change to a VT and check for other symptoms, because vmware-player does not seem to have a way to pass strg+alt+fN to the guest.

Brett Alton (brett-alton) wrote :

I'm waiting for http://cdimage.ubuntu.com/releases/8.10/ to show alpha2 and then I'll tell you if I can reproduce this bug in the second alpha.

Brett Alton (brett-alton) wrote :

Seems to occur in alpha-2 as well. I haven't been able to login to either of the alphas because of this bug.

Same for me here. However I use the following workaround to log in at all (this is with VMWare Workstation):

1. Click in the VMs Window and hit Ctrl+Alt+Shift+F2
2. Log in to the console
3. sudo apt-get install openssh-server

4. From the host: ssh -Y user@VMs_IP
5. sudo gnome-control-center &
6. Click on "Login Window"
7. Enable Remote Login
8. Restart the VM (sudo shutdown -r now)
9. Open another Logon Screen on the Host (Switch User)
10. Select XDMCP from the menu
11. Select the VMs IP and log in

Voila, full screen logon to your Intrepid system.

mejogid (mejogid) wrote :

I noticed that when this was occurring on VMWare Fusion (for OS X), there was a constant buzzing sound around the time when the login tone should happen - even if I had disabled the virtual sound card. After a bit of trial and error, I thought this may be coming from the system speaker, and it turns out unloading the module snd_pcsp prevents the noise *and* the freezing when logging in.

It seems that this is two seperate bugs - Ubuntu using the system speaker to play sounds on, and VMWare locking up when this piece of virtual hardware is used for prolonged periods. The Ubuntu forums thread - http://ubuntuforums.org/showthread.php?t=845844 - seems to deal with the first problem, although I can't find a corresponding launchpad bug, and VMWare probably need to be alerted of the second issue.

Scott Ritchie (scottritchie) wrote :

I'm able to login if I use failsafe mode under select session, but not otherwise.

Tux (peter-hoogkamer) wrote :

I can confirm the workaround from mejogid. I had notice the noise from the pc speaker as well, but since I could not find the pcspkr module I was not able to disable it. Turns out this was the snd_pcsp module. No wonder I could not find it. I am logging in fine now on Intrepid Alpha 2 on Vmware Workstation 5.0.0. There must be a problem with the snd_pcsp in relation to vmware.

Tux

Chris Coulson (chrisccoulson) wrote :

I can also confirm mejogid (unloading snd_pcsm module) works for me. I can log in using a normal GNOME session after unloading this module

EmyrB (emyr) wrote :

I can also confirm that this is still happening for me when using VMWare Workstation v6 and Virtual Box 1.62. After I enter my username and password Intrepid hangs with the speaker making a noise. This is happening with both Alpha 1 and 2. The only way I could find a workaround was to install Hardy Heron, change the sources.list to point to Intrepid and dist-upgrade. Once I had done this, on the grub screen I press escape and choose to boot with the 2.6.24-19 kernel and this works fine. Not sure if this is a Kernel issue.

EmyrB (emyr) wrote :

Sorry I should have added that I have used both Windows XP Pro, Vista Home Premium, Vista Ultimate and Ubuntu Hardy Heron 8.04.1 as hosts for the VM with the same results in all of them with both VMWare Workstation 6 and Virtual Box 1.62, so I can't see it being a VMWare bug.

Tux (peter-hoogkamer) wrote :

I am not really convinced this being a vmware bug. I have Vmware Workstation 5.0 running. When installing hardy heron (kernel 2.6 17 or 19) there is no issue, but after installing intrepid alpha 1 or 2 (kernel 2.6.26- ) I have problems with sound and mouse grabbing. So I think there are also some things wrong with the snd_pcsp module and kernel 2.6.26.

Tux

Brett Alton (brett-alton) wrote :

I'm quite sure you're correct about snd_pcsp module and kernel 2.6.26; The only reason why the title is 'gdmgreeter freezes in VMware Server 1.0.6' was because I couldn't pin point the bug at first, and that was my first guess.

Can we change the name by any chance?

Chris Coulson (chrisccoulson) wrote :

Done! In future, you can edit the description by clicking 'Update description / tags', underneath the original bug description text.

Could somebody here provide the following information, as required by the Ubuntu Kernel Team (I will do it when I get home from work if someone else hasn't done already):
1. Please include the output of the command "uname -a".
2. Please run the command "dmesg > dmesg.log" after a fresh boot and attach the resulting file "dmesg.log" to this bug report.
3. Please run the command "sudo lspci -vvnn > lspci-vvnn.log" and attach the resulting file "lspci-vvnn.log" to this bug report.

For your reference, the full description of procedures for kernel-related bug reports is available at [WWW] https://wiki.ubuntu.com/KernelTeamBugPolicies Thanks in advance!

Tux (peter-hoogkamer) wrote :

Here is my information:
First of all am I running this Ubuntu Intrepid Alpha 2 installation on Vmware Workstation 5.5.0.

uname -a
Linux Intrepid 2.6.26-4-generic #1 SMP Mon Jul 14 18:39:53 UTC 2008 i686 GNU/Linux

Tux (peter-hoogkamer) wrote :
Changed in gdm:
status: New → Invalid
Changed in linux:
assignee: nobody → ubuntu-kernel-team
description: updated
Xeletron (xeletron) wrote :

in vmware 2 it works ok (yust to clear this)

Scott Ritchie (scottritchie) wrote :

if this isn't fixed by alpha 3, we should probably add the workaround (sudo modprobe -r snd-pcsp) to the release notes

Steve Langasek (vorlon) on 2008-07-28
Changed in linux:
milestone: none → ubuntu-8.10
importance: Undecided → Medium
bbthechange (bbthechange) wrote :

I consistently experienced the same problem with alpha 3 on OSX with VMWare Fusion.

EmyrB (emyr) wrote :

Well I am still experiencing this issue with Alpha 3. Any ideas if it's Pulse Audio or the Kernel?

Martin Pitt (pitti) wrote :

Given the neverending trouble snd_pcksp causes, and the various futile attempts to work around it in bug 242966, maybe we should consider blacklisting it by default? Does it really serve any sensible purpose?

Martin Pitt (pitti) wrote :

As far as I can see, this is neither a real problem of the kernel (except that snd_pcsp is so exceptionally low-quality, much worse than we are used to from the good old DOS .mod players :) ), nor in pulseaudio, which just gets presented an ALSA card, but that the snd_pcsp device is not really meant for serious audio playback.

Since there hasn't been any more promising solution so far, I am going with the blacklist solution for now. This can easily be reverted if someone has a better idea.

Changed in linux:
assignee: ubuntu-kernel-team → pitti
milestone: ubuntu-8.10 → intrepid-alpha-4
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package module-init-tools - 3.3-pre11-4ubuntu9

---------------
module-init-tools (3.3-pre11-4ubuntu9) intrepid; urgency=low

  * extra/modprobe.d/blacklist: Blacklist snd_pcsp by default. It has an
    extraordinarily low quality and is not useful at all for real audio
    playback. It causes a lot of hangs and pain, and workarounds in ALSA and
    PulseAudio have been insufficient. (LP: #246969)

 -- Martin Pitt <email address hidden> Tue, 12 Aug 2008 17:31:29 +0200

Changed in module-init-tools:
status: In Progress → Fix Released
Björn Torkelsson (torkel) wrote :

The only drawback is that the (disctinct) system-beep, of which you can change volume independently of other sounds in the system, is gnone.

Chris Coulson (chrisccoulson) wrote :

Björn - I don't think that ever existed pre-Intrepid did it?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers