"Failed to intialize HAL" error message after gdm login. possibly because of wrong gdm priority in /etc/rc*/

Bug #227838 reported by Thomas Hammerl on 2008-05-07
38
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
High
Martin Pitt
Hardy
High
Martin Pitt
Intrepid
High
Martin Pitt

Bug Description

Binary package hint: gdm

After upgrades from Feisty to Gutsy and from Gutsy to Hardy I get an error message after logging in with gdm (2.20.5-0ubuntu3) saying "Failed to initialize HAL" but debugging HAL showed that it just comes up fine (see attachment). These are the symlinks to gdm and hal in /etc/rc*:

$ ls -l /etc/rc*/*hal
/etc/rc1.d/K16hal -> ../init.d/hal
/etc/rc2.d/S24hal -> ../init.d/hal
/etc/rc3.d/S24hal -> ../init.d/hal
/etc/rc4.d/S24hal -> ../init.d/hal
/etc/rc5.d/S24hal -> ../init.d/hal
$ ls -l /etc/rc*/*gdm*
/etc/rc0.d/K01gdm -> ../init.d/gdm
/etc/rc1.d/K01gdm -> ../init.d/gdm
/etc/rc2.d/S13gdm -> ../init.d/gdm
/etc/rc3.d/S13gdm -> ../init.d/gdm
/etc/rc4.d/S13gdm -> ../init.d/gdm
/etc/rc5.d/S13gdm -> ../init.d/gdm
/etc/rc6.d/K01gdm -> ../init.d/gdm

HAL is started after gdm and if I login to quickly HAL is not running yet. I was hinted to this by Martin Pitt (who thinks that this an Feisty upgrade issue) in another bug report:

https://bugs.launchpad.net/ubuntu/+source/dbus/+bug/25931/comments/180

TEST CASE:
Move /etc/rc2.d/S30gdm to S13gdm to simulate a broken upgrade. Then upgrade to the hardy-proposed version. The symlinks should be fixed to be at level 30 (after hal starts).

Related branches

Thomas Hammerl (thomas-hammerl) wrote :
petit-prince (petit-prince) wrote :

I can confirm this issue. This should be fixed in the postinst script in the same way Martin Pitt fixed a similar issue in the hal package (cf. https://bugs.launchpad.net/ubuntu/+source/dbus/+bug/25931/)

Thanks,
Dan

Changed in gdm:
status: New → Confirmed
Martin Pitt (pitti) on 2008-05-08
Changed in gdm:
assignee: nobody → pitti
importance: Undecided → High
status: Confirmed → In Progress
assignee: nobody → pitti
importance: Undecided → High
milestone: none → ubuntu-8.04.1
status: New → In Progress
LarryJ (larry-foxgulch) wrote :

I also get the error message("Failed to initialze HAL!) from a fresh install of Hardy 8.04. cat I moved /etc/rc2.d/24hal to /etc/rc2.d/26.d after reading the many trouble reports. I am now able to start hal manually with "$ sudo /etc/init.d/dbus start" All of the functionality, (network, etc) returns to the PC. But after DBus and HALD report "OK", System->Admininstration->Services shows but all the services are grayed out and the unlock button is grayed out. If I attempt to start it using " ~$ sudo services-admin", the Services Settings window appears but again all the services entries are grayed out and the unlock button is grayed out.

Note that this is a new install of Hardy 8.04. I didn't follow the upgrade path noted in many of these reports. This is with "Linux lian 2.6.24-16-generic #1 SMP Thu Apr 10 13:23:42 UTC 2008 i686 GNU/Linux" and "Gnome 2.22.1 5/7/2008" the log file /var/log/gdm/:0.log contains an line entry: "[config/hal] couldn't initialise context: (null) ((null))" /var/log/messages has several entries related to error messages apparently generated when invoking dhcdbd.

Ross Campbell (ross-campbell) wrote :

I am running mythbuntu 8.04 and have been regularly applying patches and rebooting about weekly. I just started getting the "Failed to initialize HAL!" error yesterday after patch and reboot, so something changed recently... I've been running same system/config since Gutsy and have never seen this issue before. I have my system set up to autologin upon reboot.

Martin Pitt (pitti) wrote :

I uploaded a fix to hardy-proposed with attached debdiff. Pending acceptance from Steve now.

description: updated
Martin Pitt (pitti) wrote :

I'll copy the hardy-proposed version to intrepid once it gets accepted.

Changed in gdm:
status: In Progress → Fix Committed
Steve Langasek (vorlon) wrote :

Accepted into -proposed, please test and give feedback here

Changed in gdm:
milestone: ubuntu-8.04.1 → none
status: In Progress → Fix Committed
Steve Langasek (vorlon) on 2008-05-21
Changed in gdm:
milestone: none → ubuntu-8.04.1
Pedro Villavicencio (pedro) wrote :

verification done:

- followed the test case moved the old gdm symlink from /etc/rc2.d/S30gdm to S13gdm to simulate the upgraded, after installed the proposed package the symlink is moved to S30gdm again, bug is fixed.

Michael Bienia (geser) wrote :

I can confirm that gdm 2.20.6-0ubuntu2 fixes the problem.

I had the same problem and the update from hardy-proposed moved the start link and the error message is gone.

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in gdm:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied to intrepid.

Changed in gdm:
status: Fix Committed → Fix Released
David Grossberg (davidgro) wrote :

This also affects kdm - I just had to fix it manually on my laptop's Kubuntu Hardy x86 install in order to get .fdi files placed into /etc/hal/fdi/policy/ working.

otakuj462 (otakuj462) wrote :

I'm using Hardy 8.04.2 (originally upgraded from Feisty), with gdm 2.20.7-0ubuntu1.1, and it appears as though I am still affected by this bug:

jacob@jacob-laptop:~$ ls -l /etc/rc?.d/*dbus
lrwxrwxrwx 1 root root 14 2008-04-29 03:54 /etc/rc1.d/K88dbus -> ../init.d/dbus
lrwxrwxrwx 1 root root 14 2008-04-29 03:54 /etc/rc2.d/S12dbus -> ../init.d/dbus
lrwxrwxrwx 1 root root 14 2008-04-29 03:54 /etc/rc3.d/S12dbus -> ../init.d/dbus
lrwxrwxrwx 1 root root 14 2008-04-29 03:54 /etc/rc4.d/S12dbus -> ../init.d/dbus
lrwxrwxrwx 1 root root 14 2008-04-29 03:54 /etc/rc5.d/S12dbus -> ../init.d/dbus
jacob@jacob-laptop:~$ ls -l /etc/rc?.d/*hal
lrwxrwxrwx 1 root root 13 2008-05-09 05:05 /etc/rc1.d/K16hal -> ../init.d/hal
lrwxrwxrwx 1 root root 13 2008-05-09 05:05 /etc/rc2.d/S24hal -> ../init.d/hal
lrwxrwxrwx 1 root root 13 2008-05-09 05:05 /etc/rc3.d/S24hal -> ../init.d/hal
lrwxrwxrwx 1 root root 13 2008-05-09 05:05 /etc/rc4.d/S24hal -> ../init.d/hal
lrwxrwxrwx 1 root root 13 2008-05-09 05:05 /etc/rc5.d/S24hal -> ../init.d/hal
jacob@jacob-laptop:~$ ls -l /etc/rc?.d/*gdm
lrwxrwxrwx 1 root root 13 2007-06-04 17:03 /etc/rc0.d/K01gdm -> ../init.d/gdm
lrwxrwxrwx 1 root root 13 2007-06-04 17:03 /etc/rc1.d/K01gdm -> ../init.d/gdm
lrwxrwxrwx 1 root root 13 2007-06-04 17:03 /etc/rc2.d/S13gdm -> ../init.d/gdm
lrwxrwxrwx 1 root root 13 2007-06-04 17:03 /etc/rc3.d/S13gdm -> ../init.d/gdm
lrwxrwxrwx 1 root root 13 2007-06-04 17:03 /etc/rc4.d/S13gdm -> ../init.d/gdm
lrwxrwxrwx 1 root root 13 2007-06-04 17:03 /etc/rc5.d/S13gdm -> ../init.d/gdm
lrwxrwxrwx 1 root root 13 2007-06-04 17:03 /etc/rc6.d/K01gdm -> ../init.d/gdm

I tried reinstalling gdm as well, but nothing changed with respect to order of the init scripts.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments