gdm is not translated

Bug #180751 reported by Patrice Vetsel on 2008-01-06
14
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
High
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gdm

Under Hardy, gdm 2.20.2-1ubuntu2 is not translated in french. I must select french language, but after reboot gdm remain untranslated.

Steps :
Install hardy 20080104.
Use French preferences (at boot/keyboard/language)
After installation reboot -> gdm is in english (keyboard is in french)

Related branches

Patrice Vetsel (vetsel-patrice) wrote :

Still available under alpha3 or daily iso 20080119 alternate i386

Changed in gdm:
importance: Undecided → High
milestone: none → hardy-alpha-4
Pedro Villavicencio (pedro) wrote :

Thanks for your report, to be confirmed by someone with similar setup.

Changed in gdm:
assignee: nobody → desktop-bugs
Sebastien Bacher (seb128) wrote :

gdm is correctly translated on my hardy installation

Changed in gdm:
milestone: hardy-alpha-4 → ubuntu-8.04
Patrice Vetsel (vetsel-patrice) wrote :

Sebastien : do you have tested a clean/fresh hardy installation in french ?

Patrice Vetsel (vetsel-patrice) wrote :

I can confirm this bug under :
my notebook
my computer
under vmware
under virtualbox

And with or without Internet connection (download of french support language during installation)

Patrice Vetsel (vetsel-patrice) wrote :

I can confirm this bug doing an spain/espanol installation too.

Joke : Am I the only man in the world testing alpha isos not in english ?

Sebastien Bacher (seb128) wrote :

Do you have language-pack-gnome-fr-base installed and which version?

Patrice Vetsel (vetsel-patrice) wrote :

Doing a fresh hardy desktop i386 installation in french, without Internet connection, I have :
1:8.04+200080119

When gdm is launched, i suppose that it use an environment variable to select language ? Wich one ?

Sebastien Bacher (seb128) wrote :

it uses the environment configuration and pam_getenv -l LANG and pam_getenv -l LANGUAGE

Ok so here, under Gutsy :
pam_getenv -l LANG ->fr_FR.UTF-8
pam_getenv -l LANGUAGE -> nothing
echo $LANG ->fr_FR.UTF-8

Under Hardy :
pam_getenv -l LANG -> nothing *** PROBLEM ?! ***
pam_getenv -l LANGUAGE -> nothing
echo $LANG ->fr_FR.UTF-8

Sebastien Bacher (seb128) wrote :

that doesn't look like a gdm bug

Andrew Conkling (andrewski) wrote :

Is this related to or caused by bug #185947?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdm - 2.20.3-0ubuntu3

---------------
gdm (2.20.3-0ubuntu3) hardy; urgency=low

  * debian/gdm.init:
    - use /etc/default/locale to set LANG and LANGUAGE (lp: #180751)

 -- Sebastien Bacher <email address hidden> Fri, 08 Feb 2008 19:28:40 +0100

Changed in gdm:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers