[hardy] missing language error

Bug #178402 reported by Alex Polinsky on 2007-12-24
108
Affects Status Importance Assigned to Milestone
gdm
Fix Released
Medium
gdm (Ubuntu)
High
Sebastien Bacher

Bug Description

After updating to Hardy from Gutsy, logging in produces an error : "Language en_US does not exist, Using system default". After clicking OK it loads the system in using en_US. The same occurs for other languages.

This bug is caused by the difference between /etc/environment in Gutsy and Hardy :

Gutsy :
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games"
LANG="en_US.UTF-8"

Hardy upgraded from Gutsy :
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games"
LANG="en_US.UTF-8"
LANGUAGE="en_US:en"

Hardy freshly installed :
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games"

Workarounds :
Remove the 'LANGUAGE="en_US:en"' (or other language) line in /etc/environment.
--or--
Choose a language in GDM (instead of using "System Default").

Related branches

Saivann Carignan (oxmosys) wrote :

Thanks for this bug report and for your contribution to ubuntu.

Can you copy these two commands on a terminal and tells if it fixes the problem?

sudo apt-get install language-support-en
sudo dpkg-reconfigure locales

Alex Polinsky (snake444) wrote :

hi, i did those two commands but it didnt solved this error , heres the output:
snake@home:~$ sudo apt-get install language-support-en
[sudo] password for snake:
Reading package lists... Done
Building dependency tree
Reading state information... Done
language-support-en is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
snake@home:~$ sudo dpkg-reconfigure locales
Generating locales...
  en_AU.UTF-8... done
  en_BW.UTF-8... done
  en_CA.UTF-8... done
  en_DK.UTF-8... done
  en_GB.UTF-8... done
  en_HK.UTF-8... done
  en_IE.UTF-8... done
  en_IN.UTF-8... done
  en_NZ.UTF-8... done
  en_PH.UTF-8... done
  en_SG.UTF-8... done
  en_US.UTF-8... done
  en_ZA.UTF-8... done
  en_ZW.UTF-8... done
  he_IL.UTF-8... done
  ru_RU.UTF-8... up-to-date
  ru_UA.UTF-8... up-to-date
Generation complete.
snake@home:~$

if you need more information say here, and if you want i can do a video of the load of ubuntu or when the computer boots..

Saivann Carignan (oxmosys) wrote :

Thanks for these informations.

I think that we would need someone to reproduce and confirm this bug. No need to make a video if your description describe everything we need to know about the problem, including any error message you get and any not-normal behavior you get from ubuntu. You can add informations about to this bug report anytime.

In your description, you say "updating to alpha 2 from gutsy", I assume that you mean that you upgraded to hardy alpha 2, I suggest that you modify the description in order to clarify this.

From now on, I'll try to see if I can reproduce that bug.

Saivann Carignan (oxmosys) wrote :

I reproduced that bug, Setting the status to confirmed and Importance to High.

We will need to find which package is the cause of that bug.

A easy workaround for that bug is to manually choose the language in GDM and then the bug won't appear again. Set importance to low.

Alex Polinsky (snake444) wrote :

ok, but where is that GDM? i didnt understood what is the meaning of GDM..

description: updated
Saivann Carignan (oxmosys) wrote :

GDM is the Gnome Display Manager. It's actually what you see when you must type your username and password. You can change the language with the little "Option" menu in the bottom-left corner of your screen and the error message will disappear. It just looks like the language name saved with Gutsy doesn't work in Hardy, maybe that something changed about the way Gnome saves the language preferences. I'll investigate more about this.

description: updated
description: updated
description: updated

I'm having the same problem here, only my login screen has no "option" menu. is there any way i can change the language from the command prompt?

Saivann Carignan (oxmosys) wrote :

kevin Schwenkler :

Can you do this and tells if it fixes your issue? :

1. type this on a terminal : sudo cp /etc/environment /etc/environment.bak
2. type this on a terminal : sudo nano /etc/environment
3. Remove the line that starts with "LANGUAGE="
4. Type CTRL + X to quit and Y to save
5. Reboot your computer and see if the problem is solved.

At anytime, if you followed step 1, you can recover your initial configuration by typing :

sudo cp /etc/environment.bak /etc/environment

Alex Polinsky (snake444) wrote :

thanks for your answer, i didnt knew what is GDM because i did "auto login" for my user, and i never see this GDM screen because it automaticly starts ubuntu with my user

Saivann Carignan (oxmosys) wrote :

No problem :)

Bart Samwel (bart-samwel) wrote :

I saw this twice: first on an upgrade from Gutsy, but I've had to reinstall because that upgrade went totally wrong (couldn't login anymore at some point, no idea what was going on). Anyway, I've just had the same problem on a fresh Hardy alpha 2 install. I don't remember exactly what I did, but I think the only things I did were to install a second language pack (Dutch) next to English, and to install the Dutch keyboard layout (which is useless since no hardware exists that uses that except typewriters, but that's for another report), and then reboot and try to log in again. Perhaps I changed the default language from English (US) to something else and then back again as well. I'm going to check if this is fixed by the suggested fix and I'll report back.

Bart Samwel (bart-samwel) wrote :

OK, removing the LANGUAGE= line removed the error message.

Saivann Carignan (oxmosys) wrote :

Thanks for this confirmation!

Changed in gdm:
importance: Low → Medium
Changed in gdm:
importance: Medium → High
description: updated
Joel C. Salomon (jcsalomon) wrote :

I've had the same problem start when I installed Hebrew & Yiddish language support. I'm going to try editing /etc/environment and will report if that worked.

Changed in gdm:
assignee: nobody → desktop-bugs
Saivann Carignan (oxmosys) wrote :

Alpha 3 just doesn't come with language support, seems to be caused by dependency problem with the openoffice lang packs. Waiting for the alpha 4

Alex Polinsky (snake444) wrote :

yes it is very annoying to be without russian and hebrew languages on the keyboard
and btw the changing languages at GDM solved the problem

I'm also seeing this but with 'Language en_DK' instead. In /etc/environment I've got:

LANG="en_DK.UTF-8"
LANGUAGE="en_DK:en"

I tested removing those and my locale was set to C instead so that was no good (did remove the error though).

Saivann Carignan (oxmosys) wrote :

Still here with Hardy Alpha 4

Matt Zimmerman (mdz) wrote :
Pedro Villavicencio (pedro) wrote :

bug 185947 has technicals thoughts about it

Alexander Jones (alex-weej) wrote :

I have LANG="en_GB.UTF-8" and LANGUAGE="en_GB:en", but locale -a lists only "en_GB.utf8" as a GB variant.

What is the difference between LANG and LANGUAGE variables? And is there any significance in *.UTF-8 vs. *.utf8?

Christian Kellner (gicmo) wrote :

As I have stated on bug 185947 my take on that bug here is that we are setting (in the language selector) a locale that is not available on the system: we only have the xx_XX.UTF-8 variant of various languages but we are setting the variant without the .UTF-8 part, i.e. xx_XX. Calls to SETLOCALE (3) with xx_XX as argument will fail (in opposite to calls with xx_XX.UTF-8) thus giving us the gdm error dialog.
IMHO *NOT* a gdm bug, since we shouldn't be setting a locale that the system doesnt offer. Either set the xx_XX.UTF-8 variant (in the language selector) or generate the xx_XX version.

Saivann Carignan (oxmosys) wrote :

Can someone from the Ubuntu Desktop Bugs make sure that this problem get fixed? I assume that the ubuntu installer as well as other ubuntu tools need to be fix since this bug also happens when upgrading from gutsy.

kripken (kripkenstein) wrote :

I am also experiencing this bug.

My system is a fresh install of Hardy from a month or so ago (*not* an upgrade from anything). The bug suddenly started a few days ago, and since then appears every single time I log in.

Janek Thomaschewski (thefoxx) wrote :

I can confirm what kripkenstein said: The bug appears not only on a fresh install of hardy. It appears when switching the language with the language-selector tool too.

crf (chrisfahlman) wrote :

Does it not occur when you create a new user as well? I upgraded to hardy and see this issue on a new user I created (but not an old user from prior to the upgrade).

chastell (chastell) wrote :

Same here, with fresh install of Hardy Alpha 4 upgraded to current and gdm 2.20.3-0ubuntu3. gdm 2.20.3-0ubuntu3’s changelog says ‘use /etc/default/locale to set LANG and LANGUAGE’ and when I changed LANGUAGE to "en_GB.UTF-8:en" in /etc/default/locale the problem went away on next reboot (logging out and back in did not suffice).

description: updated
Changed in gdm:
milestone: none → hardy-alpha-6

This happens to me too.
At the beginning I thought it was with es_ES only but then I installed en_UK and it_IT and still the problem persists.
However, after clicking on the error alert, the language seems to load correctly.

This is a Hardy Heron Alpha 4 updated untill yesterday.

Cheers.

Sebastien Bacher (seb128) wrote :

I'm working on this one

Changed in gdm:
assignee: desktop-bugs → seb128
Changed in gdm:
status: Unknown → New

This workaround/fix that was mentioned here (https://bugs.launchpad.net/ubuntu/+source/gdm/+bug/178402/comments/28) seems to have solved the issue for the time being for me.

Upgrading my EeePC resulted in this problem, which was fixed by updating:
LANGUAGE="en_US.UTF-8:en" in the /etc/default/locale file.
This file has both LANG and LANGUAGE values assigned in the file.

I did *not* have this problem on my MacBook, which only has:
LANG="en_US.UTF-8" in the /etc/default/locale file.

Both of these machines are running with the latest available updates as of Fri Feb 22, 2008.

Sebastien Bacher (seb128) wrote :

could users stop using the bug report to suggest broken workaround? if you don't want to get the message just select a language on the login screen and it'll be written to your user configuration. users discussion should be taken to an user list and not there

Guybrush88 (guybrush) wrote :

i've got this problem with italian language, but i resolved that selecting italian language in the gdm's language selector

Ryan Prior (ryanprior) wrote :

Sebastien: because knowledge of workarounds may be helpful to bug hunters, I question the wisdom of asking users not to add that info to the bug tracker.

Sebastien Bacher (seb128) wrote :

you are welcome to add informations to a bug when it's not triaged, that's not the case there, the exact cause is known and the bug should be easy to solve now, adding comments just create mail noise

Felix Rabe (public-felixrabe) wrote :

Well, if you don't want to triage bugs, be rude to the reporters until there are none left to triage? Sorry couldn't help it, maybe there's a "netiquette for triaged bugs" that I don't know about.

In the meantime, I'm glad you work on it and next boot-up I will try what you said on https://bugs.launchpad.net/ubuntu/+source/gdm/+bug/178402/comments/32 Right now, I'm still suffering from this issue. (Yes, I tried an earlier workaround that now stopped working, but I took note and can revert that change before switching language to the one I already use...)

Luka Napotnik (luka-napotnik) wrote :

I get the same error message with sl_SI just after logging into gnome. Using Hardy with latest updates and have Slovenian as the default language. Also have Slovenian support installed.

description: updated
Alexander Jones (alex-weej) wrote :

The Language Support admin applet still adds:

LANGUAGE="en_GB:en"
LANG="en_GB.UTF-8"

to the system environment, even after I've removed it as per the workaround. Is this a bug in that applet?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdm - 2.20.3-0ubuntu4

---------------
gdm (2.20.3-0ubuntu4) hardy; urgency=low

  * debian/patches/36_use_correct_locale.patch:
    - use setlocale to fix language error (lp: #178402)

 -- Sebastien Bacher <email address hidden> Wed, 27 Feb 2008 17:36:58 +0100

Changed in gdm:
status: Triaged → Fix Released
Changed in gdm:
status: New → Fix Released
Changed in gdm:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.