Login screen appears twice in (X)Ubuntu Hardy

Bug #178324 reported by Double12 on 2007-12-23
26
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

When I login with my username and password in Xubuntu (Hardy Alpha2), it returns to the terminal and I see the start-up-procedures for a moment. Then it gets back to the login screen. When I login then, it finally goes to my desktop.
So, in fact I have to login twice before I get into my account.
Maybe it restarts the X server after the first login?

This does only happen when starting up the computer, not when logging off/logging in while the pc is on.

Thank you for your bug report. I could reproduce this once but it did not happen again since then. I'm marking gdm as the affected package.

Raymond (raymond-m) wrote :

The same happens after updating from gutsy to Heron Alpha 1 but a least I now have sound (intel HD)

Raymond: are you also using Xubuntu ?

Changed in gdm:
status: New → Incomplete
Raymond (raymond-m) wrote :

No I updated from Gutsy using sudo update-manager -d to heron

Ok thank you, I'm marking this as confirmed.

Changed in gdm:
status: Incomplete → Confirmed

i have Ubuntu hardy alfa 2 and i have same problem

fuhrysteve (fuhrysteve) wrote :

The bug also affects me, everything up to date: Ubuntu 8.04.

after update to ubuntu 8.04 alfa 3 problem removed

Anyone can confirm it's fixed ?

Linard Verstraete (linardv) wrote :

Running Xubuntu Hardy Alpha 3 from LiveCD and I can confirm that I only have to log in once.

Lionel Le Folgoc (mrpouit) wrote :

Thanks for confirming.

Changed in gdm:
status: Confirmed → Fix Released

Marking this as fixed then, feel free to reopen.

miked (miked11) wrote :

root@2HewittRand-desktop:~# cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"
root@2HewittRand-desktop:~#
I have this happen also, under Ubuntu Hardy Heron 8.04 Alpha 4, and Ubuntu Gusty Gibbon Final 7.10 on another computer I use.

miked (miked11) wrote :

Then after logging in as root, confirmation dialog choice box appears and sometimes the keyboard keys do not work.
Specifically <-,->, left arrow, right arrow, up arrow, down arrow, and Tab |<-->| key, I have to use mouse to click on confirmation choice box.

miked (miked11) wrote :

Added Info

Changed in gdm:
status: Fix Released → New
Glenn (glenn-v) wrote :

I recently started seeing this behavior using fully updated Hardy alpha 4. I think miked might be having a separate issue, because my keyboard keys still work and I see no confirmation dialog. I just log in normally, then x is killed, then gdm starts again, and I must log in again.

Changed in gdm:
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

miked, your issue seems to be a different one and you added no useful information, don't reopen closed bugs without a good reason

Changed in gdm:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Confirmed → Fix Released
K8BeBop (kennybob6) wrote :

This has happened to me for a couple of months on Ubuntu. It's weird, a week ago it cleared up, but now it back. I'm attaching dmesg. I hope this will help you out. I don't know if gdm starts or stops or if something else in the background is happening or not happening. I will give you any other help you need to find the culprit.

I can't confirm the resolution, the same problem happens after updating from gutsy to Heron. (everything up to date)

Changed in gdm:
status: Fix Released → Confirmed
Sebastien Bacher (seb128) wrote :

could you attach your .xsession-errors after the not working login?

Changed in gdm:
status: Confirmed → Incomplete
K8BeBop (kennybob6) wrote :

Here is my .xsession errors. This is the login that gets me in. I do not know how to get you one, from the not working login.

After last upgrade, problem seems to be fixed.

Sebastien Bacher (seb128) wrote :

closing since there is a comment stating that's fixed now

Changed in gdm:
status: Incomplete → Fix Released
DingoMD (dingomd) wrote :

I'm getting this bug on Ubuntu Hardy beta. Please tell me what files/logs you need me to post, if any.

Vincent (vinnl) wrote :

DingoMD, if you get the problem on the latest update I suppose you'll need to reopen this bugreport.

The problem seems to go away randomly for people, so perhaps it would be best not to mark this as fixed until someone consciously fixes it?

reja (ubuntu-reja) wrote :

Same problem, I upgraded from Gutsy to Hardy 8.04. Originally I didn't have the login problem but I did have a lot of trouble getting the initial upgrade to work with my video card (NVIDIA Quadro 4 280NVS). After I changed the video driver from nvidia-glx to nvidia-legacy, my video worked, but the double login started.

shearn89 (shearn89) wrote :

My laptop has just started showing this - acer aspire 5520. Installed Hardy Beta, then upgraded to 8.04 release with apt-get upgrade. Yesterday was fine, today literally just now, started doing it. I normally have to log in twice, and then sometimes my desktop doesn't appear either and i have to restart X.

oren (orengolan) wrote :

got the same error with a sony vaio vgn txn27n.
installed xubuntu 7.10 and upgraded to hardy.

andre (garrel-andre) wrote :

Hi,
I have the same error on Ubuntu 8.04 (I installed version 7.10, and then upgrade to 8.04). I apply all the suggested upgrades.
I have this problem since an upgrade, but, i dont know exactly what was upgraded.

andre (garrel-andre) wrote :

Hi,
I created an other user, log on with this user, log off, then log on with my user, and shtdown the box.
Now i need log in only one time. If i drop the second user, I need log in twice. I re-create the second user, and it works fine, I need to log only once!!!!

vandal47 (farrowch) wrote :

I just upgraded from gutsy to hardy and I must log in twice, as described in the first post.

Flarkit (flarkit) wrote :

I upgraded from 7.10 to 8.04 and I have the user-selection enabled in the login window. I select my username and enter the password, then the login window reappears and I have to login again, before it works.

Flarkit (flarkit) wrote :

Solved my login issue: in the System->Administration->Login Window, under "Security", I disabled the "Enable automatic login" option

jaunie (jaunie) wrote :

i'm sorry, but the above solution doesn't apply to me since my "Enable automatic login" option was not enabled in the first place. up until now, i have this double log-in problem.

jalso (launchpad-jalso) wrote :

I upgraded from gutsy to hardy and I must log in twice too.
Asus A6JC notebook.
xsession-errors in attachment

jalso (launchpad-jalso) wrote :
jalso (launchpad-jalso) on 2008-05-27
Changed in gdm:
status: Fix Released → Confirmed
Sebastien Bacher (seb128) wrote :

what gdm version do you use?

Changed in gdm:
status: Confirmed → Incomplete
jalso (launchpad-jalso) wrote :

GDM 2.20.6

None of the xsession-errors files supplied appear to be Xubuntu users. Could the submitters please clarify what desktop environment they were trying to log into? I personally can't reproduce this.

jalso (launchpad-jalso) wrote :

after yesterday's system update the problem has removed

KBA3AP (serjionix) wrote :

Proposing an extension to Flarkit's solution: "in the System->Administration->Login Window, under "Security", I disabled the "Enable automatic login" option" - I enabled automatic login, then rebooted, and then disabled automatic login.

Ricardo (ricardobdasilva) wrote :

Just for the record: KBA3AP's solution worked for me. Also upgraded from Gutsy.

We have a lab in an academic setting of about 20 computers - they all seem to be replicating this behavior. My personal laptop was doing it for awhile, but then it quit - so I thought an update took care of it, but it appears the lab (fully updated Ubuntu 8.04) is still encountering the problem....all machines are Dell Optiplex GX270's.

nsteussy (nic-steussy) wrote :

The double login is also happening with me. dist-upgrade from a new 7.10 install to 8.04. The double login didn't start until a few days later. Computer is a home-built using nvidia drivers.

duke out

Laszlo Kupcsik (koopac) wrote :

I upgraded to Hardy a long-long time ago. This behavior started just recently. I don't know which log would you need to fix it. It is very annoying.

Laszlo Kupcsik (koopac) wrote :

Why is the status incomplete? What does that mean?

Laszlo Kupcsik (koopac) wrote :

It has something to do with the session starting after the login. Deleting my ~/.gnome2/session file (and setting up everything again) solved the issue. No idea why.

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Intrepid Ibex. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Sebastien Bacher (seb128) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and don't hesitate to submit bug reports in the future.

Changed in gdm:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers