ctrl-alt-f7 doesn't always return to valid X session

Bug #162252 reported by Robert North on 2007-11-12
4
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
Low
Unassigned

Bug Description

Boot into X, and into user.
When doing a ctrl-alt-f<N> where N is not 7,
then on returning to X by ctrl-alt-F7, most of the time succeeds, but occasionally, I'm left with a black screen with only a cursor visible.

I'd say that this can be repeated one time in 5, and may happen every time, if to a ctrl-alt-F7, and before X has returned, to a ctrl-alt-F<N>.

This machine has recently undergone a feisty->gutsy upgrade.

I am running the nvidia-glx-new restricted drivers.

Graphics card is:

03:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce 6600 GT] (rev a2)

Please suggest what further information you need to repeat/fix this bug.
(Will attach lspci -vv soon)

Robert North (russetrob) wrote :

output from lspci -n -vv accached.

Robert North (russetrob) wrote :

Note: This dooes *not* hang the system.
Can always to a ctrl-alt-f1 and log into the console.
Can also do a ctrl-alt-delete at console to restart.

Skip VerDuin (verduin) wrote :

My IBM G40 acts the same way - except I do not know any sequence of events to guarentee the event / it appears to be random. The work around is to reboot. I believe 7.04 worked OK, and only 7.10 presents the bug -- but I can't be certain.

I am slightly troubled by new (to me) behavior in switching between VCs. I now find both ALT+CTRL+Fx and (new?) ALT+Fx work to switch between ascii consoles.

Upon reaching F7 console the display remains black with cursor and is responsive to the keyboard. There is no line prompt, and certainly the entered text is not responded to -- even special sequences except the CTRL+ALT+Fx does switch back to an ascii console. There is no screensaver or non-default setting for the GUI, and I suspect it does not matter which desktop environment is in use at the time of leaving the GUI (I use Gnome, KDE, and XMI(?)).

I've been living with this behavior for a month(?) and all available updates available today are applied (weekly since upgrade). Please advise if I can supply specific data.

graz848 (c-graz) wrote :

Confirmed. With Compiz active (haven't tried without) and nvidia-glx-new drivers, it often happens. I dare say more than 1 out of 5, maybe also 1 out of 3... it's too high to be accepted anyway IMHO. Furthermore, sometimes if I do ctrl+alt+del to restart X, after giving username and password it will not show the X session, i just remain with a brown background and the pointer alone, so the only solution is reboot.
I think this bug should be marked as higly important...
Bye

Sebastien Bacher (seb128) wrote :

thank you for your bug report, do you still have the issue in hardy or intrepid?

Changed in gdm:
importance: Undecided → Low
status: New → Incomplete

Hi Sebastian.

On Fri, 2008-08-08 at 16:36 +0000, Sebastien Bacher wrote:
> thank you for your bug report,
Sorry to have found it...

> do you still have the issue in hardy or
> intrepid?
I am now at 8.04 with kernel 2.6.24-19 and have not experienced the
problem. Having said that -- I have not had the series of multi-console
tasks to repeat recently. If the tasks had impact on the switching
behavior then I have not tested for your question.

I do notice that BOTH alt-ctrl-Fx and alt-Fx cause the switching on my
system -- I believe this violates the documentation on the subject? To
be complete in my description: alt-Fx causes switching between ASCII
consoles and "TO" the GUI on F7, but does not cause a switch "FROM" the
GUI to the ASCII consoles. Therefore the alt-Fx switch is not universal
in behavior as is the alt-ctrl-Fx keystroke.

I'd be happy to perform specific tests if it will help this cause.
Thanks for being there and involved in advancing the port.

>
> ** Changed in: gdm (Ubuntu)
> Importance: Undecided => Low
> Status: New => Incomplete
>

Warmest regards from here,
George

Sebastien Bacher (seb128) wrote :

closing since that seems to work correctly on hardy, the other issue you describe is a different one, note that those issues seem rather xorg or video driver bugs than gdm issues

Changed in gdm:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments