xdmcp server ubuntu 14.04 login error

Bug #1421325 reported by James Anderson
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
In Progress
James Anderson

Bug Description

xdmcp server ubuntu 14.04 LTS
Client side displays server log in screen correctly, however when a user name is selected or manually entered the server will not accept any password, displays authentication error and returns to main log in screen

I believe it is a configuration file issue on the server side, not sure which configuration file though.
I have tried remmina and xepher from a client Ubuntu 14.04 LTS with same results.

 apt-cache policy xdm
  Installed: (none)
  Candidate: 1:1.1.11-1ubuntu1
  Version table:
     1:1.1.11-1ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages

Revision history for this message
James Anderson (jim-255) wrote :

Just tried going the other way, just setting


on the 'workstation' computer and attempting to login from the server.
got exactly the same result.

Something else is missing and I'm not sure what that is.

Revision history for this message
James Anderson (jim-255) wrote :

Not sure weather it's a GDM OR XDM issue, judging from other issues found it looks like it's a previous GDM bug resurfaced!

affects: xdm (Ubuntu) → gdm (Ubuntu)
Revision history for this message
James Anderson (jim-255) wrote :

Further experimentation resulted in a workaround.
I switched from GDM to LIGHTDM
Configured lightdm the same as for Ubuntu 12.04
XDMCP works as documented.
I can now login to the server from any thin client terminal.

Changed in gdm (Ubuntu):
assignee: nobody → James Anderson (jim-255)
status: New → In Progress
description: updated
Revision history for this message
Michael Plotkin (plotkin) wrote :

Hello, I am also affected by this bug - cannot login using any and all XDMCP clients that I know of into my server running Ubuntu 14.04. I am reluctant to switch to lightdm from gdm for a variety of reasons. I also would like to understand how active this bug is. It seems to me that if it's a "real" bug it should affect quite a lot of people - not just 2 of us. Or are we doing something wrong in the sense of not configuring something correctly.
Thank you,

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.