gutsy: gdm greeter is crashing

Bug #138408 reported by e-r-i-k-98 on 2007-09-09
14
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
Medium
Unassigned

Bug Description

I have problemm with X
this server start crashing when it loads ubuntu and pass ubuntu splashy.
then it writes:

"
The greeter application it appears to be crasing. Attempting to use the different one.
"
and then I cannot enter ubuntu login page
also this came right when i install it, but i knew how to pass over it and I enabled auto login
but, today i disabled auto login (another user) and it started crashing. I cannot access my Ubuntu.

e-r-i-k-98 (erik98) on 2007-09-09
description: updated
Basilio Kublik (sourcercito) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it, because your description didn't include enough information.

Please include the information requested at [WWW] https://help.ubuntu.com/community/DebuggingXAutoconfiguration as separate attachments.

e-r-i-k-98 (erik98) wrote :

i just started ubuntu
there is no attachment :-@
I have only that information

I suspect this is a duplicate of Bug #144297

Could e-r-i-k-98 report hardware specs (especially graphics card type) and check Bug #144297
to see if it is the same problem. If e-r-i-k-98 has an ATI radeon graphics card then it's likely to be the same bug.

e-r-i-k-98 (erik98) wrote :

I've got ATI RADEON x700, but my motherboard is ASUS and chipset NVIDIA.

is not the same bug as Bug #144297, but it's on PC and it writes (as I said)

"The greeter application it appears to be crasing. Attempting to use the different one."

i woud need screenshot... ew......

e-r-i-k-98 (erik98) wrote :

Here is photo of window wich shows error... (hopefully: errors sux!)

Basilio Kublik (sourcercito) wrote :

Hi there
Please follow the instructions at https://help.ubuntu.com/community/DebuggingXAutoconfiguration#head-f4197decb4dc362cf69b52ec3fdc967e55b5ed15 and include the resulting files as attachments, it could also help if you include your :0.log and :20.log files from /var/log/gdm/

Basilio Kublik (sourcercito) wrote :

i forgot to ask, are you using gutsy or feisty, is this reproducible with the Gutsy Gibbon livecd?, please also include your /etc/gdm/gdm.conf file as a separate attachment.

e-r-i-k-98 (erik98) wrote :

"i forgot to ask, are you using gutsy or feisty, is this reproducible with the Gutsy Gibbon livecd?"
gutsy, non-live cd (installed)
gdm is unable, because i already installed over ubuntu stable

Changed in gdm:
importance: Undecided → Medium
jeremy-list (quick-dudley) wrote :
jeremy-list (quick-dudley) wrote :
jeremy-list (quick-dudley) wrote :
jeremy-list (quick-dudley) wrote :

Same problem, Ubuntu Feisty -> Gutsy upgrade.

X actually starts (you get an X cursor.) gdmgreeter crashes. I've worked around it by using gdmlogin (edit /etc/gdm/gdm.conf, change Greeter=/usr/lib/gdm/gdmgreeter to Greeter=/usr/lib/gdm/gdmlogin) I've tried a variety of gdmgreeter themes. I can't get gdmgreeter to log useful debug info.

Switching to gdmlogin means perfectly working X.

nardis_Miles1 (edwardsa) wrote :

Same problem. I just wanted to add that kdm is another workaround. I'm running radeon xpress 200M with a compiled ATI proprietary driver (v 8-40) on a compaq presario v5000. Finally, it seems very strange that compiz is now required for the Ubuntu desktop.

Onno Benschop (onno-itmaze) wrote :

This may or may not assist, but I saw the same behaviour as described.

In my environment, a vmware-server guest, I had cloned the machine and on the console changed its name in /etc/hostname.

The fix for me was to also change the entry in /etc/hosts.

My upgrade from Feisty to Gutsy (based on alternate install CD) crashed somewhere with a blank screen, and I had to reboot the system. Restarting the system causes the same problem, saying that greeter application fails.

I also "fixed" the issue by replacing gdmgreeter with gdmlogin in the gdm.conf configuration file.

Using on old ATI Radeon video card, but I don't think I have trouble with X, because graphics looks fine. I haven't seen problems in X log files. Where can I find more detailed logs of gdm? Can I increase verbosity of gdm?

Maybe it's caused the unfinished/uncomplete upgrade. I have discovered some strange *dpkg* files in /etc/init.d/ directory.

Changed in gdm:
assignee: sourcercito → nobody
Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Thanks in advance.

I upgraded further to Hardy Heron some time ago, and the problem went away. I guess the new release contained all the fixes. Thanks!

Pedro Villavicencio (pedro) wrote :

great, thanks for let us know. closing the report then.

Changed in gdm:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers