Ubuntu

GNOME-desktop does not lemme log in.

Reported by Shirish Agarwal on 2007-07-30
2
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: sabayon

Hi all,
         This is on gutsy gibbon 7.10 tribe 3 + updates. GDM version is 2.19.4-0ubuntu3 . Dunno if this is the right package to file it under or not, but GNOME WM fails to start/load giving a message that the session lasted only for 10 seconds & give me the following error message in x-session errors file. As I'm no X expert & have no idea which specific package should it be filed under GDM, something in GTK or in sabayon hence filing it here.

Shirish Agarwal (shirishag75) wrote :

Please dis-regard everything in XFCE-terminal as that is where I'm doing stuff from .

description: updated
Sebastien Bacher (seb128) wrote :

Thank you for your bug. Does it happen if you uninstall sabayon?

Changed in gdm:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Incomplete
Shirish Agarwal (shirishag75) wrote :

Hi Seb,
            I tried to purge/uninstall sabayon & ran into another error Bug #129421

Shirish Agarwal (shirishag75) wrote :

Oh, how I wish I could edit that comment. Anyways, I purged/uninstalled it , ran into that bug. But still shutdown & restarted again, tried to log back in but that didn't work. GDM has been updated it seems, after these series of updates are done, I'll try again & see if its still an issue.

Shirish Agarwal (shirishag75) wrote :

Just to clear the air, I have not deleted the :-

userdel: error removing directory /var/run/sabayon-admin

dunno if just deleting/removing the directory is the only thing I need to do or somethings more, looking for direction here.

Shirish Agarwal (shirishag75) wrote :

I re-did it but still come across the same issue :-

shirish@Mugglewille:~$ sudo apt-get remove --purge sabayon
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package sabayon is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
shirish@Mugglewille:~$ dpkg -l sabayon
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-======================-======================-============================================================
pn sabayon <none> (no description available)

Giving here the x-session-errors file. Could it be also due to I am using a font called bolnagri http://www.indlinux.org/blog/?p=34

could that be giving the problems ?

Shirish Agarwal (shirishag75) wrote :

GDM version got updated to 2.19.5-0ubuntu but have the same issue :( Any more ideas?

Shirish Agarwal (shirishag75) wrote :

I talked to the developer who made bolnagri, with whom we made some tests & came to the conclusion it isn't anything due to the font. The problem lies somewhere else. Will make a new user & see if the issue arises again, if it does then it definitely is some other issue , if not then its most probably an issue somewhere in the profile. Lemme see what happens & report back.

Shirish Agarwal (shirishag75) wrote :

I made a new user, didn't give it system administration otherwise everything is same. It was able to log in GNOMe (it took its own time) there is though a .xsession-errors file which I'm attaching to it. Hope it gives some idea.

Shirish Agarwal (shirishag75) wrote :

I moved all my .gnome* stuff to a new folder borked profile & was able to log in GNOME. In there it gave me the error of "OAFIID: GNOME_Keyboard Applet"

Do you want to delete this applet from your configuration. Maybe its a GNOME keyboard applet issue?

Shirish Agarwal (shirishag75) wrote :

shirish@Mugglewille:~$ aptitude search gnomekbd
i libgnomekbd-common - GNOME library to manage keyboard configuration - common f
p libgnomekbd-dev - GNOME library to manage keyboard configuration - developm
i libgnomekbd1 - GNOME library to manage keyboard configuration - shared l
p libgnomekbd1-dbgsym - debug symbols for package libgnomekbd1
p libgnomekbdui-dev - User interface library for libgnomekbd - development file
i libgnomekbdui1 - User interface library for libgnomekbd - shared library
p libgnomekbdui1-dbgsym - debug symbols for package libgnomekbdui1

Maybe one of them is responsible?

Sebastien Bacher (seb128) wrote :

Do you have any error if you run /usr/lib/gnome-applets/mixer_applet2 on a command line and then add it to the gnome-panel configuration?

Shirish Agarwal (shirishag75) wrote :

Hi Seb,
     Now after some updates it seems to be working fine. The keyboard also seems to work fine, so will be marking it invalid for now. But since you have asked me to run /usr/lib/gnome-applets/mixer_applet2 on the CLI there is no error. While trying to add it I don't see an icon for the mixer applet but all is cool. Thanx for your time & patience.

Changed in gdm:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers