GDM fails to start after system crash

Bug #1169640 reported by Forage on 2013-04-16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)

Bug Description

My system hangs every once in a while when exiting the game HoN. Usually it was fine just to reset the system, now GDM fails to start and I can't seem to fix it. We narrowed it down to what appears to be an upstart issue after some tracking with the help of a gnome dev.

I can start gdm manually as root, but during boot it only gives me "[failed]". This happens even before gdm is actually started so there are no gdm logs created. I've altered /etc/init/gdm.conf by including echo's but it never even gets to the script part on line 24. I.e. the part in which gdm actually gets started.

I've installed lightdm to get a running system again and that does work. I do, however, prefer to get gdm back, without a drastic complete system reinstall measure.

Please see the original upstream bug report for more details and things I've tried so far.

Why is upstart failing to launch gdm while it does manage to launch lightdm? What could be the cause of the problem and how do I fix it?

OS: Ubuntu 12.10 GNOME remix (x64), with all gnome3 ppa packages updated.
Upstream bug report:

Steve Langasek (vorlon) wrote :

I don't know why it's not being a started, but this would be a bug with the gdm packaging, not with upstart. Reassigning.

affects: upstart → gdm (Ubuntu)
Forage (forage) wrote :

Found and solved the issue.

/var/log/upstart/gdm.log.1.gz contained the log entries:

/proc/self/fd/9: 31: /etc/profile: [[: not found

/etc/profile ended with the invalid line:

[[ -f "/etc/autopackage/paths-bash" ]] && . "/etc/autopackage/paths-bash"

I.e. it was caused by installing autopackage.

Changed in gdm (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers