User already logged in error message sometimes, after login fails

Bug #1064394 reported by Marius B. Kotsbak on 2012-10-09
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gdm
Expired
Critical
Arch Linux
New
Undecided
Unassigned
gdm (Fedora)
Won't Fix
Undecided
gdm (Ubuntu)
High
Unassigned
gdm3 (Debian)
Fix Released
Unknown

Bug Description

Sometimes when login fails (wrong password and maybe other times as well), my user get the status already logged in, but then I am unable to log in again and have to reboot to be able to login again.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: lightdm-gtk-greeter 1.3.1-0ubuntu1
Uname: Linux 3.6.0-030600-generic i686
ApportVersion: 2.6.1-0ubuntu1
Architecture: i386
Date: Tue Oct 9 15:32:13 2012
EcryptfsInUse: Yes
SourcePackage: lightdm-gtk-greeter
UpgradeStatus: Upgraded to quantal on 2012-08-31 (39 days ago)

Marius B. Kotsbak (mariusko) wrote :
Marius B. Kotsbak (mariusko) wrote :

I was using gdm, not lightdm.

Changed in lightdm-gtk-greeter (Ubuntu):
status: New → Invalid

Description of problem:
After an authentication error, when I login using fallback GDM
I am now longer able to start a desktop session.

Version-Release number of selected component (if applicable):
gdm-3.6.0-1.fc18
gdm-3.6.1-1.fc18

How reproducible:
100%

Steps to Reproduce:
1. install f18 with gdm
2. remove gnome-shell (if necessary)
3. login with gdm fallback
4. logout
5. authenticate in gdm with wrong password
6. try to login again and wait for desktop session to start

Actual results:
6. login succeeds but gdm hangs after authentication
   showing last login failure message and/or last login info.
   User is shown as logged in with green check icon
   but desktop session does not start.
   Pressing cancel reverts to gdm login but repeating
   gives same result.

Expected results:
6. desktop session to start normally.

Additional info:
Does not happen with gnome-shell GDM.
"Workaround" is to restart gdm.

sounds similar to the earlier problems where the old session is not quite ending and keeping gdm from creating a new one.

What does loginctl list-sessions say after the logout ?
If the session you just ended still shows up, what does loginctl session-status say for it ?

Yeah somewhat similar but this happens with no prior X desktop session.

After the failed authentication, no hanging session:

# loginctl list-sessions
         1 42 gdm seat0
         2 0 root seat0

2 sessions listed.

After successful login (see screenshot attached below):

# loginctl list-sessions
         1 42 gdm seat0
         2 0 root seat0
         3 1000 petersen seat0

3 sessions listed.
# loginctl session-status 3
3 - petersen (1000)
    Since: Wed, 31 Oct 2012 21:55:35 -0400; 1min 13s ago
   Leader: 1013 (gdm-session-wor)
     Seat: seat0; vc1
  Display: :0
  Service: gdm-password; type x11; class user
    State: online
   CGroup: name=systemd:/user/petersen/3
    ├ 1013 gdm-session-worker [pam/gdm-password]
    └ 1022 /usr/bin/gnome-keyring-daemon --daemonize --login
# loginctl show-session 3
Id=3
Timestamp=Wed, 31 Oct 2012 21:55:35 -0400
TimestampMonotonic=275751659
DefaultControlGroup=name=systemd:/user/petersen/3
VTNr=1
Display=:0
Remote=no
Service=gdm-password
Leader=1013
Audit=3
Type=x11
Class=user
Active=no
State=online
KillProcesses=no
IdleHint=no
IdleSinceHint=0
IdleSinceHintMonotonic=0
Name=petersen

Created attachment 636460
screenshot of gdm hanging around after login

Pressing Cancel goes back to gdm login, but repeating the process
it is not possible to login as that user without restarting gdm.

There has been no movement on this in almost a month and no new reports. Is this still happening with F18 beta? Does it happen if fallback is forced via preferences instead of removing shell?

I'm -1 blocker, though. While it could be seen as a violation of the following F18 beta release criterion:

All release-blocking desktops' offered mechanisms (if any) for shutting down, logging out and rebooting must work.

If I'm understanding correctly, the user is logged out. They just can't log back in afterwards. I realize that I might be splitting hairs here but it wouldn't affect lives as users wouldn't usually be logging out from a live session (thus fixable with an update post-install) and sounds like it could be worked around with a system reboot or restarting gdm. I can't see blocking release for this if it were the last bug remaining.

I'm +1 NTH, though.

I broadly agree with tflink as described, but it's possible we're missing something. tentative -1 blocker / +1 nth.

Ditto. -1 blocker / +1 nth

> If I'm understanding correctly, the user is logged out.

or not yet logged in

> (thus fixable with an update post-install) and sounds like it could
> be worked around with a system reboot or restarting gdm. I can't see
> blocking release for this if it were the last bug remaining.

Agreed NTH is fine: re-proposing.

(Apart from gnome it seems only @cinnamon and @sugar use now gdm:
I changed "@basic-desktop" to use lxdm - partly because of this bug.)

-1 blocker, +1 nth

I count +4 NTH - moving to AcceptedNTH

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gdm (Ubuntu):
status: New → Confirmed
ochatard (olivier-chatard) wrote :

This bug affects me since I upgraded to Quantal.
I am using Xubuntu, with gdm 3.6.1 (64bits version).

It happens each time I previously entered a wrong password or I pressed the "Cancel" button .

This bug has been reported in other distribution :
http://debian.2.n7.nabble.com/Bug-692821-gdm3-gdm-3-6-1-2-does-not-unlock-login-keyring-td2799131.html
https://bugzilla.redhat.com/show_bug.cgi?id=868220

Dmitry Shachnev (mitya57) wrote :

Confirmed on both raring and Debian experimental. Steps to reproduce: enter a wrong password, login won't be possible after that.

no longer affects: lightdm-gtk-greeter (Ubuntu)
Changed in gdm (Ubuntu):
importance: Undecided → High

Upstream: https://bugzilla.gnome.org/show_bug.cgi?id=690803
(Cannot edit "See Also" here.)

affects: gdm (Debian) → gdm3 (Debian)
Changed in gdm3 (Debian):
importance: Undecided → Unknown
status: New → Unknown

clearing acceptednth as f18 nth is closed now, adding upstream bug number.

Changed in gdm3 (Debian):
status: Unknown → Confirmed
Changed in gdm:
importance: Unknown → Critical
status: Unknown → New
Changed in gdm3 (Debian):
status: Confirmed → Fix Released
Changed in gdm:
status: New → Expired

This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be
able to fix it before Fedora 18 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged change the 'version' to a later Fedora
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Fedora 18 changed to end-of-life (EOL) status on 2014-01-14. Fedora 18 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Changed in gdm (Fedora):
importance: Unknown → Undecided
status: Unknown → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.