nautilus no thumbnails for .jpg and .png

Bug #1665602 reported by corrado venturini on 2017-02-17
84
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
Undecided
Unassigned
gnome-desktop
Unknown
High
gdk-pixbuf (Ubuntu)
High
Unassigned

Bug Description

thumbnail for .tif is ok
corrado@corrado-z2:~$ inxi
CPU~Dual core Intel Core i3-4130 (-HT-MCP-) speed/max~3366/3400 MHz Kernel~4.10.0-8-generic x86_64 Up~1:03 Mem~983.2/7861.2MB HDD~1000.2GB(16.0% used) Procs~231 Client~Shell inxi~2.3.8
corrado@corrado-z2:~$ uname -a
Linux corrado-z2 4.10.0-8-generic #10-Ubuntu SMP Mon Feb 13 14:04:59 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
corrado@corrado-z2:~$
display was ok with kernel 4.9.0-15
corrado@corrado-z2:~$ apt-cache policy nautilus
nautilus:
  Installed: 1:3.20.3-1ubuntu4
  Candidate: 1:3.20.3-1ubuntu4
  Version table:
 *** 1:3.20.3-1ubuntu4 500
        500 http://archive.ubuntu.com/ubuntu zesty/main amd64 Packages
        100 /var/lib/dpkg/status
corrado@corrado-z2:~$

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: nautilus 1:3.20.3-1ubuntu4
ProcVersionSignature: Ubuntu 4.10.0-8.10-generic 4.10.0-rc8
Uname: Linux 4.10.0-8-generic x86_64
ApportVersion: 2.20.4-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity:Unity7
Date: Fri Feb 17 11:22:50 2017
ExecutablePath: /usr/bin/nautilus
GsettingsChanges:
 b'org.gnome.nautilus.preferences' b'default-folder-viewer' b"'list-view'"
 b'org.gnome.nautilus.preferences' b'search-view' b"'list-view'"
 b'org.gnome.nautilus.window-state' b'geometry' b"'1329x774+49+24'"
 b'org.gnome.nautilus.list-view' b'default-zoom-level' b"'larger'"
InstallationDate: Installed on 2017-01-23 (24 days ago)
InstallationMedia: Ubuntu 17.04 "Zesty Zapus" - Alpha amd64 (20170123)
SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)
usr_lib_nautilus: gnome-terminal 3.20.2-1ubuntu5

Pictures in /Pictures/boh are a fresh copy of some (same names) in /Pictures. The old ones have a visible thumbnail, the new ones have a bad thumbnail.
Also the old files in /Pictures have a good thumbnail while the new ones have a bad thumbnail.

I deleted /home/.cache/thumbnails now ALL pictures have an bad thumbnail.

my /home/Pictures/boh as view from another partition running xenial

Same problem on another zesty installed on same PC different partition
corrado@corrado-zesty:~$ inxi -Fx
System: Host: corrado-zesty Kernel: 4.10.0-8-generic x86_64 (64 bit gcc: 6.3.0)
           Desktop: Gnome (Gtk 2.24.31)
           Distro: Ubuntu Zesty Zapus (development branch)
Machine: Device: desktop Mobo: Gigabyte model: H87M-D3H v: x.x
           UEFI: American Megatrends v: F3 date: 04/24/2013
CPU: Dual core Intel Core i3-4130 (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 13567
           clock speeds: max: 3400 MHz 1: 3399 MHz 2: 3330 MHz 3: 3175 MHz
           4: 3400 MHz
Graphics: Card: Intel 4th Generation Core Processor Family Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1680x1050@59.88hz
           GLX Renderer: Mesa DRI Intel Haswell
           GLX Version: 3.0 Mesa 17.0.0 Direct Rendering: Yes
Audio: Card-1 Intel 8 Series/C220 Series High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.10.0-8-generic
Network: Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 02:00.0
           IF: enp2s0 state: up speed: 100 Mbps duplex: full
           mac: 94:de:80:7e:90:a7
Drives: HDD Total Size: 1000.2GB (2.0% used)
           ID-1: /dev/sda model: ST1000DM003 size: 1000.2GB
Partition: ID-1: / size: 32G used: 12G (38%) fs: ext4 dev: /dev/sda8
           ID-2: swap-1 size: 8.59GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 29.8C mobo: 27.8C
           Fan Speeds (in rpm): cpu: N/A
Info: Processes: 222 Uptime: 37 min Memory: 1066.4/7861.2MB
           Init: systemd runlevel: 5 Gcc sys: 6.3.0
           Client: Shell (bash 4.4.51) inxi: 2.3.8
corrado@corrado-zesty:~$

also on a different hardware with Kernel: 4.9.0-16
corrado@corrado-HP-zesty:~$ inxi -Fx
System: Host: corrado-HP-zesty Kernel: 4.9.0-16-generic x86_64 (64 bit gcc: 6.3.0)
           Desktop: Gnome (Gtk 3.22.7-1ubuntu4) Distro: Ubuntu Zesty Zapus (development branch)
Machine: Device: laptop System: Hewlett-Packard product: HP 250 G3 Notebook PC v: 0991100000000000000600087
           Mobo: Hewlett-Packard model: 2211 v: 86.49 UEFI: Insyde v: F.36 date: 12/18/2014
Battery BAT1: charge: 18.3 Wh 81.3% condition: 22.5/22.5 Wh (100%) model: 13-42 OA03031 status: Discharging
CPU: Dual core Intel Core i5-4210U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9578
           clock speeds: max: 2700 MHz 1: 999 MHz 2: 899 MHz 3: 937 MHz 4: 999 MHz
Graphics: Card: Intel Haswell-ULT Integrated Graphics Controller bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Intel Haswell Mobile GLX Version: 3.0 Mesa 13.0.4 Direct Rendering: Yes
Audio: Card-1 Intel 8 Series HD Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Haswell-ULT HD Audio Controller driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.9.0-16-generic
Network: Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: 3000 bus-ID: 08:00.0
           IF: enp8s0 state: up speed: 100 Mbps duplex: full mac: 5c:b9:01:06:ba:ce
           Card-2: Ralink RT3290 Wireless 802.11n 1T/1R PCIe driver: rt2800pci v: 2.3.0 bus-ID: 09:00.0
           IF: wlo1 state: down mac: 32:ba:0c:53:5d:44
Drives: HDD Total Size: 500.1GB (2.2% used)
           ID-1: /dev/sda model: ST500LT012 size: 500.1GB
Partition: ID-1: / size: 32G used: 6.3G (22%) fs: ext4 dev: /dev/sda4
           ID-2: swap-1 size: 4.29GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 42.0C mobo: 42.0C
           Fan Speeds (in rpm): cpu: N/A
Info: Processes: 997 Uptime: 5 min Memory: 1132.4/3881.6MB Init: systemd runlevel: 5 Gcc sys: 6.3.0
           Client: Shell (bash 4.4.51) inxi: 2.3.8
corrado@corrado-HP-zesty:~$

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Harry (harry33) wrote :

I can confirm this bug. Tiff is OK for me too.

Harry (harry33) wrote :

This may not be a nautilus bug.
It seems the bug persists even if I upgrade nautilus from the Gnome Staging PPA to either newer one:
3.22.2
3.23.90

Also thumbnails for .pdf are ok and for video .webm e .mp4

Still having the problem with a new install from last daily: Ubuntu 17.04 "Zesty Zapus" - Alpha amd64 (20170224)

BUT
Same hardware, installed on a different partition from an old daily: Ubuntu 17.04 "Zesty Zapus" - Alpha amd64 (20161106)
Dash is filled correctly - https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1661697
.local/share/zeitgeist is NOT empty. Zeitgeist starts ok
Thumbnails created correctly

I don't had the problem with an old install from: Ubuntu 17.04 "Zesty Zapus" - Alpha amd64 (20161106)
so I'm trying to give some more info.

I started with:

Ubuntu installed from: Ubuntu 17.04 "Zesty Zapus" - Alpha amd64 (20161106)
NEVER updated:
corrado@corrado-z-nov16:~$ uname -a
Linux corrado-z-nov16 4.10.0-8-generic #10-Ubuntu SMP Mon Feb 13 14:04:59 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
corrado@corrado-z-nov16:~$

attached: BeforeUpdates: log .cache .config .local inxi screenshot
thumbnails where created ok - see screenshot

Then I Run apt-get update + upgrade

attached: After1stUpdate: installer Pictures .cache .config .gconf .local varous logs
thumbnails created wrong. see last 2 thumbnails

I restarted, but ubuntu started in low graphic mode. Restarted in emergency mode. Run update + upgrade + dist-upgrade. attached: 2ndUpgrade: varoius logs.

Restart again. now all seems ok BUT thumbnails are wrong.
attached: AfterLastUpgrade: a lot of data. thumbnails wrong for .jpg and .png. Good thumbnail for .tiff

I still have a copy of the old iso: Ubuntu 17.04 "Zesty Zapus" - Alpha amd64 (20161106)
so I may reistall it and produce more doc.
Let my know if You need.
bye

Jeremy Bicha (jbicha) wrote :

New thumbnails work if I downgrade gnome-desktop3 to 3.22.2.

affects: nautilus (Ubuntu) → gnome-desktop3 (Ubuntu)
Changed in gnome-desktop3 (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Changed in gnome-desktop:
importance: Unknown → High
status: Unknown → Incomplete
Jeremy Bicha (jbicha) on 2017-02-27
affects: gnome-desktop3 (Ubuntu) → gdk-pixbuf (Ubuntu)

should i run ubuntu-bug libgdk-pixbuf ? or something like?

corrado@corrado-z-feb27:~$ apt-cache policy gdk-pixbuf*
libgdk-pixbuf2.0-0:
  Installed: 2.36.5-1
  Candidate: 2.36.5-1
  Version table:
 *** 2.36.5-1 500
        500 http://archive.ubuntu.com/ubuntu zesty/main amd64 Packages
        100 /var/lib/dpkg/status
libgdk-pixbuf2.0-common:
  Installed: 2.36.5-1
  Candidate: 2.36.5-1
  Version table:
 *** 2.36.5-1 500
        500 http://archive.ubuntu.com/ubuntu zesty/main amd64 Packages
        500 http://archive.ubuntu.com/ubuntu zesty/main i386 Packages
        100 /var/lib/dpkg/status
libgdk-pixbuf2.0-dev:
  Installed: 2.36.5-1
  Candidate: 2.36.5-1
  Version table:
 *** 2.36.5-1 500
        500 http://archive.ubuntu.com/ubuntu zesty/main amd64 Packages
        100 /var/lib/dpkg/status
libgdk-pixbuf2.0-doc:
  Installed: (none)
  Candidate: 2.36.5-1
  Version table:
     2.36.5-1 500
        500 http://archive.ubuntu.com/ubuntu zesty/main amd64 Packages
        500 http://archive.ubuntu.com/ubuntu zesty/main i386 Packages
ruby-gdk-pixbuf2:
  Installed: (none)
  Candidate: 3.1.0-1
  Version table:
     3.1.0-1 500
        500 http://archive.ubuntu.com/ubuntu zesty/universe amd64 Packages
        500 http://archive.ubuntu.com/ubuntu zesty/universe i386 Packages
corrado@corrado-z-feb27:~$

Jeremy Bicha (jbicha) wrote :

corrado, thanks for your help.

I've already identified the problem (2 files weren't being installed by gdk-pixbuf) and I'm coordinating the fix with Debian.

Changed in gnome-desktop:
status: Incomplete → Unknown

Same problem on Ubuntu 17.04 GNOME
corrado@corrado-z-gnome:~$ inxi -Fx
System: Host: corrado-z-gnome Kernel: 4.10.0-11-generic x86_64 (64 bit gcc: 6.3.0)
           Desktop: Gnome 3.23.91 (Gtk 2.24.31)
           Distro: Ubuntu Zesty Zapus (development branch)
Machine: Device: desktop Mobo: Gigabyte model: H87M-D3H v: x.x
           UEFI: American Megatrends v: F3 date: 04/24/2013
CPU: Dual core Intel Core i3-4130 (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 13568
           clock speeds: max: 3400 MHz 1: 1605 MHz 2: 1468 MHz 3: 1399 MHz
           4: 1919 MHz
Graphics: Card: Intel 4th Generation Core Processor Family Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 driver: N/A
           Resolution: 1680x1050@59.88hz
           GLX Renderer: Mesa DRI Intel Haswell
           GLX Version: 3.0 Mesa 13.0.4 Direct Rendering: Yes
Audio: Card-1 Intel 8 Series/C220 Series High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.10.0-11-generic
Network: Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 02:00.0
           IF: enp2s0 state: up speed: 100 Mbps duplex: full
           mac: 94:de:80:7e:90:a7
Drives: HDD Total Size: 1000.2GB (13.8% used)
           ID-1: /dev/sda model: ST1000DM003 size: 1000.2GB
Partition: ID-1: / size: 32G used: 7.7G (26%) fs: ext4 dev: /dev/sda8
           ID-2: swap-1 size: 8.59GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 29.8C mobo: 27.8C
           Fan Speeds (in rpm): cpu: N/A
Info: Processes: 268 Uptime: 3:07 Memory: 1504.2/7861.2MB
           Init: systemd runlevel: 5 Gcc sys: 6.3.0
           Client: Shell (bash 4.4.51) inxi: 2.3.8
corrado@corrado-z-gnome:~$

Jeremy Bicha (jbicha) wrote :

Yes, the bug fix is identified but not in Ubuntu 17.04 yet. I have been trying but I don't have direct upload rights for this package.

Jeremy Bicha (jbicha) wrote :

This bug is fixed in Debian's svn repository. It is in the new queue for Debian experimental.

Changed in gdk-pixbuf (Ubuntu):
status: Triaged → Fix Committed
Changed in ubuntu-gnome:
status: New → Fix Committed
milestone: none → zesty
ubu4 (supergaga76) wrote :

Also file.nef are ok ( i think because works through raw-thambnailer)

file.nrw no working ( it is a raw nikon's format never worked on previous distro ...still not working)

No way to show .png jpg jpeg gif

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdk-pixbuf - 2.36.5-3

---------------
gdk-pixbuf (2.36.5-3) experimental; urgency=medium

  [ Jeremy Bicha ]
  * Add new libgdk-pixbuf2.0-bin package to install thumbnailer
    binary and metadata needed by gnome-desktop 3.23 (LP: #1665602)
  * Have libgdk-pibxuf2.0-0 recommend libgdk-pixbuf2.0-bin
  * debian/rules: Change dh_install's --list-missing to --fail-missing to
    catch this issue sooner next time

  [ Iain Lane ]
  * debian/rules: Don't use -X.la - it's error prone as it does substring
    matching instead of globbing. Instead use `find ... -delete' to remove
    *.la files explicitly.
  * debian/control.*: Update Vcs-* for branch.

 -- Jeremy Bicha <email address hidden> Tue, 14 Mar 2017 16:05:47 +0000

Changed in gdk-pixbuf (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.