gdesklets cannot start, looking for tiling module

Bug #569714 reported by Ben Aceler on 2010-04-25
244
This bug affects 54 people
Affects Status Importance Assigned to Milestone
gdesklets (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gdesklets

aceler@aceler-desktop:~$ LANG=C gdesklets
Starting gdesklets-daemon...
Connecting to daemon [ ### ]
==========================================================[04/25/10-14:37:29]===
Could not import tiling module!

Cannot establish connection to daemon: timeout!
The log file might help you solving the problem.

There is no any logs in ~/.gdesklets/logs/

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gdesklets (not installed)
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sun Apr 25 14:28:39 2010
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Release Candidate amd64 (20100419)
ProcEnviron:
 LANGUAGE=
 PATH=(custom, user)
 LANG=ru_RU.utf8
 SHELL=/bin/bash
SourcePackage: gdesklets

See also bug #344079. The "_new_imp() takes at most 4 arguments (5 given)" message described there appears on Lucid-rc (amd64) when trying to run "gdesklets shell".

Changed in gdesklets (Ubuntu):
status: New → Confirmed

with the repository version gdesklets/lucid uptodate 0.36.1-4 I get this bug. When I do a no change rebuild of the same package it works fine

Greg (gsmorgansen) wrote :

What is a "no change rebuild"?

Greg

Bill Traynor (wmat) wrote :

1. I got gdesklets 0.36.1 working on Lucid (after upgrading) by applying the fix described here:
http://forum.linuxmint.com/viewtopic.php?f=90&t=32554

or to avoid the jump:
sudo cp /usr/lib/gdesklets/utils/ErrorFormatter.py /usr/lib/gdesklets/utils/ErrorFormatter.py.orig
sudo vi /usr/lib/gdesklets/utils/ErrorFormatter.py

# 09/08/09:per article=http://forums.opensuse.org/applications/409465-fix-gdesklets.html
#def _new_imp(name, globs = {}, locls = {}, fromlist = []):
def _new_imp(name, globs = {}, locls = {}, fromlist = [], test = []):

2. Starting $gdesklets shell then spews a warning, but still starts:

/usr/lib/gdesklets/utils/ErrorFormatter.py:119: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  module = _old_imp(name, globs, locls, fromlist)

3. Also, Log messages show:
/usr/lib/gdesklets/config/ConfigDialog.py:77: DeprecationWarning: Use the new widget
gtk.Tooltip
  self.__tooltips = gtk.Tooltips()
/usr/lib/gdesklets/config/ConfigDialog.py:78: DeprecationWarning: Use the new widget
gtk.Tooltip
  self.__tooltips.enable()

Hope this helps.

Cheers
Bill

adamberdanda (pippo23) wrote :

I patched ErrorFormatter.py, i tried to rebuild the package too but it didn't solved the problem, I always get the tiling module error.

Lucid Lynxs 2.6.32-22-generic i686

adamberdanda (pippo23) wrote :

sorry, it works after deleting all files of the previous compiled versions

Ahmed Osman (ashex) wrote :

I ran into this bug, it's an incompatibility issue with Python 2.6

See following post: http://forums.fedoraforum.org/showpost.php?p=1283301&postcount=5

Péter (fourdots) wrote :

According to this announcement..
https://launchpad.net/gdesklets/+announcement/5333
0.36.2 has been out since Feb 2010!

And this link talks about future development.. 0.36.3, 0.37. So the project is not dead, yet.

Face it. 0.36.1-4 from the repo is BROKEN - It does not work out-of-the-(box)-repo, and thus, does not belong there.

Perhaps we should forget about patches and workarounds and simply package 0.36.2 for distribution.

Who's up for it? ;-)

Péter (fourdots) wrote :

Forgot the link (future development) -> http://www.gdesklets.info/archive/whatsnew/0.36.2/index.html

Bjoern Koch (h.humpel) wrote :

> And this link talks about future development.. 0.36.3, 0.37. So the project is not dead, yet.

Actually we are going to release 0.36.3 soon. 0.36.3-rc1 will be out in a few days for testing (hopefully).

> Face it. 0.36.1-4 from the repo is BROKEN - It does not work out-of-the-(box)-repo, and thus, does not belong there.

Thanks! You hit the nail on the head!
We really don't know why ubuntu is (still) shipping an old AND broken version of gdesklets.
Most of the bugs reported are ubuntu related. But unfortunatley we can't change it either.

> Perhaps we should forget about patches and workarounds and simply package 0.36.2 for distribution.

Very good idea. We have been looking for someone to set up a PPA for a few month now.
Right now it looks like the current / remaining gDesklets' developers are all running gentoo...

JW (arch0njw) wrote :

Can confirm issue here.

Can also confirm fixing it is a matter of editing line 116 of /usr/lib/gdesklets/utils/ErrorFormatter.py as follows:

#def _new_imp(name, globs = {}, locls = {}, fromlist = []):
def _new_imp(name, globs = {}, locls = {}, fromlist = [], test = []):

juliobahar (yahalla-julio) wrote :

@ JW

Wow impressive solution finally got gDesklets to run on ubuntu 10.10 32-bit. On my Toshiba A55 Satellite laptop.
Gonna do the same on my more advanced Desktop running 10.04.
Thanks

kung (binbin222-tw) on 2015-03-29
no longer affects: gdesklets
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions