gDesklets can't be started. Unhandled error!

Bug #550613 reported by Joel Gabor on 2010-03-29
66
This bug affects 13 people
Affects Status Importance Assigned to Milestone
gDesklets
Undecided
Unassigned
gdesklets (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by Joel Gabor

Bug Description

Binary package hint: gdesklets

I can't start gDesklets. I got the following error:

$ gdesklets

==========================================================[03/29/10-03:27:13]===
=== Unhandled error! Something bad and unexpected happened. ===

[EXC]_new_imp() takes at most 4 arguments (5 given)
in /usr/bin/gdesklets: line 3 <module>
in /usr/lib/gdesklets/main/__init__.py: line 52 <module>
in /usr/lib/gdesklets/utils/i18n.py: line 23 Translator
in /usr/lib/python2.6/gettext.py: line 493 translation
in /usr/lib/python2.6/gettext.py: line 180 __init__
in /usr/lib/python2.6/gettext.py: line 315 _parse
in /usr/lib/python2.6/gettext.py: line 100 c2py
[EXC]/usr/lib/python2.6/gettext.py

[---] 95 # Replace some C operators by their Python equivalents
[---] 96 plural = plural.replace('&&', ' and ')
[---] 97 plural = plural.replace('||', ' or ')
[---] 98
[---] 99 expr = re.compile(r'\!([^=])')
[ERR]> 100 plural = expr.sub(' not \\1', plural)
[---] 101
[---] 102 # Regular expression and replacement function used to transform
[---] 103 # "a?b:c" to "test(a,b,c)".
[---] 104 expr = re.compile(r'(.*?)\?(.*?):(.*)')
[---] 105 def repl(x):
[---] 106 return "test(%s, %s, %s)" % (x.group(1), x.group(2),

_______________________________
System info:

$ lsb_release -rd
Description: Ubuntu lucid (development branch)
Release: 10.04

$ apt-cache policy gdesklets
gdesklets:
  Installed: 0.36.1-4
  Candidate: 0.36.1-4
  Version table:
 *** 0.36.1-4 0
        500 http://de.archive.ubuntu.com/ubuntu/ lucid/universe Packages
        100 /var/lib/dpkg/status

Joel Gabor (joelgabor) on 2010-03-29
tags: added: gdesklets
tags: added: python
timosha (timosha) wrote :

Same problem here on 5 PC's and 1 VMWare installation. Reverted to version 0.36.1-3 which works fine in Ubuntu Lucid.

Joel Gabor (joelgabor) wrote :

I've dual monitor config. I thought dual monitor xorg affected this bug. (There was several similar bug because of dual mon conf). I changed to single monitor, but gDesklet has the same problem.

lizardmenke (lizardmenke) wrote :

Same problem here.
Can anybody tell me where i can find a 0.36.1-3.deb ??
I'd sure like to run my gdesklets.

Joe Sapp (sappj) wrote :

You will probably get better results by compiling your own. Additionally, you will get some bugfixes by upgrading to 0.36.2: http://www.gdesklets.info/archive/gDesklets/index.html

Bjoern Koch (h.humpel) wrote :

This bug has been fixed in rev. #118 (2009-05-12) of the gDesklets 0.3x branch here at launchpad (https://launchpad.net/gdesklets/0.3x).
It has been released with gDesklets 0.36.2(-rc1).
Furthermore it looks - more or less - like a duplicate of bug #344079.

Changed in gdesklets:
status: New → Fix Released
Bjoern Koch (h.humpel) wrote :

Upps... sorry... here is the link to the 0.3x branch (code):
https://code.launchpad.net/~gdesklets-core-team/gdesklets/0.3x

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gdesklets (Ubuntu):
status: New → Confirmed
Joe Sapp (sappj) on 2011-10-07
Changed in gdesklets:
milestone: none → release-of-0.36.4
milestone: release-of-0.36.4 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions