gdecrypt does not start - window appears for a blink, thats it. If I run gdecrypt in the console it says "/usr/bin/env: python2.5: No such file or directory"

Bug #574237 reported by mayleen on 2010-05-03
70
This bug affects 13 people
Affects Status Importance Assigned to Milestone
gdecrypt (Ubuntu)
Medium
Unassigned
Lucid
Medium
Unassigned

Bug Description

Binary package hint: gdecrypt

Run on console it gives me a
"/usr/bin/env: python2.5: No such file or directory"

gdecrypt was installed from the common Ubuntu Repos for 10.04

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gdecrypt 0.7.2.2-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
Architecture: i386
CheckboxSubmission: feeee488594257b6e2ea1d1b0a8d8f6e
CheckboxSystem: 669b662da410063cc918e0f60cf6cddf
Date: Mon May 3 09:05:07 2010
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
PackageArchitecture: all
ProcEnviron:
 LANG=de_DE.utf8
 SHELL=/bin/bash
SourcePackage: gdecrypt

Related branches

mayleen (der-feindliche-spunk) wrote :
Changed in gdecrypt (Ubuntu):
status: New → Confirmed
Luca Borrione (luca.borrione) wrote :

exactly the same here!

gdecrypt 0.7.2.2-0ubuntu4 on lucid (Linux 2.6.32-21-generic i686)

Inox (inox) wrote :

First line of both main.py and createui.py (located @ /usr/share/gdecrypt) should be changed from:

#!/usr/bin/env python2.5

to:

#!/usr/bin/env python2.6

It could help people with hal package installed. However hal is deprecated in Ubuntu 10.04.

Jordan Farrell (feralbytes) wrote :

So is this really the correct place for this bug to be posted or should it be directly under the project "GDecrypt". Since the current development branch is the last release branch and the same as this Ubuntu package.

Jordan Farrell (feralbytes) wrote :

By the way Inox's change resolves the issue, I am working to see if we can get the current release updated for Ubuntu 10.04+.

#!/usr/bin/env python2.5
Changed to:
#!/usr/bin/env python2.6
In both main.py and createui.py (located @ /usr/share/gdecrypt)

Changed in gdecrypt (Ubuntu):
importance: Undecided → High
importance: High → Medium
Changed in gdecrypt (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdecrypt - 0.7.2.2-0ubuntu5

---------------
gdecrypt (0.7.2.2-0ubuntu5) maverick; urgency=low

  [ Draycen DeCator ]
  * Call python instead of python2.5 (LP: #574237)
    - update createui.py
    - update main.py

  [ Stefano Rivera ]
  * Convert to 3.0 (quilt)
    - Convert Draycen's change to a quilt patch.
  * Convert rules to dh.
  * Bump Debhelper compatibility level to 7.
  * Convert copyright to dep5.
  * Bump Standards-Version to 3.9.0 (no changes needed).
  * Merge Build-Depends{,-Indep} - arch all package.
 -- Stefano Rivera <email address hidden> Sun, 18 Jul 2010 23:08:52 +0200

Changed in gdecrypt (Ubuntu):
status: Fix Committed → Fix Released
Narcis Garcia (narcisgarcia) wrote :

Using Ubuntu Lucid.
In the updated repositories I only find 0.7.2.2-0ubuntu4
In "ubuntu-proposed" I don't see any update for gdecrypt.

Narcis Garcia (narcisgarcia) wrote :

I've patched manually the problem editing the file /usr/share/gdecrypt/main.py and changing the first line:

#!/usr/bin/env python2.5

By:
#!/usr/bin/env python2

Stefano Rivera (stefanor) wrote :

In "ubuntu-proposed" I don't see any update for gdecrypt.

That's because it was fixed in Maverick, not Ubuntu. I've uploaded to lucid-proposed now. It's pending Ubuntu SRU team verification, which will be announced here.

Changed in gdecrypt (Ubuntu Lucid):
importance: Undecided → Medium
status: New → Fix Committed

Accepted gdecrypt into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed

SRU verification for Lucid:
I have reproduced the problem with gdecrypt 0.7.2.2-0ubuntu4 in lucid and have verified that the version of gdecrypt 0.7.2.2-0ubuntu4.1 in -proposed fixes the issue.

Marking as verification-done

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdecrypt - 0.7.2.2-0ubuntu4.1

---------------
gdecrypt (0.7.2.2-0ubuntu4.1) lucid-proposed; urgency=low

  * Change shebang to use unversioned python. Thanks to Draycen DeCator for
    the patch. (LP: #574237)
 -- Stefano Rivera <email address hidden> Mon, 27 Sep 2010 11:58:19 +0200

Changed in gdecrypt (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers