gdebi-gtk crashed with ValueError in open(): Unable to parse section data

Bug #980457 reported by Logan Rosen
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gdebi (Ubuntu)
Fix Released
Medium
Unassigned

Bug Description

Happens whenever I try to open http://iwscanner.googlecode.com/files/iwscanner-0.2.1.deb using GDebi. I suspect there's something wrong with the package (as Ubuntu Software Error says there's something wrong with the package), but GDebi shouldn't be outright crashing upon opening it.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: gdebi 0.8.5build1
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
ApportVersion: 2.0.1-0ubuntu2
Architecture: amd64
CrashCounter: 1
Date: Thu Apr 12 22:28:29 2012
ExecutablePath: /usr/share/gdebi/gdebi-gtk
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120309)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/gdebi-gtk /home/username/Downloads/iwscanner-0.2.1.deb
PythonArgs: ['/usr/bin/gdebi-gtk', '/home/username/Downloads/iwscanner-0.2.1.deb']
SourcePackage: gdebi
Title: gdebi-gtk crashed with ValueError in open(): Unable to parse section data
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Revision history for this message
Logan Rosen (logan) wrote :
tags: removed: need-duplicate-check
Logan Rosen (logan)
visibility: private → public
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gdebi (Ubuntu):
status: New → Confirmed
Changed in gdebi (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Luca Falavigna (dktrkranz) wrote :
Changed in gdebi (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdebi - 0.8.5ubuntu1

---------------
gdebi (0.8.5ubuntu1) quantal; urgency=low

  * gdebi, GDebi/GDebiCli.py:
    - Return dpkg error code (LP: #1033631).
  * gdebi-gtk, gdebi-kde:
    - Convert help options with unicode (LP: #976253).
  * GDebi/GDebi.py:
    - Port to new GIO API (LP: #858700).
  * GDebi/GDebi.py, data/gdebi.ui:
    - Mark menu and labels as sensitive at startup (LP: #1000014).
  * GDebi/GDebiCli.py, GDebi/GDebiCommon.py:
    - Also handle ValueError exception (LP: #980457).
  * GDebi/GDebiKDE.py:
    - Fall-back on kdesu if kdesudo is not available (LP: #949869).
  * debian/control:
    - Add xz-utils to gdebi-core Suggests field (Closes: #685193).
  * po/pt.po:
    - Fix translation string which erroneously used three format string
      parameters instead of two (LP: #964895).
 -- Luca Falavigna <email address hidden> Sat, 22 Sep 2012 15:21:29 +0200

Changed in gdebi (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers