gdebi-kde should call kdesudo, not kdesu

Bug #600644 reported by cpatrick08 on 2010-07-01
114
This bug affects 15 people
Affects Status Importance Assigned to Milestone
gdebi (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gdebi

it loads the package but when i click on install nothing happens i am running kubuntu 10.10 alpha 2

tags: added: iso-testing
Jonathan Thomas (echidnaman) wrote :

The kdesu call needs to be replaced by kdesudo:

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/GDebi/GDebiKDE.py", line 289, in installButtonClicked
    os.execl("/usr/bin/kdesu", "kdesu", executable + " -n ", self._deb.file)
  File "/usr/lib/python2.6/os.py", line 312, in execl
    execv(file, args)
OSError: [Errno 2] No such file or directory

Changed in gdebi (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
summary: - cant install .deb files
+ gdebi-kde should call kdesudo, not kdesu
Luca Falavigna (dktrkranz) wrote :
Changed in gdebi (Ubuntu):
status: Triaged → Fix Committed
罗中和 (asluozijun) wrote :

  I don't know what's happed? now i install soft i need go Gnome...TTTT.i don't wanna kill my system...

Now in KDE i can't install ....

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdebi - 0.6.2

---------------
gdebi (0.6.2) unstable; urgency=low

  [ Michael Vogt ]
  * use DebPackage from python-apt and depend on python-apt >= 0.7.96
  * merged lp:~kiwinote/gdebi/use-python-apt (with some minor
    modifcations)

  [ Luca Falavigna ]
  * GDebi/GDebiKDE.py:
    - Use kdesudo instead of kdesu in Ubuntu (LP: #600644).
 -- Michael Vogt <email address hidden> Wed, 04 Aug 2010 20:55:00 +0100

Changed in gdebi (Ubuntu):
status: Fix Committed → Fix Released
Dan Martin (ifindoubtflatout) wrote :

Hi

I have this problem. Tried to download Google Chrome (I know I know...) and LimeWire (separately) and I get the message,

"Only one software manager (or management) can run at any one time"

Can you help, the same problem for many other types of files not just .deb

Thanks in advance

Dan Martin (ifindoubtflatout) wrote :

Might as well throw this in as well before someone answers. Tried to run a malware checker today (.exe file) and got this :

 End-of-central-directory signature not found. Either this file is not
  a zipfile, or it constitutes one disk of a multi-part archive. In the
  latter case the central directory and zipfile comment will be found on
  the last disk(s) of this archive.
zipinfo: cannot find zipfile directory in one of

Please don't make me go back to MS....

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers