gdebi-gtk crashed with DebError in compressed_part_name()

Bug #407198 reported by DougieFresh4U
324
This bug affects 62 people
Affects Status Importance Assigned to Milestone
gdebi (Ubuntu)
Undecided
Unassigned
python-debian (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gdebi

Using 64 bit Karmic, downloaded the wine package and when gdebi opened then crashed

ProblemType: Crash
Architecture: amd64
Date: Thu Jul 30 22:24:28 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/gdebi-gtk
InterpreterPath: /usr/bin/python2.6
Package: gdebi 0.5.2
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/gdebi-gtk /tmp/wine1.2_1.1.26-0ubuntu1_amd64.deb
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-4.23-generic
PythonArgs: ['/usr/bin/gdebi-gtk', '/tmp/wine1.2_1.1.26-0ubuntu1_amd64.deb']
SourcePackage: gdebi
Title: gdebi-gtk crashed with DebError in compressed_part_name()
Uname: Linux 2.6.31-4-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Revision history for this message
DougieFresh4U (butcheeyboy) wrote :
tags: removed: need-duplicate-check
visibility: private → public
Brian Curtis (bcurtiswx)
Changed in gdebi (Ubuntu):
status: New → Confirmed
Revision history for this message
CydeSwype (ircone) wrote :

Same error on 32-bit arch when trying to install the development build of Google Chrome.

Revision history for this message
Thomas Grim (thomas-grim) wrote :

Same error for me, on a 32-bits arch and, just like CydeSwype, with the GoogleChrome deb installer.

Revision history for this message
Bulat Nigmatullin (bulatka) wrote :

Same error when i tried to install Google Chrome from google-chrome-unstable_current_i386.deb

Revision history for this message
Yunkwan (chanyunkwan0217) wrote :

same error when I was trying to install the deb package I compiled.
it crashes before the install button shows up.

i386 arch
karmic alpha4

Revision history for this message
wld1055 (wld1055) wrote :

Same error on 32-bit arch when trying to install the development build of Google Chrome.

Revision history for this message
Abdur-Rahman Rozell (aryr100) wrote :

same with ubuntu alpha 4 with all updates applied installing Google Chrome

Revision history for this message
Philippe Le Rohellec (philippe-lerohellec) wrote :
Revision history for this message
Fabian (fabian-h) wrote :

I've found the problem with the packages that fail to install. Both Wine and Chrome debs contain a "data.tar.lzma", but GDebi only checks for gz and bz2 file extensions. I don't know anything about deb packages, so maybe the packages don't conform to the specification, but GDebi should be able to open these packages anyway.

How to fix:

In the file
/usr/lib/pymodules/python2.6/debian_bundle/debfile.py

change on line 29
PART_EXTS = ['gz', 'bz2'] # possible extensions
to
PART_EXTS = ['gz', 'bz2', 'lzma'] # possible extensions

Revision history for this message
ChrisTomalty (christomalty-deactivatedaccount) wrote :

Error confirmed on Ubuntu 9.10 64 bit, fully patched as of 10:30 pm EST

Tried to install Google Chrome and Gdebi immediately failed.

My computer is a Dell Inspiron 1525 with an Intel Core2Duo processor and 4 GB of RAM.

Revision history for this message
Stephen Hall (stephenhall) wrote :

The issue only appears to affect gdebi-gtk. The CLI install works fine, e.g.

me@my-laptop:~$ cd Downloads/
me@my-laptop:~/Downloads$ sudo gdebi google-chrome-unstable_current_i386.deb

Chrome installs successfully.

Revision history for this message
kshitij (kraranke) wrote : Re: [Bug 407198] Re: gdebi-gtk crashed with DebError in compressed_part_name()

Thanks!

2009/8/28 Stephen Hall <email address hidden>

> The issue only appears to affect gdebi-gtk. The CLI install works fine,
> e.g.
>
> me@my-laptop:~$ cd Downloads/
> me@my-laptop:~/Downloads$ sudo gdebi
> google-chrome-unstable_current_i386.deb
>
> Chrome installs successfully.
>
> --
> gdebi-gtk crashed with DebError in compressed_part_name()
> https://bugs.launchpad.net/bugs/407198
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “gdebi” package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: gdebi
>
> Using 64 bit Karmic, downloaded the wine package and when gdebi opened then
> crashed
>
> ProblemType: Crash
> Architecture: amd64
> Date: Thu Jul 30 22:24:28 2009
> DistroRelease: Ubuntu 9.10
> ExecutablePath: /usr/bin/gdebi-gtk
> InterpreterPath: /usr/bin/python2.6
> Package: gdebi 0.5.2
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python /usr/bin/gdebi-gtk
> /tmp/wine1.2_1.1.26-0ubuntu1_amd64.deb
> ProcEnviron:
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-4.23-generic
> PythonArgs: ['/usr/bin/gdebi-gtk',
> '/tmp/wine1.2_1.1.26-0ubuntu1_amd64.deb']
> SourcePackage: gdebi
> Title: gdebi-gtk crashed with DebError in compressed_part_name()
> Uname: Linux 2.6.31-4-generic x86_64
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>

Michael Vogt (mvo)
Changed in gdebi (Ubuntu):
status: Confirmed → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-debian - 0.1.14ubuntu1

---------------
python-debian (0.1.14ubuntu1) karmic; urgency=low

  * Add .lzma as a possible extenstion for data.tar (LP: #407198)
    Note that this does not mean that reading from the .lzma part
    is supported. This is blocked on http://bugs.python.org/issue5689

 -- Michael Vogt <email address hidden> Tue, 01 Sep 2009 11:08:07 +0200

Changed in python-debian (Ubuntu):
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdebi - 0.5.5

---------------
gdebi (0.5.5) karmic; urgency=low

  * GDebi/GDebi.py:
    - do not crash if the filelist can not be read (LP: #407198)
    - avoid busy loop
  * gdebi-gtk:
    - add --auto-close commandline option

 -- Michael Vogt <email address hidden> Tue, 01 Sep 2009 11:07:05 +0200

Changed in gdebi (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
James Westby (james-w) wrote :

Michael, did you get this patch in to Debian's python-debian? I can commit
it there if you like?

Thanks,

James

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.