Issue if installed by gdebi as a dependency

Bug #367959 reported by Vadim Peretokin on 2009-04-27
2
Affects Status Importance Assigned to Milestone
Gnome Virtual Terminal Emulator
Expired
Medium
gdebi (Ubuntu)
Medium
Michael Vogt

Bug Description

Binary package hint: postfix

If postfix gets dragged in as a dependency by gdebi, it does not open a graphical configuration window but a terminal one.

Since gdebi's terminal is closed by default, the user might spend a lot of time waiting and wondering why isn't anything being installed, while postfix is waiting for user input.

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: postfix 2.5.5-1.1
ProcEnviron:
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: postfix
Uname: Linux 2.6.28-11-generic x86_64

Related branches

Vadim Peretokin (vperetokin) wrote :
Scott Kitterman (kitterman) wrote :

Not a postfix bug.

affects: postfix (Ubuntu) → gdebi (Ubuntu)
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

gdebi sets DEBIAN_FRONTEND=gnome - was perl-gtk2 installed when you ran into this bug?

Changed in gdebi (Ubuntu):
status: New → Incomplete
Michael Vogt (mvo) wrote :

I can confirm this here

Changed in gdebi (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
importance: Undecided → Medium
status: Incomplete → In Progress
Changed in vte:
status: Unknown → New
Michael Vogt (mvo) on 2009-07-17
Changed in gdebi (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdebi - 0.5.0

---------------
gdebi (0.5.0) karmic; urgency=low

  [ Anders Kaseorg ]
  * GDebi/DebPackage.py:
    - Look for Pre-Depends instead of PreDepends. (Closes: #435577)
      (LP: #392714)

  [ Michael Vogt ]
  * GDebi/DebPackage.py:
    - fix typo (LP: #387022)
  * data/gdebi-kde.desktop:
    - increase initialPreference value (LP: #379150)
  * data/gdebi.ui:
    - ported to GtkBuilder
  * fix crash because we made the window sensitive too early
    (LP: #355268)
  * do not resolve versionized dependencies with virtual
    packages (LP: #373154)
  * honor "GDEBI_DEBUG_LEVEL" environment var
  * GDebi/GDebi.py:
    - workaround bug in vte where forkpty() does not pass the
      environment (LP: #367959)
    - set the image in the gtkbuilder file, hopefully fixes
      (LP: #345260)
  * debian/rules:
    - build with DY_PYCENTRAL=include-links

 -- Michael Vogt <email address hidden> Thu, 16 Jul 2009 21:06:27 +0200

Changed in gdebi (Ubuntu):
status: Fix Committed → Fix Released
Changed in vte:
importance: Unknown → Medium
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.