Gdebi crash in Ubuntu Studio 18.04

Bug #1760910 reported by Phelps Scofield
This bug affects 12 people
Affects Status Importance Assigned to Milestone
gdebi (Ubuntu)

Bug Description

Gdebi opens normal, but when you click install package, it closes.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: gdebi
ProcVersionSignature: Ubuntu 4.15.0-13.14-lowlatency 4.15.10
Uname: Linux 4.15.0-13-lowlatency x86_64
ApportVersion: 2.20.9-0ubuntu2
Architecture: amd64
CurrentDesktop: XFCE
Date: Tue Apr 3 12:31:17 2018
InstallationDate: Installed on 2018-03-29 (4 days ago)
InstallationMedia: Ubuntu-Studio 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180328)
PackageArchitecture: all
 PATH=(custom, no user)
SourcePackage: gdebi
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Phelps Scofield (phelpsscofield) wrote :
Revision history for this message
Hans Joachim Desserud (hjd) wrote :

Thanks for taking your time to report this issue and help making Ubuntu better.

Do you see any error-messages when the program closes, for instance if you run `gdebi-gtk` from a terminal? I found bug 1756238 where gdebi failed to work on Ubuntu bionic. It might be a duplicate of that, but on the other hand some of the comments indicate that issue has been resolved...

Revision history for this message
Phelps Scofield (phelpsscofield) wrote :

What is happening is that I can run or run gdebi normally through the terminal or right-click and install the deb package with gdebi and it runs gdebi normally, but when I click install package gdebi closes.It is a bug other than bug 1756238. .

Revision history for this message
Phelps Scofield (phelpsscofield) wrote :

Yes, I was able to install the deb package by running the gdebi-gtk package in terminal mode using sudo. But it would not be a good procedure for a beginner, since gdebi was made for this, install deb packages and dependencies in graphical mode.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gdebi (Ubuntu):
status: New → Confirmed
Revision history for this message
Mark-pcnetspec (mark-pcnetspec) wrote :

If you edit the:-
launchers 'Exec' line to:-

Exec=gksudo gdebi-gtk %f

So gdebi-gtk prompts for the password BEFORE loading, it works perfectly .. maybe a pkexec issue ?

Revision history for this message
Phelps Scofield (phelpsscofield) wrote :

I tried putting this command on the launcher inside the /usr/share/applications/gdebi.desktop folder, but it did not work.

Revision history for this message
Mark-pcnetspec (mark-pcnetspec) wrote :


gksudo gedit /usr/share/applications/gdebi.desktop

make it read:-

[Desktop Entry]
Name=GDebi Package Installer
GenericName=Package Installer
Comment=Install and view software packages
Exec=gksudo gdebi-gtk %f

SAVE the file.

Now try right-clicking a .deb and selecting "Open with > GDebi Package Installer"

Revision history for this message
Phelps Scofield (phelpsscofield) wrote :

It worked, thank you very much.

Revision history for this message
Darin (newhoa) wrote :

Let me know if this is a different bug and I will file another report, but I think that it's the same.

I open a .deb with gdebi-gtk. The GUI opens. I click "Install" and gdebi simply closes.

If I open a terminal and type gdebi-gtk path/to/deb.deb it opens the deb in the GUI and when I hit install, it actually installs.

The method of adding gksu above doesn't work for me and most others because gksu is deprecated and not installed in Ubuntu anymore by default. It's a good workaround for those who can use it but it still need fixing.

I'm using gdebi and Xubuntu 18.04 (upgraded from 17.10 if that makes any difference).

Revision history for this message
Francis Marsden (marsdenf) wrote :

Same problem here, using Xubuntu 18.04. (Clean install, not upgrade) If I click on a .deb file and choose "open with gdebi", the gui opens and checks for depencies, but when "install" is clicked the gui disappears (crashes). But if I open gdebi via terminal, it works fine.

Revision history for this message
Francis Marsden (marsdenf) wrote :

I found a solution. Installed package " lxqt-sudo " using synaptic and changed the exec line in gdebi.desktop to " Exec=lxqt-sudo gdebi-gtk %f " and now gdebi works ok. Is it safe in general to use lxqt-sudo for graphical applications in Xubuntu 18.04?

Revision history for this message
Victor (victorp-info) wrote :

In researches in forums, the change that affects the gdebi was the discontinuation of the gksu package. They are currently using the admin: // command from the gvfs package. How can I use it to solve this problem?

Revision history for this message
Victor (victorp-info) wrote :

This new "admin: //" method did not work being changed in desktop entry.
The bug still remains in gdebi-gtk.

Revision history for this message
sr9000 (sr9000) wrote :

SUP, there is any information, how soon this bug will be fixed?
it's strange when u want install deb package from GUI but u NEED to open a terminal and start gdebi-gtk from CONSOLE to make it work properly with GUI. =/

Revision history for this message
Singtoh (singtoh) wrote :

A bit of a work around that worked for me is in the gdebi.desktop file where it says "Terminal=false" change it to "Terminal=true" minus the quotes of course. A "terminal window"(sort of) pops up behind the gdebi window and allows you to install, reinstall ect. Don't know but it installs packages for me in this way. A bit easier this way than pointing to the package you want to install through the terminal. Kind of works normal this way.


Revision history for this message
Hansaka Sandarwuan (hansand) wrote :

I Found a App called "Eddy" in app Store and it works fine to me.It can install .deb file Easily

Revision history for this message
Junaid Ahmed (hattingokbori87) wrote :

I've seen this problem in every recent Xubuntu release (17.10--19.04).

Revision history for this message
Paul Carissimo (bloodofjesus) wrote :

I'm on Parrot OS which is a rolling release of debian, this bug also affects me, I'm using XFCE.

An unobtrusive solution for me has been to edit /usr/share/applications/gdebi.desktop thus;

change :
       Exec=gdebi-gtk %f

   to :
       Exec=sh -c "gdebi-gtk %f"

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.