gdebi-gtk broken in 18.04 error: unable to read filedescriptor flags

Bug #1756238 reported by Mark-pcnetspec on 2018-03-16
88
This bug affects 15 people
Affects Status Importance Assigned to Milestone
gdebi (Ubuntu)
Medium
Unassigned
vte2.91 (Ubuntu)
High
Unassigned
Bionic
Undecided
Unassigned

Bug Description

When using gdebi-gtk to install a .deb the install fails with the message:-

dpkg: error: unable to read filedescriptor flags for <package status and progress file descriptor>: Bad file descriptor

This only occurs via the gdebi-gtk GUI front end, packages install perfectly if done via the CLI with:
sudo gdebi /path/to/packagename.deb

Simon Quigley (tsimonq2) on 2018-03-16
Changed in gdebi (Ubuntu):
importance: Undecided → Critical
status: New → Confirmed
Demetrius Lolos (dlolos1) wrote :

Same problem here using Ubuntu 18.04 beta 1. Did an update and now gdebit doesn't even ask for a password. But does work in terminal.

In my Ubuntu 18.04 Beta 1 the gdebi program does not install any deb packages, but when I click install package it crashes and closes. I am installing through dpkg on the terminal.

Mark-pcnetspec (mark-pcnetspec) wrote :

Any update on this ?

Jeremy Bicha (jbicha) wrote :

Maybe this is related to the fix for LP: #1719746 and the reason why the %f option was dropped in Ubuntu 17.10.

(I don't use gdebi and am not working on fixing this bug.)

Mark-pcnetspec (mark-pcnetspec) wrote :

No it's not that clicking the .deb doesn't fire up gdebi-gtk (it does), it's that gdebi-gtk crashes whilst installing the .deb throwing the error:-

dpkg: error: unable to read filedescriptor flags for <package status and progress file descriptor>: Bad file descriptor

Changing (or dropping) the %f option makes no difference :(

Jeremy Bicha (jbicha) wrote :

One other person suggested that updating vte from 0.50 to 0.52 triggered this bug
LP: #1758918

I haven't investigated that either.

Mark-pcnetspec (mark-pcnetspec) wrote :

Yep, definitely something in vte 0.52 because downgrading to 0.48 by installing these packages from artful:-

gir1.2-vte-2.91_0.48.4-0ubuntu1_amd64.deb
libvte-2.91-0_0.48.4-0ubuntu1_amd64.deb
libvte-2.91-0-udeb_0.48.4-0ubuntu1_amd64.udeb
libvte-2.91-common_0.48.4-0ubuntu1_all.deb

fixes the issue.

Mark-pcnetspec (mark-pcnetspec) wrote :

I may have gone overboard with libvte-2.91-0-udeb which isn't a default package so is unnecessary.

Jeremy Bicha (jbicha) on 2018-03-30
Changed in vte2.91 (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Egmont Koblinger (egmont-gmail) wrote :

I can reproduce the bug, and I also get the same (faulty) result with vanilla vte-0.48 compiled by me (that is, not the Ubuntu package, contrary to comment 7).

Jeremy, could you please test if bringing back 91_keep_fds.patch solves the issue? The error message sounds suspiciously related to what this patch was doing.

vte2.91 (0.51.90-1ubuntu1) bionic; urgency=medium
  [...]
  * Dropped change, apparently hasn't been needed for years:
    - Add 91_keep_fds.patch:
      + Keep file descriptors open on vte_fork_pty()

Yup, with manually compiled vte-0.53, this patch fixes the problem.

Which, of course, raises the question:

- Is gdebi doing something wrong? Is there an alternative approach provided by VTE, which gdebi should start using instead?
- Does VTE really lack a feature that is required by gdebi, so VTE should add?
- Did VTE perhaps reject adding this feature (if so, why?), hence the need for the patch?

Looks like 91_keep_fds.patch was something that never made it upstream when originally added.

vte (1:0.25.91-0ubuntu4) maverick; urgency=low

  * debian/patches/91_keep_fds.patch:
    - Update and return patch that hadn't been applied upstream (LP: #620297)
 -- Robert Ancell <email address hidden> Wed, 08 Sep 2010 17:57:18 +1000

Jeremy Bicha (jbicha) wrote :

Ok, I'm going to go ahead and restore the patch for now to fix gdebi.

Changed in vte2.91 (Ubuntu):
status: Confirmed → Fix Committed
Jeremy Bicha (jbicha) wrote :

Egmont, see https://bugzilla.gnome.org/show_bug.cgi?id=320128 (mentioned in the patch header).

for what it's worth, 91_keep_fds.patch fixes libvte-2.91-0 for me.

Ideally gdebi should be fixed not to rely on this patch. Obviously that's somewhat more work.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vte2.91 - 0.52.0-1ubuntu2

---------------
vte2.91 (0.52.0-1ubuntu2) bionic; urgency=medium

  * Restore 91_keep_fds.patch since gdebi still requires it (LP: #1756238)

 -- Jeremy Bicha <email address hidden> Sat, 31 Mar 2018 16:56:28 -0400

Changed in vte2.91 (Ubuntu):
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) on 2018-03-31
Changed in gdebi (Ubuntu):
importance: Critical → Medium
status: Confirmed → Triaged

vte2.91 (0.52.0-1ubuntu2) fixes it, thanks everyone.

Thanks for uploading the fix for this bug report to -proposed. However, when reviewing the package in -proposed and the details of this bug report I noticed that the bug description is missing information required for the SRU process. You can find full details at http://wiki.ubuntu.com/StableReleaseUpdates#Procedure but essentially this bug is missing some of the following: a statement of impact, a test case and details regarding the regression potential. Thanks in advance!

Iain Lane (laney) wrote :

This bug is Fix Released in bionic. The reference is only included in LP-Bugs-Fixed because I copied the previous merge entry and then built the source package with -v. Sorry that that's confusing.

(bug #1765389 is actually missing SRU information and I pinged Rico to add it.)

Hello Mark-pcnetspec, or anyone else affected,

Accepted vte2.91 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/vte2.91/0.52.2-1ubuntu1~18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in vte2.91 (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic

As far as I was concerned this bug was already fixed in:-

0.52.1-1ubuntu1

in the main repo, so I can't see any need for this in proposed now.

But just to answer your question anyway, YES:-

0.52.2-1ubunti1-18.04.1

also fixes the issue (though now it would likely be more accurate to say it doesn't regress the earlier fix).

Iain Lane (laney) on 2018-06-12
Changed in vte2.91 (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.