gdebi fails to install dependencies on Lubuntu 14.04

Bug #1306235 reported by Aere Greenway
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gdebi (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

I created a Debian package which is just a list of dependencies for using a software application I created that runs on Ubuntu Linux (all variants). The application itself is installed using icedtea (Java Web-Start). The dependencies package makes sure everything is in-place so that Java Web-Start can install the (Java) application.

On prior levels of Lubuntu, this worked. But on Lubuntu 14.04 (the beta release), it fails to install the dependencies.

The symptoms are, that it starts installing the package, and correctly reports the dependencies. When the user indicates to go ahead and install, fairly quickly, it reports an error, saying that the dependencies could not be installed, and that the user needs to enter "sudo apt-get install -f" in a terminal session. When that is done, the dependencies get installed.

In further testing it, it appears that if gdebi is run from with a terminal session, it actually works, and properly installs the dependencies.

However, if I right-click on the package file, requesting that it be opened with gdebi, it fails as described above.

On other Ubuntu variants, I open the package with the Software Center application, which does the installation. But on Lubuntu, the Lubuntu Software Center does not perform this function, and my only option is to use gdebi to install it.

I could document a list of packages for the user to manually install (which I formerly did), but installating a single package with a list of dependencies is much easier for the user.

I tried to report this on the actual Lubuntu 14.04 system, but apport doesn't appear to be working on that system.

So here is the summary:

gdebi in installing a package (that is just a list of dependencies) fails to install the dependencies.

I expected it to install the dependencies (as it did in Lubuntu levels prior to 14.04).

Revision history for this message
Aere Greenway (aere) wrote :

I have attached the Debian package for which gdebi failed to install the dependencies.

Revision history for this message
Aere Greenway (aere) wrote :

I thought perhaps some errors in the package might have caused this problem (though the same package worked on 13.10), so I analyzed the package using lintian. That did show some errors (not just warnings).

In looking at the errors, I solved the problem by re-building the package using fakeroot. After doing that, the lintian output indicates only 5 warnings (and no errors).

I retried the test on 14.04, installing the fixed package using gdebi (acting on a downloaded file from Firefox), but it still encounters the same error (won't load dependencies).

Revision history for this message
Aere Greenway (aere) wrote :

The above test was performed on Lubuntu 14.04, updated to the release level.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gdebi (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers