gdebi-gtk crashed with UnboundLocalError in dpkg_action(): local variable 'msg' referenced before assignment

Bug #1304274 reported by fdwsgds on 2014-04-08
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gdebi (Ubuntu)
Medium
Unassigned

Bug Description

I dont really know what happened gbut I want to help by reporting this error.
L14.04 all updates installled.

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: gdebi 0.9.5.2
ProcVersionSignature: Ubuntu 3.13.0-23.45-generic 3.13.8
Uname: Linux 3.13.0-23-generic x86_64
ApportVersion: 2.14.1-0ubuntu1
Architecture: amd64
Date: Tue Apr 8 10:34:34 2014
ExecutablePath: /usr/share/gdebi/gdebi-gtk
InstallationDate: Installed on 2014-04-03 (4 days ago)
InstallationMedia: Lubuntu 14.04 LTS "Trusty Tahr" - Daily amd64 (20140401)
InterpreterPath: /usr/bin/python3.4
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/bin/gdebi-gtk --non-interactive /home/victoria/Downloads/yumi_0.0.1-1_all.deb
PythonArgs: ['/usr/bin/gdebi-gtk', '--non-interactive', '/home/victoria/Downloads/yumi_0.0.1-1_all.deb']
SourcePackage: gdebi
Title: gdebi-gtk crashed with UnboundLocalError in dpkg_action(): local variable 'msg' referenced before assignment
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

fdwsgds (mubtcez) wrote :
information type: Private → Public
tags: removed: need-duplicate-check
Changed in gdebi (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gdebi (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdebi - 0.9.5.7

---------------
gdebi (0.9.5.7) unstable; urgency=medium

  [ Michael Vogt ]
  * GDebi/GDebiGtk.py:
    - fix child_exited() change for vte 2.91 (LP: #1472618)

  [ Dimitri John Ledkov ]
  * Fix exceptions going out of scope. (LP: #1304274)

 -- Michael Vogt <email address hidden> Wed, 08 Jul 2015 15:24:36 +0200

Changed in gdebi (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers