gdebi-gtk crashed with UnicodeDecodeError in commit(): 'utf-8' codec can't decode byte 0xc3 in position 0: unexpected end of data

Bug #1301857 reported by Josef Jansen
76
This bug affects 8 people
Affects Status Importance Assigned to Milestone
gdebi (Ubuntu)
Medium
Unassigned

Bug Description

can not install trueycrypt

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: gdebi 0.9.5
ProcVersionSignature: Ubuntu 3.13.0-21.43-generic 3.13.8
Uname: Linux 3.13.0-21-generic x86_64
ApportVersion: 2.14-0ubuntu1
Architecture: amd64
Date: Thu Apr 3 12:38:43 2014
ExecutablePath: /usr/share/gdebi/gdebi-gtk
InstallationDate: Installed on 2014-04-03 (0 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Daily amd64 (20140402)
InterpreterPath: /usr/bin/python3.4
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/bin/gdebi-gtk --non-interactive /media/josef/Trekstore/Laufwerk/Linux\ Software/gimagereader_0.9.1-1_all.deb
ProcEnviron:
 LANGUAGE=de_DE
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
 TERM=unknown
PythonArgs: ['/usr/bin/gdebi-gtk', '--non-interactive', '/media/josef/Trekstore/Laufwerk/Linux Software/gimagereader_0.9.1-1_all.deb']
SourcePackage: gdebi
Title: gdebi-gtk crashed with UnicodeDecodeError in commit(): 'utf-8' codec can't decode byte 0xc3 in position 0: unexpected end of data
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Revision history for this message
Josef Jansen (h-u-j-jansen) wrote :
tags: removed: need-duplicate-check
Changed in gdebi (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gdebi (Ubuntu):
status: New → Confirmed
Revision history for this message
Michael Vogt (mvo) wrote :

I can not reproduce the crash unfortunately, but I think the follow patch should fix the issue.

Michael Vogt (mvo)
Changed in gdebi (Ubuntu):
status: Confirmed → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdebi - 0.9.5.3

---------------
gdebi (0.9.5.3) unstable; urgency=low

  * convert only full lines from dpkg-statusfd into utf8 (LP: #1301857)

 -- Michael Vogt <email address hidden> Mon, 07 Apr 2014 10:12:02 +0200

Changed in gdebi (Ubuntu):
status: In Progress → Fix Released
information type: Private → Public
Revision history for this message
pvdeynse (vandeynse) wrote :

bug was fixed in the package gdebi - 0.9.5.3

but not fixed in the graphical version "gdebi-gtk"

 trying to install following package:

       gdebi-gtk eid-viewer_4.0.4r146_i386_tcm227-178471.deb

  Traceback (most recent call last):
    File "/usr/bin/gdebi-gtk", line 79, in <module>
      app = GDebiGtk(datadir=data,options=options,file=afile)
    File "/usr/share/gdebi/GDebi/GDebiGtk.py", line 151, in __init__
      self.open(file)
    File "/usr/share/gdebi/GDebi/GDebiGtk.py", line 300, in open
      self.label_maintainer.set_text(utf8(self._deb["Maintainer"]))
    File "/usr/share/gdebi/GDebi/DebPackage.py", line 39, in __getitem__
      return self._sections[item]
  UnicodeDecodeError: 'utf-8' codec can't decode byte 0xeb in position 10: invalid continuation byte

Revision history for this message
Wangermée Guy (wangermee-guy) wrote : Re: [Bug 1301857] Re: gdebi-gtk crashed with UnicodeDecodeError in commit(): 'utf-8' codec can't decode byte 0xc3 in position 0: unexpected end of data

Thanks.

On Sat, Apr 26, 2014 at 10:15 AM, pvdeynse <email address hidden> wrote:

> bug was fixed in the package gdebi - 0.9.5.3
>
> but not fixed in the graphical version "gdebi-gtk"
>
> trying to install following package:
>
> gdebi-gtk eid-viewer_4.0.4r146_i386_tcm227-178471.deb
>
> Traceback (most recent call last):
> File "/usr/bin/gdebi-gtk", line 79, in <module>
> app = GDebiGtk(datadir=data,options=options,file=afile)
> File "/usr/share/gdebi/GDebi/GDebiGtk.py", line 151, in __init__
> self.open(file)
> File "/usr/share/gdebi/GDebi/GDebiGtk.py", line 300, in open
> self.label_maintainer.set_text(utf8(self._deb["Maintainer"]))
> File "/usr/share/gdebi/GDebi/DebPackage.py", line 39, in __getitem__
> return self._sections[item]
> UnicodeDecodeError: 'utf-8' codec can't decode byte 0xeb in position 10:
> invalid continuation byte
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1303472).
> https://bugs.launchpad.net/bugs/1301857
>
> Title:
> gdebi-gtk crashed with UnicodeDecodeError in commit(): 'utf-8' codec
> can't decode byte 0xc3 in position 0: unexpected end of data
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/gdebi/+bug/1301857/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers