Please remove ddrescue from archive (replaced by gddrescue)

Bug #161126 reported by Inkwina on 2007-11-09
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
ddrescue (Debian)
Fix Released
Unknown
ddrescue (Ubuntu)
Wishlist
Unassigned
Declined for Dapper by Sebastien Bacher
Declined for Hardy by Sebastien Bacher
Declined for Jaunty by Sebastien Bacher
Declined for Karmic by Sebastien Bacher
Declined for Lucid by Sebastien Bacher
Declined for Maverick by Sebastien Bacher
gddrescue (Ubuntu)
Wishlist
Unassigned
Declined for Dapper by Sebastien Bacher
Declined for Hardy by Sebastien Bacher
Declined for Jaunty by Sebastien Bacher
Declined for Karmic by Sebastien Bacher
Declined for Lucid by Sebastien Bacher
Declined for Maverick by Sebastien Bacher

Bug Description

Binary package hint: ddrescue

ddrescue (provided in the package gddrescue) and dd_rescue are different pieces of software.
The package name should reflect which of these applications is installed as the current naming is confusing.

apt-get install ddrescue does not install ddrescue (from gddrescue) but dd_rescue.

Even dd-rescue would be a better name.

Ideally dd_rhelp (http://www.kalysto.org/utilities/dd_rhelp/index.en.html) should be included with dd_rescue.

maybe ddrescue could be a meta-package which depends on gddrescue, dd_rescue and dd_rhelp thus providing a variety of options for attempting data recovery.

This "bug" "affected" me as well. I couldn't find the real ddrescue, until I looked better. I thoughed gddrescue was a gnome utility for ddrescue, because of the name. Guess standard names makes you lazy. ;-)

I would like if this is solved as well, the way the reporter mentioned.

Daniel T Chen (crimsun) on 2008-11-13
Changed in ddrescue:
importance: Undecided → Wishlist
Changed in gddrescue:
importance: Undecided → Wishlist

Unfortunately there are 2 different ddrescue packages in Debian. One is dd_rescue from http://www.garloff.de/kurt/linux/ddrescue/ and the other is ddrescue from http://www.gnu.org/software/ddrescue/ddrescue.html. Neither of these homepages are described in their packages which was even more misleading. The gnu ddrescue author(s) agreed to change the name in debian as gddresque as described in this bug http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=316238 . On further review I think ddrescue hasn't had an update since 2007, versus gddrescue's last update this year. And last but not least the gnu ddrescue combines dd_rescue and dd_rhelp into one program which I think obsoletes the original dd_rescue. I'm going to report this to Debian's bug tracker as well.

actually the homepages are in the copyright files in their package, srry :/

I've just been looking around to see what's going on with this confusing naming scheme, and I've found this: http://packages.ubuntu.com/karmic/ddrescue. Here it says the package is called ddrescue, but then the description starts off with dd_rescue. Also, I've tried to find a package in ubuntu called dd_rescue and it appears that one doesn't exist.

Please can you reply to this comment and tell me if this bug is still a problem for you, because I can't seem to replicate it.

Changed in gddrescue (Ubuntu):
status: New → Incomplete
Changed in ddrescue (Ubuntu):
status: New → Incomplete
Endolith (endolith) wrote :

"maybe ddrescue could be a virtual package which depends on gddrescue, dd_rescue and dd_rhelp thus providing a variety of options for attempting data recovery."

I think that would make it even more confusing. Even the creator of dd_rescue and dd_rhelp recommends using GNU ddrescue as a replacement, if I recall.

Endolith (endolith) wrote :

The author of dd_rhelp:

"I really encourage you to use this replacement tool if it works for you (and it should be the case). ... It could be some cases where [Gnu] ddrescue won't work, and this is the major reason why I keep maintaining dd_rhelp."

description: updated

So would I be right in thinking that

1. There is a source package called ddrescue, which is in fact dd_rescue
2. ddrescue is a binary package installed be the source package gddrescue

?

Had a chat on IRC, and gddrescue only installs a binary package called gddrescue, so there should be no conflicts. If you feel that this bug is still a problem, then please reopen it and state why you believe that to be the case.

Changed in ddrescue (Ubuntu):
status: Incomplete → Invalid
Changed in gddrescue (Ubuntu):
status: Incomplete → Invalid
Endolith (endolith) wrote :

Why was this marked invalid??

See my previous comment. Basically, gddrescue is called gddrescue, and ddrescue is known as ddrescue or dd_rescue. I may have got the wrong end of the stick here, and if I have please could you explain to me why the problem still persists for you.

gddrescue installs a binary called ddrescue
ddrescue installs dd_rescue

gddrescue combines both dd_rescue and dd_rhelp into one program
ddrescue is no longer active

gddrescue deprecates ddrescue and I believe it's time to drop ddrescue from the repos.

This naming scheme seems like a problem to me.

Changed in ddrescue (Ubuntu):
status: Invalid → Confirmed
Changed in gddrescue (Ubuntu):
status: Invalid → Confirmed

If you look here https://edge.launchpad.net/ubuntu/karmic/+source/gddrescue it says that ggdrescue only installs a binary package called gddrescue.

If you look here https://edge.launchpad.net/ubuntu/karmic/+source/ddrescue it says that ddrescue only installs a binary package called ddrescue.

Those are just the binary packages name, not the actual name of the binary it creates.

So now we need to turn this bugreport into a removal request for ddrescue I presume.

How do you know the actual name of the binary it creates without installing it?

affects: debian → ddrescue (Debian)
Daniel Santos (daniel-santos) wrote :

As a note, in Gentoo they don't use underscores in package names, but they do use dashes. Therefore, the executable dd_rescue is packaged under dd-rescue and executable ddrescue is packaged under it's own name.

Changed in ddrescue (Debian):
status: New → Fix Released
Bryce Harrington (bryce) on 2012-05-14
summary: - Package name misleading
+ Please remove ddrescue from archive (replaced by gddrescue)
Changed in ddrescue (Ubuntu):
status: Confirmed → Triaged
Changed in gddrescue (Ubuntu):
status: Confirmed → Triaged
tags: added: precise quantal
Bryce Harrington (bryce) wrote :

I've been experimenting with dd_rescue (in ddrescue) for a few months and can confirm it works only for a small subset of cases that other tools (like dvdbackup or gddrescue) work.

I can definitely see that people looking for a "ddrescue" binary might get confused between the ddrescue and gddrescue, and end up using the wrong one. I don't know if that's bad enough to warrant diverging from debian on this, but I don't really see much value in keeping the ddrescue package when gddrescue seems to be better.

The debian bug alludes to functionality which is in ddrescue but not gddrescue. Might be worth doing a review of those features, possibly those functions exist in gddrescue by a different name, or are not relevant.

TomasHnyk (sup) wrote :

Out of these functions in ddrescue
       -r reverse direction copy (default=forward)
       -w abort on Write errors (default=no)
       -a spArse file writing (default=no)
       -A Always write blocks, zeroed if err (default=no)
       -i interactive: ask before overwriting data (default=no)
       -f force: skip some sanity checks (default=no)
gddrescue have at least
 -S, --sparse
              use sparse writes for output file
       -R, --reverse
              reverse direction of copy operations

It has a --force switcher, but I have no idea if it does the same as for ddrescue. So missing are those options (on packages from 12.04):

       -w abort on Write errors (default=no)
       -A Always write blocks, zeroed if err (default=no)
       -i interactive: ask before overwriting data (default=no)
       -f force: skip some sanity checks (default=no)

Bob Bib (bobbib) wrote :

Ubuntu Precise is the last release coming with Kurt Garloff's dd_rescue: https://launchpad.net/ubuntu/+source/ddrescue
Starting from Raring, there's only GNU ddrescue in Ubuntu repositories: https://launchpad.net/ubuntu/+source/gddrescue
Closed.

Changed in ddrescue (Ubuntu):
status: Triaged → Fix Released
Changed in gddrescue (Ubuntu):
status: Triaged → Fix Released
Bob Bib (bobbib) wrote :

> Starting from Raring
I meant Quantal, sorry.

tags: added: lucid
removed: quantal
tags: added: quantal
Bob Bib (bobbib) on 2013-11-25
Changed in ddrescue (Debian):
status: Fix Released → Unknown
Changed in ddrescue (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.