[FFe] gdb should be marked "Multi-arch: allowed"

Bug #1036834 reported by Mark Russell on 2012-08-14
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gdb (Ubuntu)
High
Adam Stokes
Precise
High
Adam Stokes

Bug Description

[Impact]
Marking gdb "Multi-arch: allowed" will allow 32-bit packages to depend on "gdb:any" and install successfully on 64-bit releases of Ubuntu from 11.04 onward

This package is a required dependency of some third party applications, such as Lotus Notes.

[Test Case]
Install a 32-bit package that depends on gdb:any and have it properly install gdb (which is multi-arch capable by nature).

[Regression Potential]
Regression minimal as this change applies to multi-arch status only. Packages can still depend on simply "gdb".

Can we make this change for precise?

Adam Stokes (adam-stokes) wrote :

Mark,

Could you attach a debdiff or link to a branch where you have these changes at?

Thanks,
Adam

Mark Russell (marrusl) wrote :

Hi Adam,
Here it is. Thanks.

Adam Stokes (adam-stokes) wrote :
Changed in gdb (Ubuntu):
assignee: nobody → Adam Stokes (adam-stokes)
status: New → In Progress
description: updated
Changed in gdb (Ubuntu):
importance: Undecided → Medium
Chris J Arges (arges) on 2012-09-19
Changed in gdb (Ubuntu):
importance: Medium → High
Changed in gdb (Ubuntu Precise):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Adam Stokes (adam-stokes)
Changed in gdb (Ubuntu Precise):
milestone: none → ubuntu-12.04.2
summary: - gdb should be marked "Multi-arch: allowed"
+ [FFe] gdb should be marked "Multi-arch: allowed"
James Page (james-page) wrote :

Already uploaded to precise-proposed; but I can't see this fixed in quantal yet and no FFe approval documented here?

Martin Pitt (pitti) wrote :

FWIW, I don't think this is a good SRU candidate -- precise's packages don't use gdb:any dependencies, so no need to SRU the M-A: allowed change. I sponsored the quantal change, will be in unapproved for the release team's consideration.

Please also file a Debian bug with this patch, so that we avoid a permanent delta for this.

Changed in gdb (Ubuntu):
status: In Progress → Fix Committed
Colin Watson (cjwatson) wrote :

I think this is fine for quantal, yes. FFe approved if that's considered necessary.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdb - 7.5-0ubuntu2

---------------
gdb (7.5-0ubuntu2) quantal; urgency=low

  [ Mark Russell ]
  * Add Multi-arch: allowed field to gdb. (LP: #1036834)
 -- Adam Stokes <email address hidden> Thu, 16 Aug 2012 14:29:05 -0400

Changed in gdb (Ubuntu):
status: Fix Committed → Fix Released
Mark Russell (marrusl) on 2012-10-10
description: updated
Adam Stokes (adam-stokes) wrote :

Martin,

As previously discussed and because of the SRU Impact I feel it is necessary to have this approved for Precise. Please let me know if you require more business justification.

Thanks,
Adam

Martin Pitt (pitti) wrote :

I did add a precise bug task and sponsor the precise fix:

  https://launchpad.net/ubuntu/precise/+queue?queue_state=4&queue_text=gdb

 But the SRU team rejected the upload for some reason that they didn't mention.

Colin Watson (cjwatson) wrote :

Actually, as far as I can tell what happened was that it was rejected from the release pocket just before release due to not being urgent enough to hold up 12.04 preparation, with the intent that it should be re-uploaded as an SRU. Somebody should do that.

Adam Stokes (adam-stokes) wrote :

Updated debdiff for precise to properly reflect only the m-a: allowed changes and not the build-deps

Iain Lane (laney) wrote :

Uploaded to precise-proposed: cheers!

Hello Mark, or anyone else affected,

Accepted gdb into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gdb/7.4-2012.04-0ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gdb (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Steve Langasek (vorlon) wrote :

I created a test package locally that depends on gdb:any and was able to successfully cross-install it on precise for testing purposes. I believe that confirms this fix.

tags: added: verification-donee
removed: verification-needed
tags: added: verification-done
removed: verification-donee

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gdb - 7.4-2012.04-0ubuntu2.1

---------------
gdb (7.4-2012.04-0ubuntu2.1) precise-proposed; urgency=low

  [ Mark Russell ]
  * Added Multi-arch: allowed field to gdb. (LP: #1036834)
 -- Adam Stokes <email address hidden> Tue, 06 Nov 2012 11:19:38 -0500

Changed in gdb (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers