Upgrade 11.10 to 12.04 failed on gconf2

Bug #962854 reported by Andreas Wenning on 2012-03-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gconf (Ubuntu)
High
Steve Langasek
Precise
High
Steve Langasek

Bug Description

Upgrade fails with:
subprocess installed post-installation script returned error exit status 250

This is the error from apt-term.log
Setting up gconf2 (3.2.5-0ubuntu1) ...

(gconftool-2:9066): GConf-CRITICAL **: No such file `/usr/lib/x86_64-linux-gnu/gconf/2/libgconfbackend-xml.so'

(gconftool-2:9066): GConf-WARNING **: Failed to load source "xml:readwrite:/var/lib/gconf/defaults": Failed: Couldn't locate backend module for `xml:readwrite:/var/lib/gconf/defaults'
**
GConf:ERROR:gconftool.c:969:main: assertion failed: (err == NULL)
dpkg: error processing gconf2 (--configure):
 subprocess installed post-installation script returned error exit status 250

tags: added: dist-upgrade
Jean-Baptiste Lallement (jibel) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please add the log files from '/var/log/dist-upgrade/' to this bug report as separate attachments? Thanks in advance.

Changed in update-manager (Ubuntu):
status: New → Incomplete
tags: added: oneiric2precise precise

The problem seems to be with gconf-service and multiarch.

gconf-service:amd64 and gconf-service:i386 can't be installed alongside - and for some reason the gconf-service:i386 was installed first (it is a x86_64 system). The files that gconf2 looks for is only available in gconf-service:amd64.

Changed in update-manager (Ubuntu):
status: Incomplete → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

Thanks for the logs. It it the same as bug 948294 which is marked 'Fix Released' setting to triaged.

affects: update-manager (Ubuntu) → gconf (Ubuntu)
Changed in gconf (Ubuntu):
importance: Undecided → High
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
tags: added: rls-mgr-p-tracking
Changed in gconf (Ubuntu Precise):
status: Confirmed → Triaged
Sebastien Bacher (seb128) wrote :

Seems like a side effect of the multiarch changes, Steve since you worked on that version could you have a look?

Changed in gconf (Ubuntu Precise):
assignee: Canonical Desktop Team (canonical-desktop-team) → Steve Langasek (vorlon)
status: Triaged → Confirmed
Steve Langasek (vorlon) wrote :

> Selecting previously unselected package gconf-service:i386.
> Unpacking gconf-service:i386 (from .../gconf-service_3.2.5-0ubuntu1_i386.deb) ...
[...]
> Setting up gconf-service:i386 (3.2.5-0ubuntu1) ...
> Setting up libgconf-2-4 (3.2.5-0ubuntu1) ...
> Setting up gconf2 (3.2.5-0ubuntu1) ...
>
> (gconftool-2:9066): GConf-CRITICAL **: No such file `/usr/lib/x86_64-linux-gnu/gconf/2/libgconfbackend-xml.so'
>
>
> (gconftool-2:9066): GConf-WARNING **: Failed to load source "xml:readwrite:/var/lib/gconf/defaults": Failed: Couldn't locate backend module for `xml:readwrite:/var/lib/gconf/defaults'
> **
> GConf:ERROR:gconftool.c:969:main: assertion failed: (err == NULL)
> dpkg: error processing gconf2 (--configure):
> subprocess installed post-installation script returned error exit status 250

This is two bugs. One is apt bug #850264, which we know we need to fix via SRU to oneiric. apt should always prefer gconf-service:amd64 here, and it's installing gconf-service:i386 instead.

The other is a bug in the gconf dependencies. gconf2 declares that it depends on the exact version of gconf-service, *but* gconf-service is marked Multi-Arch: foreign, allowing the dependency to be satisfied by a foreign version of the package when part of the package (the plugin) definitely has to be of the same arch as the rev-dep.

We could make gconf-service Multi-Arch: allowed and have gconf2 depend on gconf-service:any, except that doesn't work with the lucid apt.

Changed in gconf (Ubuntu Precise):
status: Confirmed → Triaged
Steve Langasek (vorlon) on 2012-03-23
Changed in gconf (Ubuntu Precise):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gconf - 3.2.5-0ubuntu2

---------------
gconf (3.2.5-0ubuntu2) precise; urgency=low

  * Split gconf-service further into gconf-service and gconf-service-backend,
    one package being Multi-Arch: foreign and the other Multi-Arch: none, so
    that we correctly handle the fact that gconf2 needs backend modules of
    the same arch whereas other reverse-dependencies just need a working
    daemon. LP: #962854.
 -- Steve Langasek <email address hidden> Fri, 23 Mar 2012 14:43:19 -0700

Changed in gconf (Ubuntu Precise):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers