gconfd-2 crashed with SIGABRT in __kernel_vsyscall()

Bug #882525 reported by discont on 2011-10-27
196
This bug affects 22 people
Affects Status Importance Assigned to Milestone
gconf
Fix Released
Medium
gconf (Ubuntu)
Medium
Canonical Desktop Team
Oneiric
Undecided
Unassigned

Bug Description

Fresh install of 11.10

0. Enable proposed updates. sudo apt-get update; sudo apt-get upgrade
1. sudo add-apt-repository ppa:bikooo/glippy
2. sudo apt-get install glippy
3. Apport reported about crash after successfull installation

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: libgconf2-4 3.2.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-13.21-generic-pae 3.0.6
Uname: Linux 3.0.0-13-generic-pae i686
ApportVersion: 1.23-0ubuntu4
Architecture: i386
Date: Thu Oct 27 15:45:42 2011
ExecutablePath: /usr/lib/libgconf2-4/gconfd-2
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
ProcCmdline: /usr/lib/libgconf2-4/gconfd-2
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
Signal: 6
SourcePackage: gconf
StacktraceTop:
 __kernel_vsyscall ()
 raise () from /lib/i386-linux-gnu/libc.so.6
 abort () from /lib/i386-linux-gnu/libc.so.6
 g_assertion_message () from /lib/i386-linux-gnu/libglib-2.0.so.0
 gconf_database_set_sources ()
Title: gconfd-2 crashed with SIGABRT in __kernel_vsyscall()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

discont (discont) wrote :

StacktraceTop:
 g_assertion_message (domain=0x805002b "GConf", file=0x804f733 "gconf-database.c", line=806, func=0x804f8a0 "gconf_database_set_sources", message=<optimized out>) at /build/buildd/glib2.0-2.30.0/./glib/gtestutils.c:1425
 gconf_database_set_sources (db=0x86e4768, sources=0x8798cb8) at gconf-database.c:806
 reload_databases () at gconfd.c:1346
 periodic_cleanup_timeout (data=0x0) at gconfd.c:1050
 g_timeout_dispatch (source=0x86e84f0, callback=0x804d060 <periodic_cleanup_timeout>, user_data=0x0) at /build/buildd/glib2.0-2.30.0/./glib/gmain.c:3907

Changed in gconf (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gconf (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
visibility: private → public
tags: added: regression-proposed
Marc Deslauriers (mdeslaur) wrote :

Caused by this commit:

http://git.gnome.org/browse/gconf/commit/?id=d7917514549f48297bc0032a7e2b54bfb17f7495

The assert probably shouldn't be there...

Changed in gconf:
importance: Unknown → Medium
status: Unknown → New
Jeremy Bicha (jbicha) on 2011-10-29
description: updated
discont (discont) on 2011-10-30
Changed in gconf (Ubuntu):
status: Confirmed → Invalid
status: Invalid → Confirmed
Changed in gconf (Ubuntu):
status: Confirmed → Triaged
Changed in gconf (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Marc Deslauriers (mdeslaur) wrote :

The regression was fixed in 3.2.3...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gconf - 3.2.3-0ubuntu1

---------------
gconf (3.2.3-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Fixes gconf crasher regression in 3.2.2 (LP: #882525)

gconf (3.2.2-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release.
    - Fixes gconf errors affecting GNOME Shell & Evolution, especially
      seen after a system upgrade (LP: #848198)
    - Build fix for -Werror=format-securiy
    - Avoid crash when there is no reply to messages in
      gconf_engine_notify_remove
    - Clean-up ORBit vs DBus logic
  * debian/watch: Removed extra \d
 -- Jeremy Bicha <email address hidden> Tue, 01 Nov 2011 08:48:09 -0400

Changed in gconf (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gconf (Ubuntu Oneiric):
status: New → Confirmed
Changed in gconf:
status: New → Fix Released

Hello discont, or anyone else affected,

Accepted gconf into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gconf (Ubuntu Oneiric):
status: Confirmed → Fix Committed
tags: added: verification-needed
Jeremy Bicha (jbicha) wrote :

Hello discont, or anyone else affected,

Accepted gconf into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

discont (discont) wrote :

No longer appears. Thanks

Martin Pitt (pitti) on 2011-11-03
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gconf - 3.2.3-0ubuntu0.1

---------------
gconf (3.2.3-0ubuntu0.1) oneiric-proposed; urgency=low

  * New upstream release.
    - Fixes gconf crasher regression in 3.2.2 (LP: #882525)

gconf (3.2.2-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release.
    - Fixes gconf errors affecting GNOME Shell & Evolution, especially
      seen after a system upgrade (LP: #848198)
    - Build fix for -Werror=format-securiy
    - Avoid crash when there is no reply to messages in
      gconf_engine_notify_remove
    - Clean-up ORBit vs DBus logic
  * debian/watch: Removed extra \d
 -- Jeremy Bicha <email address hidden> Tue, 01 Nov 2011 08:48:09 -0400

Changed in gconf (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.