gsettings-data-convert crashed with SIGSEGV in gconf_client_get_default()

Bug #810795 reported by Guy Stone on 2011-07-14
902
This bug affects 213 people
Affects Status Importance Assigned to Milestone
gconf (Ubuntu)
High
Martin Pitt
Oneiric
High
Martin Pitt

Bug Description

Like many of the other instances of "gsettings-data-convert crashed with SIGSEGV in gconf_client_get_default()" except Celeron and US english on ASUS eeePC900 with external KVM

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: gconf2 3.1.3-0ubuntu1
ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
Uname: Linux 3.0-3-generic i686
Architecture: i386
CrashCounter: 1
Date: Thu Jul 14 18:42:13 2011
ExecutablePath: /usr/bin/gsettings-data-convert
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110705.1)
ProcCmdline: gsettings-data-convert
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0xc2eb49: mov 0xc(%eax),%eax
 PC (0x00c2eb49) ok
 source "0xc(%eax)" (0x0000000c) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gconf
StacktraceTop:
 ?? () from /usr/lib/libgconf-2.so.4
 gconf_client_get_default () from /usr/lib/libgconf-2.so.4
 ?? ()
 __libc_start_main () from /lib/i386-linux-gnu/libc.so.6
 ?? ()
Title: gsettings-data-convert crashed with SIGSEGV in gconf_client_get_default()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Guy Stone (stoneguy3) on 2011-07-14
visibility: private → public
Jeffrey Tees (jeff-tees) wrote :

Error Occurred when manually running update manager after previous successful run and reboot following failed run resulting in broken packages (fixed with Package Manager).

Changed in gconf (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Changed in gconf (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)

Thank you for taking the time to report this crash and helping to make Ubuntu better. This particular crash has already been reported and is a duplicate of bug #737244, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

Alessandro Losavio (alo21) wrote :

i have the same problem

Nicolas DERIVE (kalon33) wrote :

Same problem, it doesn't seem to be hardware dependant, or occur on lots of different hardwares

Carla Sella (carla-sella) wrote :

I just did a update-manager -d to test Oneiric alpha 2 on my pc, but after rebooting I got a kernel panic, so I booted with a previous version of the kernel, as I logged screenlets crashed.
I had natty installed with all updates.

Carla Sella (carla-sella) wrote :

DistroRelease: Ubuntu 11.10
Linux 2.6.38-10-generic x86_64
Architecture: amd64

Carla Sella (carla-sella) wrote :
Sam_ (and-sam) wrote :

After recent updates and reboot, no crash of gsettings reported by apported.
Package gconf2-common is the same.
gconf2-common 3.1.3-0ubuntu1

Attached upgrade history.

Sam_ (and-sam) wrote :

Erratum: reported by apport

The error occurs when logging into unity. Jockey (jocket-text first, then jockey-common) does crash at the same time, if that is of any importance.

Sam_ (and-sam) wrote :

Reverse of #9, wondering why it didn't crash there.
Just booted again, login to unity via unity-greeter, apport reports crash, offering restart, after restart no further crash report.
syslog:
Jul 17 21:19:16 kernel: [ 71.258590] gsettings-data-[1791]: segfault at 18 ip 00007fee9df02571 sp 00007fff63702e50 error 4 in libgconf-2.so.4.1.5[7fee9deeb000+2d000]
Jul 17 21:19:16 gnome-session[1680]: WARNING: Application 'gsettings-data-convert.desktop' killed by signal
Jul 17 21:19:16 gnome-session[1680]: WARNING: App 'gsettings-data-convert.desktop' respawning too quickly
Jul 17 21:19:16 gnome-session[1680]: WARNING: Error on restarting session managed app: Component 'gsettings-data-convert.desktop' crashing too quickly

Sam_ (and-sam) wrote :

Crash happens randomly or better said only when system was shutdown and newly booted (cold boot).
Rebooted three times and no crash.

Martin Pitt (pitti) wrote :

Reproduces perfectly well with "gsettings-data-convert --verbose --dry-run", marking triaged.

Changed in gconf (Ubuntu Oneiric):
assignee: Canonical Desktop Team (canonical-desktop-team) → Martin Pitt (pitti)
importance: Medium → High
milestone: none → oneiric-alpha-3
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gconf - 3.1.3-0ubuntu2

---------------
gconf (3.1.3-0ubuntu2) oneiric; urgency=low

  * Add 00git_gsettings-data-convert_g_type_init.patch: Fix crash at startup
    in gsettings-data-convert. Also committed to upstream git. (LP: #810795)
 -- Martin Pitt <email address hidden> Mon, 18 Jul 2011 10:04:56 +0200

Changed in gconf (Ubuntu Oneiric):
status: Triaged → Fix Released
tags: removed: need-i386-retrace
Azmodeus (azmodeus) wrote :

azmodeus@ubi ~> gsettings-data-convert --verbose
File 'brasero.convert already converted, skipping
File 'gvfs-dns-sd.convert already converted, skipping
File 'gvfs-smb.convert already converted, skipping
File 'nautilus-sendto-convert already converted, skipping
File 'shotwell.convert already converted, skipping
File 'org.gnome.crypto.pgp.convert already converted, skipping
collecting settings for schema 'org.gnome.desktop.background'

GLib-GIO-ERROR **: Settings schema 'org.gnome.desktop.background' is not installed

aborting...
fish: Job 1, “gsettings-data-convert --verbose” terminated by signal SIGABRT (Abort)

https://launchpadlibrarian.net/65327266/login-error2.pnghttps://bugs.launchpad.net/ubuntu/+source/gconf2/+bug/726889/+attachment/1877839/+files/login-error2.png

chris_c (c-camacho) wrote :

ubuntu 12.04

running gconf-cleaner fixed this for me and resulted in 20 second quicker start of unity

DO have a terminal running, as when I ran the cleaner unity fell over...

To post a comment you must log in.