package gconf2 2.31.91-0ubuntu3 failed to install/upgrade: No such file or directory: '/usr/share/gconf/defaults/20-edubuntu'

Bug #633370 reported by j.purvis69 on 2010-09-08
66
This bug affects 6 people
Affects Status Importance Assigned to Milestone
edubuntu-artwork (Ubuntu)
Undecided
Unassigned
Maverick
Undecided
Unassigned
gconf (Ubuntu)
Medium
Unassigned
Maverick
Medium
Unassigned

Bug Description

Binary package hint: gconf

I got all these problems from the upgrade option to ubuntu 10.10 bete version

ProblemType: Package
DistroRelease: Ubuntu 10.10
Package: gconf2 2.31.91-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-20.29-generic 2.6.35.4
Uname: Linux 2.6.35-20-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Wed Sep 8 12:05:56 2010
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
SourcePackage: gconf
Title: package gconf2 2.31.91-0ubuntu3 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

TEST CASE
1. Create a non existent symlink in /usr/share/gconf/defaults
    $ sudo ln -s non_exitent_file /usr/share/gconf/defaults/99_non_existent_file
2. Reinstall gconf2
    $ sudo apt-get install --reinstall gconf2
3. Verify the gconf installs

j.purvis69 (j-purvis69) wrote :
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

The relevant error is
----
Setting up gconf2 (2.31.91-0ubuntu3) ...
Traceback (most recent call last):
  File "/usr/bin/update-gconf-defaults", line 161, in <module>
    read_entries(realname)
  File "/usr/bin/update-gconf-defaults", line 121, in read_entries
    for line in file(filename):
IOError: [Errno 2] No such file or directory: '/usr/share/gconf/defaults/20-edubuntu'
dpkg: error processing gconf2 (--configure):
 subprocess installed post-installation script returned error exit status 1

Setting to confirmed

Changed in gconf (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
summary: - package gconf2 2.31.91-0ubuntu3 failed to install/upgrade: subprocess
- installed post-installation script returned error exit status 1
+ package gconf2 2.31.91-0ubuntu3 failed to install/upgrade: No such file
+ or directory: '/usr/share/gconf/defaults/20-edubuntu'
Michael Vogt (mvo) wrote :

The 20-edubuntu file is part of edubuntu-artwork

Michael Vogt (mvo) wrote :

This is a dangling symlink from the previous package it seems, the lucid version has:

  echo "Setting desktop defaults ..."
  if [ -L /usr/share/gconf/defaults/20-edubuntu ]; then
        rm -f /usr/share/gconf/defaults/20-edubuntu
        ln -s /usr/share/edubuntu-artwork/gconf/$theme /usr/share/gconf/defaults/20-edubuntu
  else
        ln -s /usr/share/edubuntu-artwork/gconf/$theme /usr/share/gconf/defaults/20-edubuntu
  fi

Michael Vogt (mvo) wrote :

It looks like we have two issues here:
a) update-gconf-defaults should check if the file actually exists (for broken symlinks)
b) edubuntu-artwork needs remove the symlink

Michael Vogt (mvo) wrote :

For gconf I commited a fix to bzr and upload it to maverick (its in the queue) now.

Changed in gconf (Ubuntu Maverick):
status: Triaged → Fix Committed

Accepted edubuntu-artwork into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in edubuntu-artwork (Ubuntu Maverick):
status: New → Fix Committed
tags: added: verification-needed
Jonathan Carter (jonathan) wrote :

To test that it properly installed:

1. install updated edubuntu-artwork from -proposed
2. install a package that calles update-gconf-defaults (eg. apt-get --reinstall install gnome-panel-data)

Jonathan Carter (jonathan) wrote :

PS: or even using the gconf package as per the original report

Jonathan Riddell (jr) wrote :

Removed from maverick-proposed as requested

Stéphane Graber (stgraber) wrote :

Ok, after looking more closely at the issue, here are the details:

In Lucid /usr/share/gconf/defaults/20-edubuntu was a dangling symlink when doing a fresh install. Jonathan made an SRU to fix that just after release by fixing the symlink to point to somewhere that actually exists.

So after the SRU we basically had /usr/share/gconf/defaults/20-edubuntu being a symlink of /usr/share/edubuntu-artwork/gconf/default which itself is a symlink to /usr/share/gconf/defaults/20-edubuntu-artwork-settings

That means that both /usr/share/gconf/defaults/20-edubuntu and /usr/share/gconf/defaults/20-edubuntu-artwork-settings are the same file. That's not causing any gconf issue that we know of, it's just bad and will be fixed in Natty.

In Maverick, we no longer create /usr/share/gconf/defaults/20-edubuntu, only /usr/share/gconf/defaults/20-edubuntu-artwork-settings exists in the package.

So basically, the bug is only going to appear for someone who installed Edubuntu 10.04 and never upgraded their system. As our upgrade instructions include a system upgrade prior to doing a dist-upgrade, that bug isn't supposed to happen.

I still agree that 20-edubuntu should be removed for people upgrading but it's not causing any issue as long as the upgrade process is respected so it can and will be fixed in the first natty upload of edubuntu-artwork.

Marking the bug as Invalid. If I'm completely wrong, please feel free to re-open ;)

Changed in edubuntu-artwork (Ubuntu Maverick):
status: Fix Committed → Invalid
Martin Pitt (pitti) wrote :

Accepted gconf into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

SRU verification for Maverick:
I have reproduced the problem with gconf2 2.31.91-0ubuntu3 in maverick and have verified that the version of gconf2 2.31.91-0ubuntu3.1 in -proposed fixes the issue.

Marking as verification-done

description: updated
tags: added: verification-done
removed: verification-needed
Changed in gconf (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gconf - 2.31.91-0ubuntu3.1

---------------
gconf (2.31.91-0ubuntu3.1) maverick-proposed; urgency=low

  * debian/update-gconf-defaults:
    - check if a file exists before trying to read it, otherwise
      it crashes on broken symlinks (LP: #633370)
 -- Michael Vogt <email address hidden> Thu, 07 Oct 2010 12:02:13 +0200

Changed in gconf (Ubuntu Maverick):
status: Fix Committed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers