Ubuntu

"gconf-sanity-check-2 exited with status 256" on log in

Reported by Andy Pascall on 2010-05-08
86
This bug affects 17 people
Affects Status Importance Assigned to Milestone
gconf (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gconf

I get the error message: "There is a problem with the configuration server. (/usr/lib/libconf-2-4/gconf-sanity-check-2 exited with status 256)" every time I log into my computer. After I click "close" the desktop loads as normal.

This has been happening on all three of my computers since I upgraded to 10.04 LTS (using boht amd64 and i386 versions).

This is not caused by the permissions issues mentioned in bug #269215 as /etc/gconf/gconf.xml.system is chmodded 755 and /tmp is chmodded 1777.

Running "/usr/lib/libconf-2-4/gconf-sanity-check-2" from a terminal produces no output.

Attached is my .xsession-errors.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: libgconf2-4 2.28.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sat May 8 11:18:30 2010
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gconf

Andy Pascall (apascall) wrote :
wkulecz (walter-kulecz-1) wrote :

I got the same error message on a virgin 10.04 AMD 64-bit quad core install, except I'm stuck in an apparently infinite can't login in loop when I click close on the error dialog.

I had added a seperate partition to mount as /tmp before the reboot from today's updates, so on a hunch I shutdown, removed its power, and let the system boot by dismissing the mount error dialog and gnome came up OK.

Looks like some gconf state is being maintainted in /tmp across reboots. I thought this was bad practice as /tmp is supposed to be volitile.

--wally.

Sebastien Bacher (seb128) wrote :

Thank you for you bug report, most users don't get that issue, if you get it every time on every box you are using it's likely triggered by something you configure differently from the default installation on those

Changed in gconf (Ubuntu):
importance: Undecided → Low
ຄຳ (bz-datenkueche) wrote :

I have the same bug.

BUT I can't log in at all. The screen is black after login.
This happened on two completely different systems now.

My TWO computers are not useable anymore.

More details:

Siemens Amilo Pro v2035:
=====================

Before login:
"Es gibt ein Problem mit dem Konfigurationsserver
(/usr/lib/libgconf2-4/gconf-sanity-check-2 beendet mit Status 256)

When closing the message in the right lower korner a message appears that tells about an
error with energie management.

After login the sanity check error appears again. The screen is black. System completly unusable.

The problem is the same with gnome and kde.

It is possible to start xterm without window manager.
It's possible to start programs like firefox. But without window manager
that's not very usefull.

Starting metacity gives some gconf-key errors and
dies with
"metacity:ERROR:core/prefs.c:2495:meta_prefs_get_worksace_name: assertion failed
Aborted

ASUS EEE 1000H
===============

Same bug, but no xterm, no gnome, no kde.

------------

Importance should be urgent.

Bernhard

Andy Pascall (apascall) wrote :

Sebastien,

That seems logical. Any idea on where to look for an error message on what might be causing this?

Also, this only appeared on upgrade to lucid. I used the alternate CD and pulled in updated packages from the Internet during install.

Sebastien Bacher (seb128) wrote :

not really no, .xsession-errors could have errors

Andy Pascall (apascall) wrote :

Comparing the .xsession-errors between computers that have the problem and those that don't didn't yield anything. All seem to have a few errors in common, but there is no error that only shows up in the affected computers.

Does anyone know what exit status 256 of gconf-sanity-check-2 indicates? or where I might be able to find this info?

Andy Pascall (apascall) wrote :

Switching to tty2 and running "/usr/lib/libconf-2-4/gconf-sanity-check-2" produced a bunch of errors. One of which was that "/usr/local/etc/gconf/gconf.xml.default" could not be created.

Running: "sudo mkdir -p /usr/local/etc/gconf/gconf.xml.default" solved the issue for me.

The strange thing is that the computers where this wasn't an issue don't have "/usr/local/etc/gconf/gconf.xml.default" either.

Sebastien Bacher (seb128) wrote :

do you get the issue in a guest session? did you install something which could have changed the gconf path on your box?

ຄຳ (bz-datenkueche) wrote :

Maybe chromium/chrom beta is he source of the problem.
That's the only "exotic" software I had on both computers.

Andy Pascall (apascall) wrote :

ຄຳ -
I don't have chrome installed.

Sebastien-
I'll check out the guest session thing in a bit. As for the software, it turns out I have 2 affected computers and one that is not.

I ran "dpkg --get-selections" on all three. Then, I found which packages the 2 affected computers had in common and diff'ed that with the not affected computer. Attached is the result.

Andy Pascall (apascall) wrote :

Switching to the guest account after logging into a normal user account does not trigger the error.

Garry Leach (garry-leach) wrote :

I also get this message since I moved to 10.04, 6 weeks ago.

I did mention it in another bug (#580755: login screen locks up), which covers problems of more concern to me. However, I am the only subscriber, so I am not getting much (any?) attention.

Since I am able to boot up (although by a messy process), I have stopped worrying about exit status 256, but I would be happy to be able to resolve it.

I have checked the permissions on the various folders mentioned above, but they are all correct.

I am also subscribed to bug #554172, which seems to cover a range of problems associated with upstart; I wonder whether #577545 could be affected by upstart...

I would be willing to do some tests or whatever, but I don't have enough skill to know what to do.

Regards, Garry.

Hi Gerry,

try to change the permission of /tmp to 777.
( e.g. put "tmpfs /tmp tmpfs mode=1777 0 0" or somethinge like that to
your fstab. mode=1777 sets the permission.)
i have solved the problem on this way for my ubuntu 10.04.

good luck!

Am Freitag, den 25.06.2010, 00:16 +0000 schrieb Garry Leach:
> ct.

snowingplace (sweetyztt) wrote :

Hi sebbo,

Thank you for you sugestion! I have tried many methods. They all didn't work . But when I changed the permission of /tmp as you said , the problem had resloved .

Best regards,

Snow

sudo mkdir -p /usr/local/etc/gconf/gconf.xml.defaults
[note plural "defaults" rather than "default"]
fixed the problem for me too.
I got the same errors [apart from his typo] as Andy Pascall in tty running "/usr/lib/libconf-2-4/gconf-sanity-check-2" .
[Note running this in a GUI terminal will not work.]

Georg H (grhilsch) wrote :

Had the same problem after upgrading to Ubuntu 10.04. w/o any error when running "/usr/lib/libconf-2-4/gconf-sanity-check-2" in a terminal. Tried many things w/o success. Finally, #16 solved the problem for me too.

Brett Alton (brett-alton) wrote :

I have a friend that just installed Ubuntu 10.04.1 for the first time on his machine and this error came up. I will post details once I get a hold of his machine specs.

Garry Leach (garry-leach) wrote :

I added the line as proposed in #16, but it hasn't made any difference. By the way, is gconf.xml.defaults supposed to be a folder?

Going back to Sebastien Bacher's comment in #3. I have run the live CD on 2 other PCs (currently with Myth 9.10 installed) & they didn't exhibit any issues. Perhaps it needs to be installed before they show up. 2 of my sons have 10.04 installed & don't have any problems.

So these cases seem to support Sebastien's comment that there is something different/unusual about our configurations.

But as a mostly end-user, I am at a loss to know how to proceed to check anything.

I also seem to be a lone owner of another problem (bug #580755) that I can't boot other than via fail-safe. In a "normal" boot, my keyboard & mouse are disable after the first (few?) keystroke/s or mouse movement. Again, it would seem that there is something different/specific about my configuration.

I made a CD of 10.04.1, but I can't load it for the same reason.

On earlier live CD's, F4 enabled one to change to fail-safe mode, buts F4 on 10.04.1 does not provide fail-safe.

Can anyone suggest what I could check about my configuration, as a minimum for the gconf-sanity-check problem, but if it helps with the lock-up problem, that would be great.

Regards, Garry.

Molly Lumley (molly-lumley) wrote :

I'm having the same error message. I just installed 10.04 on my netbook. I sort of understand what I need to do to fix this, but could someone tell me EXACTLY what it is I need to do to change the /tmp file? I have no idea how to even access it. I think that the answer in post #16 would solve my problem, but I don't know how to do that.

If this helps, I am not able to boot Ubuntu at all; it doesn't make it past the login screen. I have it and its swap space installed in it own partitions separate from my Windows 7 starter partition. This is the first time I've ever used a Linux product but I really want to get it to work. I'm not familiar with a lot of this stuff, so if someone could let me know what I need to do to fix this, I would really appreciate it.

Attila Hammer (hammera) wrote :

I do now a clean installation with Ubuntu 10.04.1 64 bit version.

The problem is present my machine, but chmod 7777 /tmp command is resolving my problem.

Attila

armelp (armelp) wrote :

and how can I launch a command with chmod 7777 /tmp ?

I am a new user (first week-end) because I bought (to see) a Asus netbook with Ubuntu but without CD reader or manual or anthing... it was well running but now after the message "there is a problem of configuration server- /usr/lib/libconf2-4/gconf-sanity-check-2 exited with status 256" and after it cannot start so I have always the black screen and no opportunity to type a command. Only thing he says "problem with GNOME power system"

so I think to a guest who was curious and perhaps he dismounted the battery hardly ? could it be a clue ?

how could I reinstall ubuntu without CD intrance and without internet on this Asus ?

thanks to all contribuors on this rich server. (armel)

armelp (armelp) wrote :

as newbee in Linux, a friend explained me how to reload and now it's running

sorry for the disturb

Regards to all contributors (armel)

Matthew Sheffield (mes85) wrote :

I had this problem with only the status 256 error being displayed. After trying everything suggested in every forum I just ended up reinstalling Ubuntu 10.04 and now it works fine.
I think the best first step is to try and reinstall Linux and maybe do something different during setup. (For instance I was running a dual boot and this time I manually partitioned the drive instead of letting the disc auto partition. And I also used a different password.) If the problem still persists I suggest you try the other suggestions floating out there like the chmod thing. Also FYI, terminal can be reached by pressing Ctrl+Alt+F1 at login screen.

Garry Leach (garry-leach) wrote :

I had this problem in 10.04 (see post #13, plus a locked-PC problem).

I did a fresh install to 10.10 in November. I no longer have the locked-PC problem, but I still get status 256. It's not a serious problem, just irritating.

However, just recently, I made a USB-stick copy of 10.10, just so that my sister could run Gramps on her MS Windows PC.

When I want to boot up using the memory stick, I need to adjust the boot sequence in BIOS.

When I remove the stick, then boot to my normal desktop, I don't need to go into BIOS, because it knows that there is no memory stick. - BUT- I then don't get the status 256 message.

Does that give any expert a different perspective on the cause of the problem?

Regards, Garry.

Garry Leach (garry-leach) wrote :

Sorry, I forgot to include in my comment #25:

On subsequent boots, I still get status 256. It's only on the FIRST boot after booting from the memory stick, that it doesn't appear.

Regards, Garry.

tags: added: iso-testing
Chad A. Davis (chadadavis) wrote :

This also occurs on Natty when installing in expert mode.

Follow the test case described here to repeat this from the 'alternate' installer :
http://testcases.qa.ubuntu.com/Install/AlternateExpert

Brian Ssennoga (b-ssennoga) wrote :

Nice People,

I have had this problem for a month or so, so please forgive my frustration n exasperation if it shows up in my posts:

System: Ubuntu 10.04.1 Server, on Dell Optiplex330. Webmin+Squid+ an apt-mirror.

I have tried the following and still failed:
1. chmod 1777 /tmp (and its variants) - i notice, there is an orbit-gdm that is owned by gdm:gdm.
2. shorter password
3. reinstalling gdm
4. large amounts of sudo apt-get update && sudo apt-get upgrade followed by sudo reboot
5. have also tried:

[I]proxyadmin@proxy:~$ /usr/lib/libconf-2-4/gconf-sanity-check-2
-bash: /usr/lib/libconf-2-4/gconf-sanity-check-2: No such file or directory
proxyadmin@proxy:~$ /usr/lib/libconf2-4/gconf-sanity-check-2
-bash: /usr/lib/libconf2-4/gconf-sanity-check-2: No such file or directory[/I]

 and its intended solution:
[I]sudo mkdir -p /usr/local/etc/gconf/gconf.xml.defaults[/I]

This server (squid + mirror) is hosting crucial services and i really need to get it working. I need anyone who can wrap their head around this to help. Am attaching what necessary files -

please skype me (bssennoga) and also, help me understand if there is anything like: 10.04 Server 64-bit LiveCD!!! and where to get it.

stranded & frustrated, but ready to learn.

Sebastien Bacher (seb128) wrote :

those who workaround it with a local dir probably have a local build or configuration

Danl (landryd) wrote :

The previous message describes my situation exactly. We are trying to launch a 100+ seat ltsp upgrade, We have tried every suggested solution for this problem with no positive result. This bug was opened nearly 1 year ago and no successful solution has been found. A complete show stopper for us.

ferro (jschwender) wrote :

got the same issue with our ltsp upgrade to natty after customizing entries of gconf entried of the user gdm. Got it fixed by wiping /var/lib/gdm/* + restarting gdm service. Hope that helps.

Eli Flanagan (efffxed) wrote :

My experience with this bug has been after a clean install of 10.04. (Much of my preferences and previous files came from a 10.10 system though).

My /tmp directory has the appropriate permissions and I tried creating a directory as per post of this thread:
http://ubuntuforums.org/showthread.php?t=1061084&page=4
I also reinstalled gdm.

I created a new desktop user, and the error does not show for them.

For me this isn't a crashed-and-burned system, just mildly infuriating.

Changed in gconf (Ubuntu):
status: New → Confirmed
mdyn (tamerlaha-gmail) wrote :

affected me too, but chmod 777 /tmp resolve it. btw it resolve problem with notification applet missing.

This occurred to me after
1 dist upgrade from 8.04 to 10.04
2 apt-get clean
3 apt-get autoclean
4 some other cleanup involving booting up with a rescue CD, (and, critically, cleaning the /tmp directory) in order to tar up the image for future deployment in the field (20 laptops).

unable to log in to gdm, with the subject error present
used virt terminal 1 to log in

There was no directory /usr/local/etc/gconf/gconf.xml.defaults, as described in #16, adding this did not change the boot results.

checked the perms of /tmp, they were incorrect (v several working lucid systems). Changed them to 7777, and now the system reaches the gdm login screen with no errors (and I can log in)

reversing the change from #16 (rm -rf /usr/local/etc/gconf) resulted in the boot sequence stopping at the terminal screen (virt terminal 1) -- that is, no gdm login screen at all.

re-creating /usr/local/etc/gconf/gconf.xml.defaults allows normal booting.

so it seems both are necessary sometimes.

preetammn (preetammn) wrote :

making /tmp as readwrite solved my issue

there is a problem with config server
usr/lib/libcon2-4/gconf-sanity-check-2 exited with status 256

Thanks Am Freitag

Sebastien Bacher (seb128) wrote :

the recent comments suggest local issues rather than a gconf bug then

Jessie (iluminameluna) wrote :

All the above issues involve 10.04 but I'm running 10.10 from a 2G SDHC card (Kingston, if it matters) & it began showing the posted msg after I used GParted to try to re-partition my 2 SSDs AFTER I had already installed Natty & that installation began giving me errors abt my /root partition running out of space.

My specs: ASUS Eee PC 901 netbook (nvr knew what the orig config was & s/n label too faded to read) w/ 2 SSDs (4G & 16G); 2G RAM, 1.7Mhz (I think) Atom .

I've been messing around w/ different builds of Ubuntu & other flavors of Linux but none are installed @ the moment. For now, NO OS is installed, & as stated, I'm running Natty off a 2G flash card.

Also, @ log-in screen, a msg appears for about 30 secs: The configuration defaults for GNOME Power Manager have not been installed correctly. Contact your network administrator.

I am the only user.

Since this msg began appearing I can no longer Mount ANY drive (or unmount). I was trying to partition a flash card in order to update my OS & when I tried to Mount it in order to copy the *.ROM to it, I found I cldn't mount it. On a hunch, I tried to access the other drives (the SSDs) & found they were Unmount-able! The system sees them but I don't even try booting from them since I KNOW there's no OS installed.

I'm at a loss @ this point ... I'm not an experienced Linux user & have only experience using the GUI Terminal though I've taken note of how to access the "real" terminal, just haven't had the guts to do that yet.

Help!

Garry Leach (garry-leach) wrote :

Hi Jessie

Firstly, this bug does not seem to affect anything that I (as an end
user, like yourself) could detect. Clearing the message seemed enough
to be able to proceed with booting & using the PC.

I have now moved on to 11.10. This bug went away by 11.04. I don't
know how 11.10 would go in an eeePC, although it is supposed to be
designed as an all-round OS...

I use a desktop PC, so I can't comment on your eeePC issues, but it
sounds awful for you. One of my daughters has an original eeePC (the
small screen one). We haven't tried to change the OS, as it just keeps
on going (the speaker has died).

My understanding is that the ASUS version of the OS was tailored to the
HW - one of the reasons I didn't like to try a different version of
Ubuntu.

In spite of my lack of IT training, I am a volunteer in a computer
recycling depot (in Australia). We rebuild PCs if they are OK,
generally 5 year old, with Pentium 4 CPUs, using the Ubuntu OS. We are
finding that drivers for the older hardware are not always supported in
later versions of Ubuntu (we are working with 10.04).

Have you thought about trying one of the lighter versions of Linux? Or
and older version, particularly an LTS (long term support) version?

Regards, Garry.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers