Please merge gconf 3.2.6-4 (universe) from Debian unstable (main)

Bug #1696659 reported by Olivier Tilloy on 2017-06-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gconf (Ubuntu)
Wishlist
Unassigned

Bug Description

Please merge gconf 3.2.6-4 (universe) from Debian unstable (main).

Related branches

Olivier Tilloy (osomon) wrote :

* Merge from Debian unstable (LP: #1696659). Remaining changes:
  + don't package the gsettings backend since it's not meant to be distributed
  + debian/patches/02_xml-gettext-domain.patch: use gettext from schemas translations
  + debian/patches/05_nodisplay_autostart.patch: don't show in "Startup Applications"
  + debian/70gconfd_path-on-session, debian/gconf2-common.install: add additional gconf path depending on selected desktop session
  + debian/gconf-schemas:
    - convert to python3
    - encode and decode from UTF-8 to avoid postinst failing when schemas contain non ascii chars
    - shrink the generated %gconf-tree.xml, by filtering out locale specific defaults for uninstalled locales, leading tabs, empty short descriptions, and mtimes (which aren't interesting for system-wide defaults)
  + debian/update-gconf-defaults:
    - convert to python3
    - encode and decode from UTF-8 to avoid postinst failing when schemas contain non ascii chars
  + debian/gconf2.triggers, debian/gconf2.postinst, debian/gconf2.postrm: declare a new trigger on /usr/share/GConf/gsettings to watch when new gsettings convert files are installed
  + split gconf-service further into gconf-service and gconf-service-backend, one package being Multi-Arch: foreign and the other Multi-Arch: none, so that we correctly handle the fact that gconf2 needs backend modules of the same arch whereas other reverse-dependencies just need a working daemon
  + debian/patches/0001-Support-s-to-as-migrations-v2.patch: support 's' to 'as' migrations
  + debian/patches/call-dbus_g_thread_init.patch: Initialize dbus threads before doing anything. This fixes crashes in multithreaded applications that don't use libdbus directly.
  + debian/patches/pytwonisms.patch: fix gsettings-schema-convert pythonisms
  + debian/patches/reduce-polling.patch: call the cleanup routine every minute, instead of twice per minute, to reduce wakeups and therefore power usage
  + debian/rules:
    - updated for python3
    - call dh_python3 with --shebang=/usr/bin/python3
  + debian/{control,control.in}: updated for python3

Changed in gconf (Ubuntu):
assignee: Olivier Tilloy (osomon) → nobody
status: In Progress → Confirmed
Changed in gconf (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gconf - 3.2.6-4ubuntu1

---------------
gconf (3.2.6-4ubuntu1) artful; urgency=low

  * Merge from Debian unstable (LP: #1696659). Remaining changes:
    + don't package the gsettings backend since it's not meant to be
      distributed
    + debian/patches/02_xml-gettext-domain.patch: use gettext from schemas
      translations
    + debian/patches/05_nodisplay_autostart.patch: don't show in
      "Startup Applications"
    + debian/70gconfd_path-on-session, debian/gconf2-common.install: add
      additional gconf path depending on selected desktop session
    + debian/gconf-schemas:
      - convert to python3
      - encode and decode from UTF-8 to avoid postinst failing when schemas
        contain non ascii chars
      - shrink the generated %gconf-tree.xml, by filtering out locale specific
        defaults for uninstalled locales, leading tabs, empty short
        descriptions, and mtimes (which aren't interesting for system-wide
        defaults)
    + debian/update-gconf-defaults:
      - convert to python3
      - encode and decode from UTF-8 to avoid postinst failing when schemas
        contain non ascii chars
    + debian/gconf2.triggers, debian/gconf2.postinst, debian/gconf2.postrm:
      declare a new trigger on /usr/share/GConf/gsettings to watch when new
      gsettings convert files are installed
    + split gconf-service further into gconf-service and gconf-service-backend,
      one package being Multi-Arch: foreign and the other Multi-Arch: none, so
      that we correctly handle the fact that gconf2 needs backend modules of
      the same arch whereas other reverse-dependencies just need a working
      daemon
    + debian/patches/0001-Support-s-to-as-migrations-v2.patch: support 's' to
      'as' migrations
    + debian/patches/call-dbus_g_thread_init.patch: Initialize dbus threads
      before doing anything. This fixes crashes in multithreaded applications
      that don't use libdbus directly.
    + debian/patches/pytwonisms.patch: fix gsettings-schema-convert pythonisms
    + debian/patches/reduce-polling.patch: call the cleanup routine every
      minute, instead of twice per minute, to reduce wakeups and therefore
      power usage
    + debian/rules:
      - updated for python3
      - call dh_python3 with --shebang=/usr/bin/python3
    + debian/{control,control.in}: updated for python3

gconf (3.2.6-4) unstable; urgency=medium

  [ Raphael Geissert ]
  * update-gconf-defaults: add support for lists of integers (Closes: #833131)

  [ Jeremy Bicha ]
  * debian/control.in:
    - Depend on default-dbus-session-bus | dbus-session-bus instead of
      dbus-x11 (Closes: #835880)

 -- Olivier Tilloy <email address hidden> Thu, 08 Jun 2017 08:53:23 +0200

Changed in gconf (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers