please convert python scripts to python3

Bug #1440549 reported by Matthias Klose on 2015-04-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gconf (Ubuntu)
High
Didier Roche

Bug Description

There is still the goal to remove Python2 from the desktop images, and to use Python3 only. Please convert the two python scripts installed with the gconf2 package to Python3.

Sebastien Bacher (seb128) wrote :

Thanks

Changed in gconf (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Didier Roche (didrocks) on 2015-04-10
Changed in gconf (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
status: Confirmed → Fix Committed
Didier Roche (didrocks) wrote :

Please see the fix I attached to it.

Matthias, did you have a FFe on this for vivid? Otherwise, that can wait vivid+1.

On 04/10/2015 04:19 PM, Didier Roche wrote:
> Please see the fix I attached to it.
>
> Matthias, did you have a FFe on this for vivid? Otherwise, that can wait
> vivid+1.

this can wait, I only uploaded packages which actually fix dependencies, not
converting anything to python3.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gconf - 3.2.6-3ubuntu2

---------------
gconf (3.2.6-3ubuntu2) wily; urgency=medium

  [ Didier Roche ]
  * Convert update-gconf-defaults and gconf-schemas to python3 (LP: #1440549)
  * debian/{rules,control}: updated for python3

 -- Steve Langasek <email address hidden> Wed, 10 Jun 2015 18:51:15 -0700

Changed in gconf (Ubuntu):
status: Fix Committed → Fix Released
Bryan Quigley (bryanquigley) wrote :

I still a python(2) dependency.. Am I missing something?

Changed in gconf (Ubuntu):
status: Fix Released → Opinion
status: Opinion → Incomplete
Robert Ancell (robert-ancell) wrote :

This seems to be causing failures when the files contain non valid ASCII, see bug 1406641 and bug 1504442

Didier Roche (didrocks) wrote :

The python2 dependency on gconf2 binary package is due to the fact that migrations scripts are using #!/usr/bin/env python, which is what was adviced by the ubuntu python maintainers so that the day default python is changing, we'll get the correct default version.

dh_python3 is then, adding this python2 dependency. It means that day python3 is the default, a simple package rebuild will be needed.
Considering back this bug as "fix released" as nothing has to be done in gconf itself.

Changed in gconf (Ubuntu):
status: Incomplete → Fix Released
Matthias Klose (doko) wrote :

No, you misunderstand dh-python. It won't rewrite shebangs from python to python3.

Changed in gconf (Ubuntu):
status: Fix Released → New
Matthias Klose (doko) wrote :

please use dh_python3 --shebang=/usr/bin/python3 explicitly

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gconf - 3.2.6-3ubuntu5

---------------
gconf (3.2.6-3ubuntu5) wily; urgency=medium

  * Call dh_python3 with --shebang=/usr/bin/python3. LP: #1440549.

 -- Matthias Klose <email address hidden> Fri, 16 Oct 2015 16:34:16 +0200

Changed in gconf (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers