Ubuntu

2-click mode drops pieces

Reported by matli on 2011-05-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gcompris
Fix Released
Undecided
Unassigned
gcompris (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gcompris

My young kids prefer to use the "2 clicks" mode when playing GCompris on a laptop without a mouse in those games where you need to drag and drop pieces, for example in "Locate the Countries" or Chronos.

In recent versions of the game this has become problematic, especially on computers with more modest graphics hardware. The problem is that the piece being moved may lag behind the mouse pointer when moving the pointer too fast (which isn't fast at all on my laptop, and at least reproducible on a Core i7 with Geforce 460 graphics). As soon as the piece lags behind so much that the pointer gets located outside the bounding box of the piece, the piece stops following the pointer, and rests at the current location until the pointer is placed on it again.

This behaviour was not present in older versions, but I can reproduce it in at least versions 9.0-0ubuntu7 and 9.3-1ubuntu2. This is unfortunately a definite showstopper for acceptance from my kids.

The bug is present in at least Ubuntu 10.04 and 11.04.

matli (ml-launchpad) on 2011-05-04
description: updated
matli (ml-launchpad) wrote :

This seems to be a problem in the upstream version. I have investigated the problem further and found a possible soultion. See the attached patch, which has also been sent upstream.

matli (ml-launchpad) wrote :

The proposed fix was applied upstream

Changed in gcompris:
status: New → Fix Committed
tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gcompris - 9.3-1.1ubuntu2

---------------
gcompris (9.3-1.1ubuntu2) oneiric; urgency=low

  * Apply patch from Mattias Lindblad resolving 2-click mode dropping
    pieces. (LP: #777349) Patch applied upstream in git changeset
    83850c4. Thanks, Mattias!
 -- Daniel T Chen <email address hidden> Sun, 21 Aug 2011 19:36:04 -0400

Changed in gcompris (Ubuntu):
status: New → Fix Released
Daniel T Chen (crimsun) on 2011-08-21
Changed in gcompris:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

  • auto-gcompris-devel Edit

Bug watches keep track of this bug in other bug trackers.