gcompris crashed with SIGSEGV in gc_board_get_current()

Bug #625301 reported by Steven Lamb on 2010-08-27
38
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gcompris (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gcompris

ubuntu 10.10

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: gcompris 9.3-1
ProcVersionSignature: Ubuntu 2.6.35-19.26-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic i686
Architecture: i386
Date: Fri Aug 27 23:04:09 2010
ExecutablePath: /usr/games/gcompris
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Release i386 (20100429.4)
ProcCmdline: gcompris
ProcEnviron:
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x8053dfb <gc_board_stop+11>: mov 0x4(%eax),%edx
 PC (0x08053dfb) ok
 source "0x4(%eax)" (0x00000004) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gcompris
StacktraceTop:
 gc_board_get_current ()
 ?? ()
 ?? () from /usr/lib/libgtk-x11-2.0.so.0
 g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
 ?? () from /usr/lib/libgobject-2.0.so.0
Title: gcompris crashed with SIGSEGV in gc_board_get_current()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Steven Lamb (slamb-linuxmail) wrote :

StacktraceTop:
 gc_board_get_current () at board.c:213
 _gtk_marshal_BOOLEAN__BOXED (closure=0x88366f0,
 ?? () from /usr/lib/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
 g_signal_emitv () from /usr/lib/libgobject-2.0.so.0

Changed in gcompris (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

visibility: private → public
Changed in gcompris (Ubuntu):
status: New → Triaged
Charlie Kravetz (charlie-tca) wrote :

This bug is also present in a fresh Xubuntu 10.10 installation on a 64bit athlon system . Unfortunately, it does create a core dump on my computer. Gcompris is not usable with this issue.

ccaaatt (ccaaatt) wrote :

Bug #656888, this is nouveau driver,
Bug #647876, this is nvidia driver

ccaaatt (ccaaatt) wrote :

Bug #656888, and Bug #647876, this are IBUS-CRITICAL **: in XsessionErrors.txt

Oops,iBus

ccaaatt (ccaaatt) wrote :

I delete iBus, install fcitx.
now gcompris OK.

ccaaatt (ccaaatt) on 2011-09-13
Changed in gcompris (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers