regressions in libjava testsuite on arm-linux

Bug #593564 reported by Matthias Klose on 2010-06-14
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gcc
Fix Released
Medium
binutils (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
gcj-4.4 (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned

Bug Description

PR libgcj/40860 results in a gcj on armel with a broken stack unwinder, breaking the openjdk stage2 build on armel, and probably other gcj based builds.

fixed in maverick and unstable, no problems seen with the patch until now.

Matthias Klose (doko) on 2010-06-14
Changed in binutils (Ubuntu Lucid):
status: New → In Progress
Changed in gcj-4.4 (Ubuntu Lucid):
status: New → In Progress
Changed in binutils (Ubuntu):
status: New → Fix Released
Changed in gcj-4.4 (Ubuntu):
status: New → Fix Released
Changed in gcc:
status: Unknown → Fix Released

Accepted binutils into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in binutils (Ubuntu Lucid):
status: In Progress → Fix Committed
tags: added: verification-needed
Matthias Klose (doko) wrote :

ld now handles --no-merge-exidx-entries on armel, gcj-4.4 test build succeeds

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package binutils - 2.20.1-3ubuntu6

---------------
binutils (2.20.1-3ubuntu6) lucid-proposed; urgency=low

  * Apply proposed patch for ARM: Add option to disable merging of adjacent
    exidx unwinder entries. Addresses PR libgcj/40860. LP: #593564.
  * Fix PR gold/10893, IFUNC support for gold backported from the trunk.
    LP: #582754.
 -- Matthias Klose <email address hidden> Mon, 14 Jun 2010 10:18:35 +0200

Changed in binutils (Ubuntu Lucid):
status: Fix Committed → Fix Released
Jonathan Riddell (jr) wrote :

gcj-4.4 now in lucid-proposed unapproved queue awaiting approved from ubuntu-sru.

Patch needed on this bug.

test case needed on this bug.

On 29.06.2010 15:40, Jonathan Riddell wrote:
> gcj-4.4 now in lucid-proposed unapproved queue awaiting approved from
> ubuntu-sru.
>
> Patch needed on this bug.

see the debdiff.

> test case needed on this bug.

openjdk-6 two stage build

Accepted gcj-4.4 into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gcj-4.4 (Ubuntu Lucid):
status: In Progress → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Martin Pitt (pitti) wrote :

How can this be tested/verified?

Matthias Klose (doko) wrote :

> How can this be tested/verified?

by comparing the test results?
by a two stage openjdk-6 build?

but we'll need a fix for #608143 too.

Matthias Klose (doko) on 2010-07-28
Changed in gcj-4.4 (Ubuntu):
status: Fix Released → In Progress
Jonathan Riddell (jr) wrote :

New upload seems to be in lucid-proposed unapproved queue. Needs debdiff on this bug. Needs test case. Needs approval from ubuntu-sru.

Matthias Klose (doko) wrote :

see the results of the testsuite for the "testcase"

John Dong (jdong) wrote :

ACK from SRU team.

Jonathan Riddell (jr) wrote :

Accepted gcj-4.4 into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

Any testers of the lucid-proposed package?

Matthias, is this fixed in natty? If so, please close the task.

Matthias Klose (doko) wrote :

see
http://launchpadlibrarian.net/53900525/buildlog_ubuntu-lucid-armel.gcj-4.4_4.4.3-1ubuntu4_FULLYBUILT.txt.gz
for the testsuite results.

it is "fixed" in natty in the same way, building gcj for arm mode, not thumb.

Changed in gcj-4.4 (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gcj-4.4 - 4.4.3-1ubuntu4

---------------
gcj-4.4 (4.4.3-1ubuntu4) lucid-proposed; urgency=low

  * Target armv6 on ARM (armv7 implies thumb mode). LP: #593564.

gcj-4.4 (4.4.3-1ubuntu3) lucid-proposed; urgency=low

  * Fix PR libgcj/40860, handle --no-merge-exidx-entries (ARM). LP: #593564.
 -- Matthias Klose <email address hidden> Wed, 28 Jul 2010 16:12:51 +0200

Changed in gcj-4.4 (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in gcc:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.