patches for cgo on arm64

Bug #1361946 reported by Michael Hudson-Doyle on 2014-08-27
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gccgo-5 (Ubuntu)
High
Michael Hudson-Doyle
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned
gccgo-go (Ubuntu)
Medium
Michael Hudson-Doyle
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned

Bug Description

Hi,

I am attaching 5 patches that together with https://bugs.launchpad.net/ubuntu/+source/gcc-4.9/+bug/1361940 enable cgo to work on arm64 with gccgo. The patches are all rather small and could probably be rolled up into fewer, but well.

Cheers,
mwh

Michael Hudson-Doyle (mwhudson) wrote :
description: updated

The attachment "0001-cmdcgo.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Michael Hudson-Doyle (mwhudson) wrote :

that which is not tested is broken etc. here's a fixed version of the makefile

James Page (james-page) wrote :

Hi Michael

Does arm64 need to be added to the pointer size map in src/cmd/cgo/main.go?

Michael Hudson-Doyle (mwhudson) wrote :

Yes. How did I not include that patch, I wonder...

Here's that patch. Are you waiting on anything else? Would be nice to get these changes into utopic.

Ah, we need one more patch. This one is a bit of a hack but with all of these (as seen at the packages in https://launchpad.net/~mwhudson/+archive/ubuntu/gccgo-cgo/+packages) it does actually work (enough to build docker with some hacks to docker).

James Page (james-page) on 2015-01-22
Changed in gccgo-go (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Matthias Klose (doko) wrote :

Michael, please check and submit these patches for gccgo-5 as well.

Changed in gccgo-5 (Ubuntu):
importance: Undecided → High
status: New → Incomplete
assignee: nobody → Michael Hudson-Doyle (mwhudson)
Matthias Klose (doko) wrote :

now fixed in gccgo-5 in vivid.

Changed in gccgo-5 (Ubuntu):
status: Incomplete → Fix Released
Matthias Klose (doko) wrote :

gccgo-go is removed in vivid, superseded by gccgo-5

Changed in gccgo-go (Ubuntu):
status: Triaged → Invalid

Turns out these changes are required to do SRU verification for 1361940, so I've reapplied them and made a debdiff.

Changed in gccgo-go (Ubuntu):
status: Invalid → In Progress
Changed in gccgo-go (Ubuntu Trusty):
status: New → In Progress
Changed in gccgo-go (Ubuntu Utopic):
status: New → Invalid
Changed in gccgo-go (Ubuntu):
assignee: nobody → Michael Hudson-Doyle (mwhudson)

Better debdiff (better formatting, deleted two hunks that confusingly had no effect)

Chris J Arges (arges) wrote :

Before doing the SRU can you verify this works on Xenial?

Matthias Klose (doko) wrote :

no, not directly. gccgo-go isn't in the distro anymore, intgrated into gccgo-5. confirmed to work.

Chris J Arges (arges) on 2015-12-02
Changed in gccgo-go (Ubuntu):
status: In Progress → Invalid
Changed in gccgo-go (Ubuntu Trusty):
status: In Progress → Fix Committed

Hello Michael, or anyone else affected,

Accepted gccgo-go into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gccgo-go/1.2.1-0ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gccgo-go - 1.2.1-0ubuntu1.2

---------------
gccgo-go (1.2.1-0ubuntu1.2) trusty-proposed; urgency=medium

  * SRU: #1361940.
  * Backport some changes from pre-release vivid (LP: #1361946):
    - Build and install the cgo tool
    - In the go tool, look for the cgo tool where it is installed (and do not
      attempt to rebuild it, ever) and enable cgo by default on ppc64le.
    - In the cgo tool itself, support arm64 and ppc64le.

 -- Michael Hudson-Doyle <email address hidden> Fri, 27 Nov 2015 09:39:19 +1300

Changed in gccgo-go (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gccgo-go has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Robie Basak (racb) wrote :

Claimed regression caused by this update in bug 1527020.

I think the regression will be fixed when gccgo from bug 1361940 migrates.

Rolf Leggewie (r0lf) on 2016-04-24
Changed in gccgo-5 (Ubuntu Utopic):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers