Needs tar/xattr support to build docker

Bug #1542080 reported by dann frazier
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gccgo-4.9 (Ubuntu)
Confirmed
High
Unassigned
Trusty
In Progress
High
dann frazier

Bug Description

[Impact]
docker.io does not build on archs that require gccgo.

[Test Case]
Build docker.io in trusty on an arch that requires gccgo. I used arm64.
(Also need patch in LP: #1510288)

[Regression Risk]
This is an upstream patch that applies cleanly (other than file tree rearrangements), and it is adding new functionality.

Tags: patch
Revision history for this message
dann frazier (dannf) wrote :
Revision history for this message
dann frazier (dannf) wrote :
Changed in gccgo-4.9 (Ubuntu Trusty):
status: New → Triaged
tags: added: patch
dann frazier (dannf)
Changed in gccgo-4.9 (Ubuntu Trusty):
assignee: nobody → dann frazier (dannf)
importance: Undecided → Critical
importance: Critical → High
status: Triaged → In Progress
Revision history for this message
dann frazier (dannf) wrote :

I prepared a docker PPA with this update and asked our QA team to run some tests on it. Even though the binary builds and runs, we're still seeing docker crashes based on the older version of gccgo in trusty, so it still doesn't make sense to enable docker for gccgo in trusty at this time.

A fix for this is pending in the SRU queue - I'll ask an SRU team member to reject.

Revision history for this message
Chris J Arges (arges) wrote :

Are you wanting gccgo-4.9 4.9.3-0ubuntu5 rejected from the trusty queue?

Revision history for this message
dann frazier (dannf) wrote : Re: [Bug 1542080] Re: Needs tar/xattr support to build docker

On Wed, Mar 23, 2016 at 6:01 AM, Chris J Arges
<email address hidden> wrote:
> Are you wanting gccgo-4.9 4.9.3-0ubuntu5 rejected from the trusty queue?

Yes.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers