proposed update to gcc-4.3.3

Bug #237544 reported by Matthias Klose
8
Affects Status Importance Assigned to Milestone
gcc-snapshot (Ubuntu)
Fix Released
Undecided
Unassigned
Hardy
Fix Released
Undecided
Unassigned
Intrepid
Fix Released
Undecided
Unassigned

Bug Description

Binary package hint: gcc-snapshot

the current gcc-snapshot package in hardy is taken from the gcc-4_3-branch. Proposing to update this package to the final gcc-4.3.3.

Revision history for this message
Matthias Klose (doko) wrote :
Revision history for this message
Luke Yelavich (themuso) wrote :

ACK.

Changed in gcc-snapshot:
status: New → Confirmed
Revision history for this message
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

Changed in gcc-snapshot:
status: New → Fix Committed
Revision history for this message
Martin Pitt (pitti) wrote :

Intrepid is already newer:

gcc-snapshot | 20080611-0ubuntu1 | intrepid/universe | source, amd64, hppa, i386, ia64, lpia, sparc

Changed in gcc-snapshot:
status: Confirmed → Fix Released
Revision history for this message
Matthias Klose (doko) wrote :

the compiler is usable, checked the results of the testsuite, which do match those of the gcc-4.3 packages in intrepid.

Revision history for this message
Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in gcc-snapshot:
status: Fix Committed → Fix Released
Revision history for this message
Martin Pitt (pitti) wrote :

Whoops, pressed Enter too fast. I didn't copy this, since it failed to build. Looks like this needs another upload.

Changed in gcc-snapshot:
status: Fix Released → Triaged
Revision history for this message
Martin Pitt (pitti) wrote :

Accepted into hardy-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gcc-snapshot:
status: Triaged → Fix Committed
Matthias Klose (doko)
description: updated
Revision history for this message
Martin Pitt (pitti) wrote :

Any testers on this? I'll pull it from -proposed next week if it doesn't get any testing, since it's been over three months already.

Revision history for this message
Matthias Klose (doko) wrote : Re: [Bug 237544] Re: proposed update to gcc-4.3.3

Martin Pitt schrieb:
> Any testers on this? I'll pull it from -proposed next week if it doesn't
> get any testing, since it's been over three months already.

what do you need for testing? package installs, doesn't show unexpected results
in the testsuite. not sure what should be tested more for a snapshot package.

  Matthias

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gcc-snapshot - 20081013-0ubuntu2

---------------
gcc-snapshot (20081013-0ubuntu2) hardy-proposed; urgency=low

  * Re-add build dependency on gnat.

gcc-snapshot (20081013-0ubuntu1) hardy-proposed; urgency=low

  * Update to SVN 20081013 from the gcc-4_3-branch. LP: #237544.
  * Update packaging from the gcc-4.3 trunk.
  * Fix package build for ada components.

 -- Matthias Klose <email address hidden> Thu, 16 Oct 2008 10:47:10 +0200

Changed in gcc-snapshot:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers