libasan0 : AddressSanitizer CHECK failed

Bug #1786391 reported by Moses Moore on 2018-08-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gcc-4.8 (Ubuntu)
Undecided
Unassigned

Bug Description

Code that worked in Ubuntu 16.04 LTS does not work in Ubuntu 18.04.1.
(I tried to report this bug for package "libasan0" but bugs.launchpad.net sends me hto gcc-4.8)

$ mp3gain --help
==8893== AddressSanitizer CHECK failed: ../../../../src/libsanitizer/asan/asan_rtl.cc:411 "((!asan_init_is_running && "ASan init calls itself!")) != (0)" (0x0, 0x0)
    #0 0x7f287806d0cd (/usr/lib/x86_64-linux-gnu/libasan.so.0.0.0+0x120cd)
    #1 0x7f2878073eb3 (/usr/lib/x86_64-linux-gnu/libasan.so.0.0.0+0x18eb3)
    #2 0x7f287806e088 (/usr/lib/x86_64-linux-gnu/libasan.so.0.0.0+0x13088)
    #3 0x7f2878063fb9 (/usr/lib/x86_64-linux-gnu/libasan.so.0.0.0+0x8fb9)
    #4 0x7f28780701f2 (/usr/lib/x86_64-linux-gnu/libasan.so.0.0.0+0x151f2)
    #5 0x7f287b001aa7 (/lib/x86_64-linux-gnu/ld-2.27.so+0x17aa7)
    #6 0x7f287aff53eb (/lib/x86_64-linux-gnu/ld-2.27.so+0xb3eb)
    #7 0x7f2877a32da5 (/lib/x86_64-linux-gnu/libc-2.27.so+0x166da5)
    #8 0x7f28774aa0e3 (/lib/x86_64-linux-gnu/libdl-2.27.so+0x10e3)
    #9 0x7f2877a332de (/lib/x86_64-linux-gnu/libc-2.27.so+0x1672de)
    #10 0x7f2877a3336e (/lib/x86_64-linux-gnu/libc-2.27.so+0x16736e)
    #11 0x7f28774aa734 (/lib/x86_64-linux-gnu/libdl-2.27.so+0x1734)
    #12 0x7f28774aa165 (/lib/x86_64-linux-gnu/libdl-2.27.so+0x1165)
    #13 0x7f2878078b3b (/usr/lib/x86_64-linux-gnu/libasan.so.0.0.0+0x1db3b)
    #14 0x7f287806bff3 (/usr/lib/x86_64-linux-gnu/libasan.so.0.0.0+0x10ff3)
    #15 0x7f287806da3a (/usr/lib/x86_64-linux-gnu/libasan.so.0.0.0+0x12a3a)
    #16 0x7f287affa805 (/lib/x86_64-linux-gnu/ld-2.27.so+0x10805)
    #17 0x7f287afeb0c9 (/lib/x86_64-linux-gnu/ld-2.27.so+0x10c9)

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: libasan0 4.8.5-4ubuntu8
ProcVersionSignature: Ubuntu 4.15.0-29.31-generic 4.15.18
Uname: Linux 4.15.0-29-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
CurrentDesktop: XFCE
Date: Thu Aug 9 23:04:04 2018
Dependencies:
 gcc-4.8-base 4.8.5-4ubuntu8
 gcc-8-base 8-20180414-1ubuntu2
 libc6 2.27-3ubuntu1
 libgcc1 1:8-20180414-1ubuntu2
InstallationDate: Installed on 2016-06-05 (795 days ago)
InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
SourcePackage: gcc-4.8
UpgradeStatus: Upgraded to bionic on 2018-04-27 (104 days ago)

Moses Moore (moses-ubuntu) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers