FFe: upload gcc-4.8 to raring

Bug #1159547 reported by Matthias Klose on 2013-03-24
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gcc-4.7 (Ubuntu)
Undecided
Unassigned
Raring
Undecided
Unassigned

Bug Description

[filed for gcc-4.7, because gcc-4.8 isn't yet available in LP]

Proposing to upload gcc-4.8 to raring (as packaged in the ubuntu-toolchain-r/test PPA).

Rationale: Make gcc-4.8 available to developers in the latest Ubuntu release for development purposes. GCC-4.8 will become the default GCC in the s-series, and the next LTS release, so exposing this earlier to (not only Ubuntu) developers might be good idea. This is not a proposal to make gcc-4.8 the default at this point (well, maybe except for gccgo, which doesn't have any reverse build dependencies). http://gcc.gnu.org/gcc-4.8/changes.html shows the list of changes.

The runtime libraries in GCC didn't bump soversions in 4.8 (except for libgo and libgcj). These are the packages then built from the gcc-4.8 sources instead of the gcc-4.7 sources. The compilers stay the same.

The proposal includes updating the gcc-4.8 package to a 4.8.1 release as a stable release update for raring.

I'm running a raring desktop with the binaries installed from the gcc-4.8 source package since January without problems. Same for armhf build environments.

Matthias Klose (doko) on 2013-03-24
Changed in gcc-4.7 (Ubuntu Raring):
milestone: none → ubuntu-13.04-beta-1
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gcc-4.7 (Ubuntu):
status: New → Confirmed
Steve Langasek (vorlon) wrote :

For such a major change so close to release, I think it's important that we get more testing that one user's desktop before upload. If you could coordinate with the community team to get some user testing of the new libraries organized, then I think this could go in.

Matthias Klose (doko) wrote :

too late, will provide the package in the ubuntu-toolchain-r/test PPA

Changed in gcc-4.7 (Ubuntu Raring):
status: Confirmed → Won't Fix
Matthias Klose (doko) wrote :

and the gcc-snapshot package in raring is gcc-4.8

Matthias Klose (doko) on 2013-07-15
Changed in gcc-4.7 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers