gcc-4.7 causes libcmis FTBFS on armhf, regression against 4.6

Bug #1146903 reported by Björn Michaelsen on 2013-03-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gcc-4.7 (Ubuntu)
Undecided
Unassigned
libcmis (Ubuntu)
Undecided
Unassigned

Bug Description

see:

 https://launchpadlibrarian.net/132896096/buildlog_ubuntu-raring-armhf.libcmis_0.3.1-1ubuntu1_FAILEDTOBUILD.txt.gz

note that the libcmis version we currently have in the archive (0.3.0-1~ubuntu2) fails running those tests too -- but the package did not run those back then yet (tests were initially disabled as they did run all kind of networking tests, however this can be disabled in ./configure now).

Building and testing the package with gcc 4.6 works just fine on armhf.

This is blocking LibreOffice updates as we need libcmis-0.3.1 in main, please advise if we shall:
- build LibreOffice with an internal copy of libcmis
- disable the tests on libcmis as we did before
to keep moving there? Note that we are not breaking something additional by any of those as it is already broken in the archive.

Matthias Klose (doko) on 2013-03-05
tags: added: ftbfs

It seems like using CXXFLAGS=-O0 works around the issue. As libcmis is not that performance relevant we could do that on armhf for quick mitigation. Thanks doko for the hint.

Changed in libcmis (Ubuntu):
status: New → In Progress
Changed in libcmis (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libcmis - 0.3.1-1ubuntu2

---------------
libcmis (0.3.1-1ubuntu2) raring; urgency=low

  * build with -O0 on armhf because of compiler bug (LP: #1146903)
 -- Bjoern Michaelsen <email address hidden> Tue, 05 Mar 2013 23:12:42 +0100

Changed in libcmis (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers