gcc-4.7-multilib dependencies broken on powerpc

Bug #1100894 reported by Colin Watson on 2013-01-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gcc-4.7 (Ubuntu)
Undecided
Unassigned

Bug Description

 Package: gcc-4.7-multilib
 Version: 4.7.2-2ubuntu1
 Architecture: powerpc
 Depends: gcc-4.7-base (= 4.7.2-2ubuntu1), gcc-4.7 (= 4.7.2-2ubuntu1), libc6-dev-ppc64 (>= 2.11), lib64gcc1 (>= 1:4.7.2-2ubuntu1), lib64gomp1 (>= 4.7.2-2ubuntu1)

But:

 Package: gcc-4.7-multilib
 Version: 4.7.2-18ubuntu1
 Architecture: powerpc
 Depends: gcc-4.7-base (= 4.7.2-18ubuntu1), gcc-4.7 (= 4.7.2-18ubuntu1), libc6-dev (>= 2.11), lib64gcc-4.7-dev (= 4.7.2-18ubuntu1)

The lack of libc6-dev-ppc64 is the cause of
https://launchpadlibrarian.net/128715489/buildlog_ubuntu-raring-powerpc.libffi_3.0.11-2ubuntu1_FAILEDTOBUILD.txt.gz.

This is inconsistent with other architectures: for example, on i386 gcc-4.7-multilib correctly depends on libc6-dev-amd64.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gcc-4.7 - 4.7.2-19ubuntu1

---------------
gcc-4.7 (4.7.2-19ubuntu1) raring; urgency=low

  * Merge with Debian; remaining changes:
    - Build from upstream source.

gcc-4.7 (4.7.2-19) experimental; urgency=low

  * Update to SVN 20130117 (r195280) from the gcc-4_7-branch.
    - Fix PR target/55974 (AVR), PR fortran/55072, PR fortran/55618,
      PR libstdc++/52887, PR fortran/55983.
    - Backport multiarch patches.
  * Update the Linaro support to the 4.7-2013.01 release.

  * Don't call dh_shlibdeps for staged cross builds. These packages
    are never shipped, and the information is irrelevant.
  * Don't ship libiberty.a in gcc-4.7-hppa64. Closes: #659556.
  * Fix dependency on the non-default multilib libc-dev. LP: #1100894.
 -- Matthias Klose <email address hidden> Thu, 17 Jan 2013 21:47:02 +0100

Changed in gcc-4.7 (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers