command not found data outdated due to stale mirror

Bug #1062043 reported by MarekH on 2012-10-05
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
command-not-found (Ubuntu)
High
Unassigned
Quantal
High
Unassigned
gcc-4.7 (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

Freshly installed Ubuntu: 12.10-beta2, later updated amd64

=======================
1.

g++ symlink not created in /usr/bin directory, when the package g++-4.7 was manually install (sudo apt-install g++-4.7)

Remedy: sudo ln -s /usr/bin/g++-4.7 /usr/bin/g++
========================

2.

g++ is usually not installed as usually.

Entering g++ in terminal suggests only pentium-builder package, which unfortunately does not provide installation of any package that contains g++

========================

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: g++-4.7 4.7.2-2ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-17.26-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
ApportVersion: 2.6.1-0ubuntu1
Architecture: amd64
Date: Fri Oct 5 08:15:22 2012
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Beta amd64 (20120926)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=sk_SK.UTF-8
 SHELL=/bin/bash
SourcePackage: gcc-4.7
UpgradeStatus: No upgrade log present (probably fresh install)

MarekH (mhycko) wrote :
Matthias Klose (doko) wrote :

install g++, or build-essential. command-not-found should not suggest pentium-builder

Changed in gcc-4.7 (Ubuntu):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in command-not-found (Ubuntu):
status: New → Confirmed
Michael Vogt (mvo) wrote :

Turns out that the data for command-not-found on i386, amd64 is unreliable as the mirror in use on bignay is not updated since some weeks.

Changed in command-not-found (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → High
Michael Vogt (mvo) wrote :

The archive mirror on bignay is syncing now once that is done a new extract can be done.

summary: - no symlink for g++ is created when g++-4.7 package manually installed
+ command not found data outdated due to stale mirror
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package command-not-found - 0.3ubuntu5

---------------
command-not-found (0.3ubuntu5) quantal; urgency=low

  * updated for the RC release, re-scan archive now that the internal
    archive mirror is up-to-date again
  * blacklist pentium-builder (LP: #1062043)
 -- Michael Vogt <email address hidden> Tue, 09 Oct 2012 13:39:27 +0200

Changed in command-not-found (Ubuntu Quantal):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers