ICE in arm_select_dominance_cc_mode, at config/arm/arm.c:10625

Bug #943264 reported by Matthias Klose on 2012-02-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro GCC
Won't Fix
Medium
Michael Collison
gcc
Fix Released
Medium
gcc-4.6 (Debian)
Fix Released
Unknown
gcc-4.6 (Ubuntu)
Medium
Unassigned

Bug Description

seen with 4.5 and 4.6 with -O1. Other optimization levels don't show the ICE.

$ gfortran -c -O1 -fpermissive -Wfatal-errors -w fbasics_gss-min.f
fbasics_gss-min.f: In function 'deval':
fbasics_gss-min.f:39:0: internal compiler error: in arm_select_dominance_cc_mode, at config/arm/arm.c:11474
Please submit a full bug report,
with preprocessed source if appropriate.

trunk 20120107 has a different ICE:
$ /usr/lib/gcc-snapshot/bin/gfortran -c -O1 -fpermissive -Wfatal-errors -w fbasics_gss-min.f
fbasics_gss-min.f:139:0: internal compiler error: vector VEC(tree,base) index domain error, in ipa_get_indirect_edge_target at ipa-cp.c:1115
Please submit a full bug report,
with preprocessed source if appropriate.

Matthias Klose (doko) wrote :
Changed in gcc-4.6 (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
In , Doko-v (doko-v) wrote :

Created attachment 26784
test case

seen with 4.5 and 4.6 with -O1. Other optimization levels don't show the ICE.

$ gfortran -c -O1 -fpermissive -Wfatal-errors -w fbasics_gss-min.f
fbasics_gss-min.f: In function 'deval':
fbasics_gss-min.f:39:0: internal compiler error: in arm_select_dominance_cc_mode, at config/arm/arm.c:11474
Please submit a full bug report,
with preprocessed source if appropriate.

trunk 20120107 has a different ICE:
$ /usr/lib/gcc-snapshot/bin/gfortran -c -O1 -fpermissive -Wfatal-errors -w fbasics_gss-min.f
fbasics_gss-min.f:139:0: internal compiler error: vector VEC(tree,base) index domain error, in ipa_get_indirect_edge_target at ipa-cp.c:1115
Please submit a full bug report,
with preprocessed source if appropriate.

Changed in gcc:
importance: Unknown → Medium
status: Unknown → New
Changed in gcc-4.6 (Debian):
status: Unknown → New
Asa Sandahl (asa-sandahl) wrote :

Thank you for the bug report. I've confirmed this with gcc-linaro-4.6-2012.02 on ARM:

/home/asa-san/bugs/cbuild/slaves/ursa4/gcc-linaro-4.6-2012.02 gfortran -c -O1 -fpermissive -Wfatal-errors -w fbasics_gss-min.f
fbasics_gss-min.f: In function 'deval':
fbasics_gss-min.f:39:0: internal compiler error: in arm_select_dominance_cc_mode, at config/arm/arm.c:11452
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://gcc.gnu.org/bugs.html> for instructions

The work-around is to compile at -O2.

The fault exists in all versions of gcc-linaro-4.6 and gcc-linaro-4.5 that I have tried, from 2011.04 and forward on.
The fault also exists in gcc-4.5.3 and gcc-4.6.2.

On trunk there is another error message, as stated in the ticket. However, this error does not go away when switching to -O2 or -03. The work around in this case is to compile at -O0.
Running the test over a few older versions of 4.7 shows that the behavior changed somewhere along the way.

Old error message still shows on 177688:
/tools/toolchains/arch/armv7l/gcc-4.7~svn177688-armv7l-natty-cbuild161-ursa1-cortexa9r1 gfortran -c -O1 -fpermissive -Wfatal-errors -w fbasics_gss-min.f
fbasics_gss-min.f: In function 'deval':
fbasics_gss-min.f:39:0: internal compiler error: in arm_select_dominance_cc_mode, at config/arm/arm.c:10902
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://gcc.gnu.org/bugs.html> for instructions.

The new message is seen on 182152:
/tools/toolchains/arch/armv7l/gcc-4.7~svn182152-armv7l-natty-cbuild212-tcpanda02-cortexa9r1 gfortran -c -O1 -fpermissive -Wfatal-errors -w fbasics_gss-min.f
fbasics_gss-min.f:139:0: internal compiler error: vector VEC(tree,base) index domain error, in ipa_get_indirect_edge_target at ipa-cp.c:1115
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://gcc.gnu.org/bugs.html> for instructions.

The same error occurs at -O2 (and -O3).
/tools/toolchains/arch/armv7l/gcc-4.7~svn182152-armv7l-natty-cbuild212-tcpanda02-cortexa9r1 gfortran -c -O2 -fpermissive -Wfatal-errors -w fbasics_gss-min.f
fbasics_gss-min.f:139:0: internal compiler error: vector VEC(tree,base) index domain error, in ipa_get_indirect_edge_target at ipa-cp.c:1115
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://gcc.gnu.org/bugs.html> for instructions.

Further investigation will show if this is question of two different errors.

I've set this ticket to medium priority as it is a ftbfs, there is a work-around and the error probably exists upstream.

Changed in gcc-linaro:
status: New → Triaged
importance: Undecided → Medium

Will not fix. Does not occur with linaro 4.8 or 4.9.

Changed in gcc-linaro:
assignee: nobody → Michael Collison (michael-collison)
status: Triaged → Won't Fix

I can't reproduce this with 4.8.3, 4.9.1 or 4.10 trunk.

Is this still an issue?

In , Doko-v (doko-v) wrote :

yes, can't reproduce anymore with 4.9 and trunk

Changed in gcc:
status: New → Fix Released
Changed in gcc-4.6 (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.