gdb crashed with ImportError in /usr/lib/i386-linux-gnu/libstdc++.so.6.0.16-gdb.py: No module named libstdcxx.v6.printers

Bug #908163 reported by Fabio Duran Verdugo
72
This bug affects 8 people
Affects Status Importance Assigned to Milestone
gcc-4.6 (Ubuntu)
Undecided
Unassigned

Bug Description

debugging one app

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: gdb 7.3.1-2011.12-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-6.12-generic 3.2.0-rc6
Uname: Linux 3.2.0-6-generic i686
ApportVersion: 1.90-0ubuntu1
Architecture: i386
Date: Fri Dec 23 12:48:44 2011
ExecutablePath: /usr/bin/gdb
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
ProcCmdline: gdb --batch --ex file\ /usr/bin/gedit --ex core-file\ /tmp/tmpRzwEXc --ex set\ backtrace\ limit\ 2000 --ex p\ -99 --ex bt\ full --ex p\ -99 --ex thread\ apply\ all\ bt\ full --ex p\ -99 --ex info\ registers --ex p\ -99 --ex x/16i\ $pc --ex p\ -99 --ex print\ (char*)\ __abort_msg
SourcePackage: gdb
Title: gdb crashed with ImportError in /usr/lib/i386-linux-gnu/libstdc++.so.6.0.16-gdb.py: No module named libstdcxx.v6.printers
Traceback:
 Traceback (most recent call last):
   File "/usr/lib/i386-linux-gnu/libstdc++.so.6.0.16-gdb.py", line 59, in <module>
     from libstdcxx.v6.printers import register_libstdcxx_printers
 ImportError: No module named libstdcxx.v6.printers
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare vboxusers

Revision history for this message
Fabio Duran Verdugo (fabioduran) wrote :
tags: removed: need-duplicate-check
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gdb (Ubuntu):
status: New → Confirmed
Matthias Klose (doko)
visibility: private → public
Matthias Klose (doko)
affects: gdb (Ubuntu) → gcc-4.6 (Ubuntu)
Changed in gcc-4.6 (Ubuntu):
status: Confirmed → In Progress
Revision history for this message
Matthias Klose (doko) wrote :

fixed in precise

Changed in gcc-4.6 (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
SRombauts (sebastien-rombauts) wrote :

Bug #952999 says that there is the same kind issue for /usr/lib/debug/usr/lib/i386-linux-gnu/libstdc++.so.6.0.16-gdb.py

Where can we find the fix please ?

Revision history for this message
Nick Leverton (nick-leverton) wrote :

Still happening in Precise, see #952999. This occurs every time the crash reporter tries to invoke gdb for a backtrace. DrKonqui can get backtraces quite happily so I'm not sure what the difference is.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers